ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - DTSMA passthru problem Z170 Gaming-ITX/ac (solved)
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

DTSMA passthru problem Z170 Gaming-ITX/ac (solved)

 Post Reply Post Reply
Author
Message
10k View Drop Down
Newbie
Newbie


Joined: 14 Oct 2015
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote 10k Quote  Post ReplyReply Direct Link To This Post Topic: DTSMA passthru problem Z170 Gaming-ITX/ac (solved)
    Posted: 14 Oct 2015 at 7:51am
Hello, I have just bought an Asrock Fatal1ty Z170 Gaming-ITX/ac for use in HTPC with a new 4K OLED supporting HDMI 2.0 and 4k resolution at 60hz.

I have the PC hooked up via HDMI2 to my Marantz nr1605 receiver which is hooked up to my LG 65EF9500 OLED at 4k resolution 60hz refresh rate.

My problem is that in windows sound properties it correctly shows my marantz avr as supporting DTS-HD and DTS-MA formats, however when I try and pass those formats to the receiver I get no sound. 

This setup worked previously when I had an NVIDIA gtx950 driving things so I suspect that there is potentially something wrong with the asrock hdmi implementation.

Does anyone have any idea or solution?

Thanks


Edited by 10k - 18 Oct 2015 at 5:24am
Back to Top
10k View Drop Down
Newbie
Newbie


Joined: 14 Oct 2015
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote 10k Quote  Post ReplyReply Direct Link To This Post Posted: 18 Oct 2015 at 5:17am
In case anyone gets here from Google.  I did further testing and can confirm that the HDMI2 (hdmi 2.0) port on the Asrock Fatal1ty Z170 Gaming ITX/ac motherboard does not support hd audio format passthrough (dts-hd dolby TrueHD). 

I connected another HDMI cable to the HDMI1 port and set windows to use that as the default audio device.  HD audio passthrough began working immediately after that.

Hopefully this is something Asrock can address with a future firmware update.
Back to Top
mrlanz View Drop Down
Newbie
Newbie


Joined: 01 Nov 2015
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote mrlanz Quote  Post ReplyReply Direct Link To This Post Posted: 01 Nov 2015 at 8:42pm
I'm interested to know about your video setup. Do you have 4k@60Hz with deep color working? And if so did you updated the MC2800 firmware to make it work? And finally how did you verify that it was running deep color?
Back to Top
10k View Drop Down
Newbie
Newbie


Joined: 14 Oct 2015
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote 10k Quote  Post ReplyReply Direct Link To This Post Posted: 04 Nov 2015 at 3:54am
Yes, I updated firmware updated to latest when I got the board last month and had not tried 4k60hz before the update.  If 4k 60hz rgb 4:4:4 is working, then deep color is working as it can not work otherwise.

As an aside, I found the spec sheet for the MDCP2880 chip that provides HDMI 2.0, and DTS HD and Dolby TrueHD are absent from the list of audio formats supported
http://www.megachips.us/products/documents/MCDP28x0_Databrief.pdf


Back to Top
berry131 View Drop Down
Newbie
Newbie


Joined: 06 Sep 2016
Location: NL
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote berry131 Quote  Post ReplyReply Direct Link To This Post Posted: 06 Sep 2016 at 2:30am

@10k: did send you a pm about the HD passtrough issue

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.078 seconds.