ASRock.com Homepage
Forum Home Forum Home > OverClocking(OC) Zone > OC Technical Discussion
  New Posts New Posts RSS Feed - B450 Gaming K4 + Ryzen APU
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

B450 Gaming K4 + Ryzen APU

 Post Reply Post Reply Page  12>
Author
Message
speedphlux View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Dec 2018
Location: Bulgaria
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote speedphlux Quote  Post ReplyReply Direct Link To This Post Topic: B450 Gaming K4 + Ryzen APU
    Posted: 05 Dec 2018 at 3:41am
Hi there,

Recently saved up a bit of cash and went on to buy myself a new PC. Ended up with the following components :

AMD Ryzen 5 2400G
ASRock B450 Fatality Gaming K4
16GB (2x8) HyperX Predator - HX430C15PB3K2/16 (QVL listed)
DeepCool DQ550ST 80+ Gold PSU

Been rocking this build for almost a week now and it's great in terms of daily workload. All the drivers are the latest, BIOS has also been updated to 1.50. RAM has been set to XMP Profile 1 and then "downclocked" from 3000 to 2933, as I've heard that Ryzen doesn't like 3000 very much. So yeah, when it came down to gaming and unwinding, there was a little bit of stuttering and artifacting at times. Nothing major, just annoying the crap outta me.

So I went around, read a bunch, watched some YT videos and what not and made up my mind that I want to overclock the iGPU part of my APU, to get in a little bit more stable gaming, without the stutter and artifacting. Disabled PBC, Cool'n'Quiet and C-State as advised, then proceeded to thinker with the rest of the settings.

Now, at "stock" settings, the CPU_VCORE voltage reported in HWMonitor was roofing all the way up to 1.562V, which looked to me to be unsafe. So with the Precision Boost Clock and C-State disabled, I turned to the CPU to manual and set it to 3600 MHz, lowering the voltage to 1.4V, which at least in my eyes, looked a lot safer. Without touching the GFX yet, I went back into Windows (10 Pro x64 BTW, in case you're wondering) to check the voltages for the CPU_VCORE and to my surprise, they were maxxing out at 1.312V while under stress (AIDA64), way less than what I've set in the BIOS. So I went back to the BIOS and tried lowering the number down to 1.35V. Unfortunately, this time the PC hang up while stress testing it, so I went back and dialed in 1.4V as it used to be. Went again for stress testing - full hour, no problems.

I'm not after CPU Clock speed anyways, so 3600MHz is perfectly fine for me. Could even downclock it for all that I care. Games I'm playing are not the latest AAA titles anyways, so that's not an issue for me. Playing mostly World of Tanks and Star Wars The Old Republic. Problem came when I tried the "GFX" values. VDDCR_SOC value reported in HWMonitor at "stock" was hovering around 1.1V, which seems pretty fine. Problem is, this is an APU, which means any sort of overclock to the iGPU part, will result in an increase of SOC voltage as well, right ? So you understand why things got a bit awkward from here on now. My APU suffers from something called "Black Hole". Any GFX Clock value that is between 1300 and 1450, simply results in a TDR BSOD. I've found a stable setting at 1500MHz, but that required for me to input 1.3V-1.35V as my GFX Voltage, which immediately jumped up my VDDCR_SOC value displayed in HWMonitor all the way up to 1.3V as well. So, my question is - is that even safe for the VRM of the Gaming K4 ? Artifacting and stuttering were mostly cured with those settings, but I am kinda worried not to fry anything at this moment, so I went back in and locked it back to "Auto" on both GFX Settings in the BIOS. And yeah, I did clear the Advanced > AMD thingy > iGPU Overclock values too, so I know I'm running at 1240MHz with stock SOC Voltage. BTW, those VID values - I really hope ASRock dumps them off at the next BIOS update.

I'm quite surprised how people are running AB350 version of the motherboard I have and are able to run the 2400G at 3,9GHz with the iGPU all the way to 1600MHz on a stock cooler with way less voltage than what I've encountered.

TL;DR : When using an APU, what are the safe Voltages values for the SOC and GFX in the BIOS ?
Back to Top
speedphlux View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Dec 2018
Location: Bulgaria
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote speedphlux Quote  Post ReplyReply Direct Link To This Post Posted: 24 Dec 2018 at 11:03pm
NO response after 20 days ? -.-
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5139
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 25 Dec 2018 at 5:29am
Your post appears to have fallen through the cracks it seems. This happens sometimes when posts are made during a particularly active period on the forums.

I am afraid I don't have any info on max safe voltages for the Raven Ridge APU lineup. If you are concerned you can try open a support ticket with ASRock Tech Support: https://event.asrock.com/tsd.asp

This is a community forum and while ASRock_TSD posts here fairly often these days they don't catch everything. This means that you only get replies when a forum user has an answer for you. In specific cases like yours, often no one knows. Your best bet with specific technical questions is to contact tech support, either ASRock's or AMD's, either should have the answers you are looking for.

Back to Top
speedphlux View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Dec 2018
Location: Bulgaria
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote speedphlux Quote  Post ReplyReply Direct Link To This Post Posted: 25 Dec 2018 at 8:49pm
Thanks ! I've wrote to the tech support and now awaiting reply. I didn't knew you could contact them directly.
Back to Top
asp View Drop Down
Newbie
Newbie


Joined: 23 Jan 2019
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote asp Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jan 2019 at 4:59am
Safe voltage is 1.2v, which is the default target of 1.1v on this board with 1.8 bios. I have my 2400G at 3500@1.25V with boost off, VEGA left at default which sits at 1000 with voltage peaks of just under 1.2 which is max recommended, but RAM is 3200/14@1.35v to give excellent and efficient performance while running very cool.
Back to Top
speedphlux View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Dec 2018
Location: Bulgaria
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote speedphlux Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jan 2019 at 10:25pm
What my dealings with the ASRock tech support unveiled, was that when overclocking just the iGPU, the max SOC voltage that is considered safe is 1.22 -1.225 V.

On stock settings, I'm comfortable sitting at 1.096 V on the SOC, but I guess I did drew the short stick in the silicon lottery, because I can not overclock my GFX to anything under 1500 MHz and have it stable, due to some sort of "black hole" issue. And in order to keep it stable at 1500 MHz, I need to bump up the SOC voltage all the way to 1.32-1.35 V. Real bummer, but I guess I can just wait for a Ryzen 3000 APUs to come out and hope for a better luck in the silicon lottery.

The problems I have right now, are just random screen flickering and artifacting, while running stock speeds and settings. Sometimes my iGPU gets underutilized while playing and it downclocks itself all the way down to 400 MHz and that seems to be what is causing the flickering. Problem is, with that "black hole" I've described, I can't even set the iGPU to fixed 1240 MHz @ 1.1 V. Weird AF ! It's either "stock and default" or 1500 MHz @ 1.35 V. Anything in between is BSOD.
Back to Top
asp View Drop Down
Newbie
Newbie


Joined: 23 Jan 2019
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote asp Quote  Post ReplyReply Direct Link To This Post Posted: 31 Jan 2019 at 2:10am
Stock base clockspeed is 3600, but with boost on mine goes to 3900, the vcore goes to 1.5v and it promptly hits the temp ceiling of 95C (PROCHOT). I wonder if this is complicating your matters? You could try setting CPU to 3500 with 1.25v (in bios, Ryzen Master doesn't work at least not for me), and then trying to mess with GFX.
Back to Top
speedphlux View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Dec 2018
Location: Bulgaria
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote speedphlux Quote  Post ReplyReply Direct Link To This Post Posted: 02 Feb 2019 at 11:40am
Temps on mine are fine. Default settings usually doesn't go over 65 degrees C even when under stress. Might try lowering the CPU clock and voltage and then toying with the GFX settings. Hopefully that either unlocks the "Black Hole" of my iGPU or lower its voltage hunger to normal levels.

Stick rocking the stock cooler. Thinking of swapping it out for an Arctic Freezer 33 eSports ONE in a month or two.
Back to Top
speedphlux View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Dec 2018
Location: Bulgaria
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote speedphlux Quote  Post ReplyReply Direct Link To This Post Posted: 04 Feb 2019 at 8:20pm
Finally had some free time to test your theory out and you are on the right tracks to some extend.

Set the CPU clock to 3500 MHz with the VCORE voltage set to 1.3 V initially. Ran some stability tests - all passed with flying colors. Went back to BIOS and tried to see if I can just set the GFX Clock to 1240 MHz, so it doesn't downthrottle any more, which is what I believe to be the cause of screen flickering and artifacting. Left the GFX Voltage to Auto. Ran some tests - PC froze up. Went back into the BIOS and bumped up the GFX Clock to 1500 MHz and set the GFX Voltage to 1.225 V. Ran some tests again - they all passed. Increase of around 3 FPS in CB R15. However, in the AIDA64 stress test on both CPU and GPU, proved to be getting a bit too warm for my comfort. After 2:30 minutes, the CPU temp hit 85 degrees Celsius, so I stopped it. PC is working fine thou, so now what I think I'll do, is to try downclock and undervolt the CPU even more, since I'm pretty sure my GFX doesn't understand anything between Auto and 1500 MHz speeds. But at least it's stable at somewhat reasonable SOC Voltages.

You've been most helpful ! :)
Back to Top
speedphlux View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Dec 2018
Location: Bulgaria
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote speedphlux Quote  Post ReplyReply Direct Link To This Post Posted: 04 Feb 2019 at 11:57pm
Hmm, that's awkward. It appears that the settings are good only for stress testing. 2 to 5 minutes into a game, the PC just stops being responsive. From my previous dialog with the ASRock tech support indicated that the SOC/GFX Voltage shouldn't go higher than 1.22V, so I tried to toy around the CPU side of things a bit more, but to no avail. Lowering the CPU Clock further down resulted in the same thing - stable stress tests and zero responsiveness after few minutes of gaming. Bumping up the CPU Voltage was exactly the same story.

Then I tried lowering the iGPU Clock, just a tiny bit (1475 MHz), but that froze up on Windows boot. It's like my iGPU refuses anything but "Auto". I did try pretty much every value with increment of 50 that is between 1100 and 1500 MHz with 1.225 V on the GFX Voltage, but it only worked on 1500 MHz and only during stress tests.

It looks to be the "short stick of the silicon lottery" from where I'm standing. I guess I should start planning on whatever Ryzen 3000G are going to come out by the end of the year.
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.063 seconds.