ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Z370 Extreme4 front panel USB
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Z370 Extreme4 front panel USB

 Post Reply Post Reply
Author
Message
Lebowsky View Drop Down
Newbie
Newbie


Joined: 17 Jan 2019
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lebowsky Quote  Post ReplyReply Direct Link To This Post Topic: Z370 Extreme4 front panel USB
    Posted: 17 Jan 2019 at 11:13pm
Hello,

I built a machine with a Z370 Extreme4 motherboard and a Fractal Design Define R6 Type C case. This case has 3 front panel connectors:
- 1 for 1 Type-C USB 3.1 Gen 2 port
- 1 for 2 Type-A USB 3.0 ports
- 1 for 2 Type-A USB 2.0 ports

The type-C port works fine but I have issues with the others.

The 3.0 connectors has been connected to the USB3_5_6 header on the motherboard. But there are problems when connecting devices to it. Sometimes the devices are simply not detected by Windows, sometimes they are but the connection is lost, and sometimes it works fine.

The motherboard manual says those headers are USB 3.1. Is it a problem to connect them to a 3.0 connector? Shouldn't there be some kinf of backwards compatibility? Should I try connecting it to the other header (USB3_7_8)? In the specs, it is said one of those headers is ASmedia, the other is Intel PCH, but it is not specified which is which. Is there a way to tell?

Drivers have been installed from Motherboard disc, and then through Windows Update. OS is windows 10 professional.

Looking forward to your answers, thanks!
Back to Top
RLGL View Drop Down
Newbie
Newbie
Avatar

Joined: 29 Jul 2018
Location: MN
Status: Offline
Points: 184
Post Options Post Options   Thanks (0) Thanks(0)   Quote RLGL Quote  Post ReplyReply Direct Link To This Post Posted: 17 Jan 2019 at 11:59pm
It is a possibility the front panel receptacles are causing the issue.
Asrock Z370 Gaming K6,Intel i7 8700K, ThermalTake Contact Silent12

EVGA RTX2070
EVGA 750 W Super Nova,
16G GSkill Ripjaws, F4-3200C16D-16GVKB,
Samsung 960 Evo 500G M.2,Samsung 970 Evo 1T M.2
Back to Top
Lebowsky View Drop Down
Newbie
Newbie


Joined: 17 Jan 2019
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lebowsky Quote  Post ReplyReply Direct Link To This Post Posted: 18 Jan 2019 at 4:37am
How would I be able to confirm it's the problem? Is there a way?
Back to Top
RLGL View Drop Down
Newbie
Newbie
Avatar

Joined: 29 Jul 2018
Location: MN
Status: Offline
Points: 184
Post Options Post Options   Thanks (0) Thanks(0)   Quote RLGL Quote  Post ReplyReply Direct Link To This Post Posted: 18 Jan 2019 at 6:44am

When there is no response from the PC when connecting the cable, gently wiggle the end to see if it connects.
Asrock Z370 Gaming K6,Intel i7 8700K, ThermalTake Contact Silent12

EVGA RTX2070
EVGA 750 W Super Nova,
16G GSkill Ripjaws, F4-3200C16D-16GVKB,
Samsung 960 Evo 500G M.2,Samsung 970 Evo 1T M.2
Back to Top
Lebowsky View Drop Down
Newbie
Newbie


Joined: 17 Jan 2019
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lebowsky Quote  Post ReplyReply Direct Link To This Post Posted: 18 Jan 2019 at 7:41am
Thanks. I don't have direct access to the box at the moment, but will do next time I can and report back.

I'd still be interested to know which USB 3.1 header is the Intel PCH and which is the Asmedia one if anyone knows.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.066 seconds.