ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - B450m Pro4, Ryzen 5 2400G constantly crashing
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

B450m Pro4, Ryzen 5 2400G constantly crashing

 Post Reply Post Reply Page  <123
Author
Message Reverse Sort Order
xhue View Drop Down
Groupie
Groupie


Joined: 17 Aug 2018
Status: Offline
Points: 634
Post Options Post Options   Thanks (1) Thanks(1)   Quote xhue Quote  Post ReplyReply Direct Link To This Post Posted: 01 Feb 2019 at 5:59am
Hey, Tom!

Sorry to hear that you're having issues with your new build. I know how frustrating it can be. Your PC not booting even with default settings is a clue for several things.

Let's first start with a few basic steps that each new build should start with, shall we?

Double and tripple check all cables, connectors and component seating/fitting. DDR4 slots are not forgiving. Even the tiniest misalignment could cause disaster. I can't stress this step enough.

Sometimes it's worth it to check it the CPU is seated well, too. It looks trivial with this CPU socket but I know of many cases where people got mislead and took it for granted.

Check if there are no metal parts shorting out some circuity.

With the PC off and power cord taken out of the wall socket, use the jumper of a dedicated button to clear the CMOS. Plug cables back in and reboot the PC.

Update the latest BIOS, even if it as a beta. Totally true for ASRock.

Reboot, clear CMOS once again, reboot, turn on XMP for RAM and re-deploy Win from scratch.

All should be fine now. Report back to us, so wen advise further if needed.
Back to Top
thomas1986 View Drop Down
Newbie
Newbie


Joined: 01 Feb 2019
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote thomas1986 Quote  Post ReplyReply Direct Link To This Post Posted: 01 Feb 2019 at 5:05am
Forum search function: B450m Pro4 - no results for my issue
Google: B450m Pro4 - shows shopping options
        B450m Pro4, Ryzen 5 2400G - shows shopping options
        B450m Pro4, Ryzen 5 2400G, Fix crashes - long story short "buy different MB"

Hy. This is my first self-built system since 2008. And i remember it was a little easier that time.
I recently bought a b450m Pro4 with a Ryzen 5 2400G and 2x4GB Patriot Viper RAM which i set to it's stated 3000Mhz. System was not even booting. Google said "activate that XMP Profile" so i did.
System boots but crashes constantly while installing WIN10. Google said "Board doesn't support 3000mhz, reduce to 2933mhz" and so i did.
Installing All In 1 drivers from cd coming with the board, system crashes on start up. Uninstalling All In One Drivers and Google said "load Adrenalin 2019 Edition 19.1.1 from AMD Website", so i did. Windows boots fine, i can do what so ever but after 15 - 45mins the system randomly crashes on several errors. Google said "many people had these problems and solved it with replacing the AsRock MB with different manufacturer"

Does anyone have a better solution to this? Or a link to... somewhere
I mean... i just activated a win10 OEM on that board.

cheers, Tom
Back to Top
 Post Reply Post Reply Page  <123
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.063 seconds.