ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Error version bios 3.10 for B450M and B450
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Error version bios 3.10 for B450M and B450

 Post Reply Post Reply Page  <12
Author
Message
mir View Drop Down
Newbie
Newbie


Joined: 25 Mar 2019
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote mir Quote  Post ReplyReply Direct Link To This Post Posted: 15 Apr 2019 at 7:25pm
Sorry, I meant x470 chipsets.

Wonder if anyone dares to try it
Back to Top
Daveydguk View Drop Down
Newbie
Newbie


Joined: 07 Apr 2019
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote Daveydguk Quote  Post ReplyReply Direct Link To This Post Posted: 16 Apr 2019 at 12:38am
3.20 firmware same issues with hdmi audio disappearing. Boooo
Back to Top
Daveydguk View Drop Down
Newbie
Newbie


Joined: 07 Apr 2019
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote Daveydguk Quote  Post ReplyReply Direct Link To This Post Posted: 18 Apr 2019 at 4:08pm
Hi Asrock.

Can you please advise on any solution to install firmware 3.20 and retain hdmi hd audio. Would restoring windows help ?

Also does the new firmware include updates for Ryzen 2 ?

Im using fatal1ty b450 itx/ac with saphire pulse rx 580 4gb.

Thanks
Back to Top
Daveydguk View Drop Down
Newbie
Newbie


Joined: 07 Apr 2019
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote Daveydguk Quote  Post ReplyReply Direct Link To This Post Posted: 22 Apr 2019 at 2:25am
ASROCK... CAN YOU PLEASE HELP.

I've uninstalled all AMD drivers using safe mode and AMD uninstaller and another unintaller called DDU from 3DGuru. Updated to firmware 3.20 and tried system restore/fix..

This bios just wipes out HDMI Audio on my Saphire Pulse 4GB RX 580.

When I revert back to firmware 1.70 it works fine.

I want to upgrade my 2400G APU to ryzen 2+ CPU later on this year, so will need some sort of Bios upgrade for new compatibility with Ryzen 2+ 3600.

Can you please comment on the current state of play in regards to supporting the new AMD Ryzen 2+ chips ?


Thanks.
Back to Top
danknabbit View Drop Down
Newbie
Newbie


Joined: 23 Apr 2019
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote danknabbit Quote  Post ReplyReply Direct Link To This Post Posted: 23 Apr 2019 at 2:37pm
Updated my fatal1ty b450 itx/ac from 1.70 to 3.20. 2600X w/ GTX 1080. No longer boots to Windows 10. The BIOS splash screen shows briefly but I get a black screen when I try to enter BIOS.

I suppose.... I have a fancy paperweight?
Back to Top
AloTek View Drop Down
Newbie
Newbie


Joined: 26 Apr 2019
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote AloTek Quote  Post ReplyReply Direct Link To This Post Posted: 26 Apr 2019 at 8:18pm
How exactly did you the Windows flashing? I have the problems with 3.10 as well and I wanted to try downgrade to 2.00.
Back to Top
bjlockie View Drop Down
Newbie
Newbie


Joined: 17 Nov 2015
Status: Offline
Points: 65
Post Options Post Options   Thanks (0) Thanks(0)   Quote bjlockie Quote  Post ReplyReply Direct Link To This Post Posted: 27 Apr 2019 at 4:34am
Originally posted by danknabbit danknabbit wrote:

Updated my fatal1ty b450 itx/ac from 1.70 to 3.20. 2600X w/ GTX 1080. No longer boots to Windows 10. The BIOS splash screen shows briefly but I get a black screen when I try to enter BIOS.

I suppose.... I have a fancy paperweight?


* If you updated the BIOS before updating the AMD all in one driver, please refer to the Display recovery SOP to recover your system.
* User will not able to flash previous BIOS once upgrading to this BIOS version.
* If the current BIOS version is older than P1.70, please update BIOS to P1.70(PinnaclePI-AM4_1.0.0.6) before updating this version.
http://asrock.pc.cdn.bitgravity.com/TSD/Display%20recovery%20SOP.pdf
ASRock B450M Pro4
16 GB DDR4, 500 watt PS, AMD Ryzen-5 2600, NVidia GTX-1050
Back to Top
Killer_088 View Drop Down
Newbie
Newbie
Avatar

Joined: 23 May 2019
Location: Athens
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Killer_088 Quote  Post ReplyReply Direct Link To This Post Posted: 23 May 2019 at 12:20am
Hi i had the same problem but i found a solution please download this version from this site->https://drivers.softpedia.com/get/BIOS/Asrock/ASRock-B450M-Pro4-BIOS-1-50.shtml and then download the first release of your bios version from asrock site this worked for me.
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.