ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Cannot use M.2 SATA drive
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Cannot use M.2 SATA drive

 Post Reply Post Reply
Author
Message
SuarezTheGreat View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote SuarezTheGreat Quote  Post ReplyReply Direct Link To This Post Topic: Cannot use M.2 SATA drive
    Posted: 09 Apr 2019 at 10:52am
When I tried to add WDS250G2B0B to M2_2, no detect in BIOS or Win10.
However, I change a NVMe 970EVO to M2_2 and work.
So, M2_2 really doesn't support SATA M.2 drives?
Back to Top
SuarezTheGreat View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote SuarezTheGreat Quote  Post ReplyReply Direct Link To This Post Posted: 09 Apr 2019 at 4:10pm
X470 taichi, sorry
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 2626
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 09 Apr 2019 at 4:21pm
Dear SuarezTheGreat,

Greetings, this is ASRock TSD.


Regarding your question, X470 Taichi M2_2 slot only support M Key type 2230/2242/2260/2280 M.2 PCI Express module up to Gen2 x4 (20 Gb/s).
M.2 SATA SSD only works at M2_1 slot.

Please refer to the detail specification from below link.
https://www.asrock.com/mb/AMD/X470%20Taichi/index.asp#Specification


Thanks!

All the best,
ASRock TSD
Back to Top
brkkab123 View Drop Down
Newbie
Newbie


Joined: 21 Dec 2018
Location: USA - Californi
Status: Offline
Points: 48
Post Options Post Options   Thanks (0) Thanks(0)   Quote brkkab123 Quote  Post ReplyReply Direct Link To This Post Posted: 09 Apr 2019 at 5:38pm
He's correct I was in the same situation as you when I recently built my pc with the X470 Taichi Ultimate.
I put my Samsung 850 EVO m.2 ssd in m.2 slot 2 and it wasn't recodnized.
I put it in m.2 slot 1 and it works fine.
Back to Top
SuarezTheGreat View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote SuarezTheGreat Quote  Post ReplyReply Direct Link To This Post Posted: 19 Apr 2019 at 12:08pm
Thanks all, my problem is solved.
Love ASRock!!!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.063 seconds.