ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - AMD Ryzen 3600x with Fatal1ty X470 Gaming-ITX/ac
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

AMD Ryzen 3600x with Fatal1ty X470 Gaming-ITX/ac

 Post Reply Post Reply Page  <1 23456>
Author
Message
Apizz View Drop Down
Newbie
Newbie


Joined: 12 Jul 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Apizz Quote  Post ReplyReply Direct Link To This Post Posted: 22 Jul 2019 at 2:23pm
How about b350 gaming itx can i adopt this BIOS ?yes i know it had a risk.
Back to Top
pthrogmo View Drop Down
Newbie
Newbie


Joined: 16 Jul 2019
Status: Offline
Points: 8
Post Options Post Options   Thanks (0) Thanks(0)   Quote pthrogmo Quote  Post ReplyReply Direct Link To This Post Posted: 22 Jul 2019 at 9:25pm
Originally posted by Apizz Apizz wrote:

How about b350 gaming itx can i adopt this BIOS ?yes i know it had a risk.


The one I received is intended only for the B450, I would suggest opening a support case with ASRock to see if there is one suitable for the B350.
Back to Top
edlebert View Drop Down
Newbie
Newbie


Joined: 10 Jul 2019
Status: Offline
Points: 41
Post Options Post Options   Thanks (0) Thanks(0)   Quote edlebert Quote  Post ReplyReply Direct Link To This Post Posted: 22 Jul 2019 at 11:11pm
Originally posted by Apizz Apizz wrote:

How about b350 gaming itx can i adopt this BIOS ?yes i know it had a risk.


Someone else just posted a link to a beta bios for the Fatal1ty AB350 Gaming ITX here:
http://forum.asrock.com/forum_posts.asp?TID=11970&title=beta-bios-for-ab350-gaming-itx-agesa-combo-1003
Back to Top
Apizz View Drop Down
Newbie
Newbie


Joined: 12 Jul 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Apizz Quote  Post ReplyReply Direct Link To This Post Posted: 22 Jul 2019 at 11:14pm
I had try it no change still not post
Back to Top
Xcomp666 View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Jul 2019
Location: Canada
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xcomp666 Quote  Post ReplyReply Direct Link To This Post Posted: 22 Jul 2019 at 11:32pm
Same here!
I just bought a Ryzen 7 3700X yesterday. I was so happy until updated my Asrock Fatal1ty B450 itx bios to 3.30. My M.2 driver disappeared, Memory frequency can? get over 2133 ghz , system unstable( rebooting all the time). If Asrock doesn? fix it until tomorrow. I am going to buy an Auros x570 itx when became available on Newegg again. What lazy customer service!!
Back to Top
pthrogmo View Drop Down
Newbie
Newbie


Joined: 16 Jul 2019
Status: Offline
Points: 8
Post Options Post Options   Thanks (0) Thanks(0)   Quote pthrogmo Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jul 2019 at 2:14am
Originally posted by Xcomp666 Xcomp666 wrote:

Same here!
I just bought a Ryzen 7 3700X yesterday. I was so happy until updated my Asrock Fatal1ty B450 itx bios to 3.30. My M.2 driver disappeared, Memory frequency can?嚙緣 get over 2133 ghz , system unstable( rebooting all the time). If Asrock doesn?嚙緣 fix it until tomorrow. I am going to buy an Auros x570 itx when became available on Newegg again. What lazy customer service!!


I PM'd you the link I got from ASRock support for 3.33 BIOS which fixes the m.2 issue and, for me, performs well.
Back to Top
Tosen View Drop Down
Newbie
Newbie


Joined: 21 Jul 2019
Location: M矇xico
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tosen Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jul 2019 at 6:58am
Originally posted by pthrogmo pthrogmo wrote:

Originally posted by Xcomp666 Xcomp666 wrote:

Same here!
I just bought a Ryzen 7 3700X yesterday. I was so happy until updated my Asrock Fatal1ty B450 itx bios to 3.30. My M.2 driver disappeared, Memory frequency can?嚙緣 get over 2133 ghz , system unstable( rebooting all the time). If Asrock doesn?嚙緣 fix it until tomorrow. I am going to buy an Auros x570 itx when became available on Newegg again. What lazy customer service!!


I PM'd you the link I got from ASRock support for 3.33 BIOS which fixes the m.2 issue and, for me, performs well.




That bios works for B450 Gaming K4 fatality atx?

I got an email from ASRock 3.31 bios and on the site around the forum there's the 3.32 bios...unsure which one to use.
Back to Top
gizmic View Drop Down
Groupie
Groupie
Avatar

Joined: 13 Jun 2018
Location: Hong Kong
Status: Offline
Points: 398
Post Options Post Options   Thanks (0) Thanks(0)   Quote gizmic Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jul 2019 at 12:00pm
all i can say all boards including other brands have that same m.2 issue until you upgrade to 1.0.0.3
Back to Top
edlebert View Drop Down
Newbie
Newbie


Joined: 10 Jul 2019
Status: Offline
Points: 41
Post Options Post Options   Thanks (0) Thanks(0)   Quote edlebert Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jul 2019 at 11:24pm
For those using a stock bios based on AGESA 1.0.0.1 and are having RAM speed issues, please read/watch this: https://www.reddit.com/r/Amd/comments/cbpt6p/psa_asrock_b350b450_pro4_with_r5_36003600x_bsod/

Running at 2133 didn't work for me becase the RAM's SPD dictates to run that speed at a low voltage. Simply dropping down from 3200 to 3000 made my system very stable.
Back to Top
danknabbit View Drop Down
Newbie
Newbie


Joined: 23 Apr 2019
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote danknabbit Quote  Post ReplyReply Direct Link To This Post Posted: 26 Jul 2019 at 2:52pm
Originally posted by danknabbit danknabbit wrote:

I can repro the problem. B450 Fatality ITX, 3600X, GSkill TridentZ 3200mhz 2x8gb ram, 3.30 bios.

Pulled all drives, including the back NVMe, to no avail - it reboots itself endlessly while trying to POST.

Reinstalling the otherwise-outgoing 2600X. System POSTed normally. Glad to hear there's a beta bios update in the works. I will update the BIOS in my board once there's an official release, and try again with the 3600X.


P 3.40 is now available. I flashed the motherboard to that with the 2600X, swapped in the 3600X, and cleared the bios (cmos jumper).

It did not work initially. After several poweron/poweroff cycles, it finally displayed the BIOS splash screen! Hard locked. Power cycle again, and it POSTed all the way to BIOS.

Re-enabled fTPM, disabled CSM, set RAM speed via XMP profile to 3200. PBO enabled. It successfully POSTed to bios. Reinstalled both SATA and NVMe drives. It booted to Windows.

It does not make it to windows every single time it power cycles, but, it makes it there often enough to begin perf and stability testing.

Windows 10 is updated to the latest revision of 1903. It recognizes the CPU name but does not recognize the RAM besides the capacity. Unclear cause.
Back to Top
 Post Reply Post Reply Page  <1 23456>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.078 seconds.