ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Ryzen 3000 series support
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Ryzen 3000 series support

 Post Reply Post Reply Page  <1 6364656667>
Author
Message
hinchyman View Drop Down
Newbie
Newbie


Joined: 04 Aug 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote hinchyman Quote  Post ReplyReply Direct Link To This Post Posted: 09 Nov 2019 at 12:48am
Where are the bios updates supporting 1.0.0.4? Been dealing with issues ever since I upgraded
Back to Top
CamJ26 View Drop Down
Newbie
Newbie
Avatar

Joined: 08 Nov 2019
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote CamJ26 Quote  Post ReplyReply Direct Link To This Post Posted: 09 Nov 2019 at 12:57am
Originally posted by Xaltar Xaltar wrote:

Hi Camj26

The GPU needs 2 PCIe 6+2 pin power connectors not 4+4 (CPU power) connectors.
Make sure you have connected your CPU power connectors (4+4) at the top left of the board.

Without the CPU 8pin power connected you will get exactly the symptoms you describe.


Thanks for chiming in, this worked! I plugged in both PCIE power into the GPU and it gave me a display!

Now I have Insert Boot Media, I assume I need to create a Windows boot key and boot from that. I think this has me on a path to figuring it out. What a stupid mistake, THANK YOU!
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5426
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 09 Nov 2019 at 2:44am
Great, enjoy the build
Back to Top
CorNut View Drop Down
Newbie
Newbie


Joined: 25 Aug 2019
Location: Eugene, OR
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote CorNut Quote  Post ReplyReply Direct Link To This Post Posted: 11 Nov 2019 at 1:16am
Seeing how the beta 1.0.0.4 bios fixed my bootloop issues on my b450 fatal1ty itx, I decided to give the x470 fatal1ty itx beta bios a try. Both worked fine before my Ryzen 3000 upgrades, with the 1.0.0.4 update on my x470 I'm still getting bootloop but it's posting each time so I'll troubleshoot & update when/if I figure out what's causing it.
Back to Top
brave View Drop Down
Newbie
Newbie


Joined: 11 Nov 2019
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote brave Quote  Post ReplyReply Direct Link To This Post Posted: 11 Nov 2019 at 1:37am
Hi guys,

i built a few weeks ago my new build, but I have a minor problem with that, I can? solve it. I hope you can help me.

Motherboard: Asrock X570 Phantom Gaming 4
CPU: AMD Ryzen 7 3700x
VGA: GigaByte GeForce GTX 1080 Windforce OC
RAM: Crucial Ballistix Sport 2x8GB DDR4 2400Mhz
PSU: Enermax 600W LEPA MX F1

What only happens by a cold boot: PC is started and I get the Asrock logo the first time it is powered on, but the boot will not continue. The VGA red LED on the motherboard lights up. In this case, if I press a restart button, the PC will boot up and work properly. There is no problem with a simple restart. This error does not occur during a simple reboot/restart.

I make Windows reinstall, SSD is in UEFI mode formatted, and I reinstalled the drivers. The BIOS version is the latest available on the official website. (1.88)

Thanks so much in advance if you have any tips for this!
Back to Top
shmerl View Drop Down
Newbie
Newbie


Joined: 23 Oct 2017
Status: Offline
Points: 197
Post Options Post Options   Thanks (0) Thanks(0)   Quote shmerl Quote  Post ReplyReply Direct Link To This Post Posted: 11 Nov 2019 at 4:46am
Originally posted by sajmon83 sajmon83 wrote:

7.11.19
...
X370 Taichi - BIOS 5.94
...
All bios are beta versions and can be found at https://shop.jzelectronic.de/news.php?id=1572952560&sw=


I don't really see it there, or may be I'm missing something? When will Asrock release that for X370 Taichi? I wanted to buy Ryzen 7 3700X for one of my computers with X370 Taichi but lack of recent UEFI is a concern.
Back to Top
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Germany, Berlin
Status: Offline
Points: 547
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Nov 2019 at 5:33am
https://shop.jzelectronic.de/news.php?kat=Bios
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE
Back to Top
shmerl View Drop Down
Newbie
Newbie


Joined: 23 Oct 2017
Status: Offline
Points: 197
Post Options Post Options   Thanks (0) Thanks(0)   Quote shmerl Quote  Post ReplyReply Direct Link To This Post Posted: 11 Nov 2019 at 5:53am
Originally posted by Ray62 Ray62 wrote:

https://shop.jzelectronic.de/news.php?kat=Bios


Searching around, I found it here: https://shop.jzelectronic.de/news.php?id=1573118100&sw=
Back to Top
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Germany, Berlin
Status: Offline
Points: 547
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Nov 2019 at 4:46pm
Originally posted by shmerl shmerl wrote:

Originally posted by Ray62 Ray62 wrote:

https://shop.jzelectronic.de/news.php?kat=Bios

Searching around, I found it here: https://shop.jzelectronic.de/news.php?id=1573118100&sw=

And your link now is not valid any more...

With
https://shop.jzelectronic.de/news.php?kat=Bios
one can see the last bios blog entries at every time.
11.11.19 08:40     Neue BIOSe f羹r ASRock Serie AM4


11.11.19
B450 Steel Legend - BIOS 3.15
B450 Gaming K4 - BetaBIOS 3.85
B450 Pro4 - BetaBIOS 3.85
B450M Steel Legend - BIOS 2.85
B450M Pro4 - BetaBIOS 3.85 ...kommt


Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE
Back to Top
humbug View Drop Down
Newbie
Newbie
Avatar

Joined: 30 Jan 2018
Location: UK
Status: Offline
Points: 31
Post Options Post Options   Thanks (0) Thanks(0)   Quote humbug Quote  Post ReplyReply Direct Link To This Post Posted: 12 Nov 2019 at 12:50am
Any news on 1004B for B350?
Back to Top
 Post Reply Post Reply Page  <1 6364656667>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.