ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Ryzen 3000 series support
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Ryzen 3000 series support

 Post Reply Post Reply Page  <1 910111213 106>
Author
Message
marcooli0 View Drop Down
Newbie
Newbie


Joined: 03 Aug 2019
Location: London
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote marcooli0 Quote  Post ReplyReply Direct Link To This Post Posted: 03 Aug 2019 at 6:27pm
Wait, so just so I'm clear here after reading the last 10 pages or so...

The K4 X370 Fatal1ty *IS* eventually getting a BIOS update to allow higher memory clocks or? I just upgraded to Ryzen 3700x with my Corsair Vengeance sticks at 3200 - I was previously able to get up to 2800mhz but can now only post at 2133mhz. It's absolutely infuriating because I can tell it's gimping my performance by a lot.
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5779
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 03 Aug 2019 at 11:13pm
Originally posted by srdjan1995 srdjan1995 wrote:

Any news on new bios releases for 300 series motherboards, like my AB350 Pro4?


Check the link in my original post, there is a Beta for the AB350 Pro4. If there is a beta then there will certainly be a release BIOS to follow.
Back to Top
srdjan1995 View Drop Down
Newbie
Newbie


Joined: 11 Jan 2018
Status: Offline
Points: 36
Post Options Post Options   Thanks (0) Thanks(0)   Quote srdjan1995 Quote  Post ReplyReply Direct Link To This Post Posted: 04 Aug 2019 at 4:39am
Originally posted by Xaltar Xaltar wrote:

Originally posted by srdjan1995 srdjan1995 wrote:

Any news on new bios releases for 300 series motherboards, like my AB350 Pro4?


Check the link in my original post, there is a Beta for the AB350 Pro4. If there is a beta then there will certainly be a release BIOS to follow.


I can't seem to find it. I mean, I found the link with beta bioses, but there does not seem to be one for AB350 Pro4, or at least I don't see one. If you have a link, can you send me? Thanks :)
Btw, I currently have 5.80, but I wanna buy one of the zen 2 cpu's soon, so I wanna update first. This 5.80 seem to be working great on my R3 1200, having it OC'ed at 4GHz, no problem whatsoever.
Back to Top
badboy141 View Drop Down
Newbie
Newbie


Joined: 04 Aug 2019
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote badboy141 Quote  Post ReplyReply Direct Link To This Post Posted: 04 Aug 2019 at 2:22pm
I can't find it either. Can you give us some information when a bios (even beta) with new agesa is coming out? I'm getting really annoyed with all these bsod and i know, this is one of the cheapest motherboards from asrock, but seeing that even most expensive one like x370 taichi is in the same situation doesn't help either.
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5779
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 04 Aug 2019 at 3:13pm
I am on holiday at the moment and away from my PC, once I get home I will look through the BIOS betas I have there, I could have sworn I saw one for the ab350 pro4 on JZ's site but it may have been in my own archive.

I will be back home on the 9th, if there is no update posted by then I will see if I have one and share it.
Back to Top
badboy141 View Drop Down
Newbie
Newbie


Joined: 04 Aug 2019
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote badboy141 Quote  Post ReplyReply Direct Link To This Post Posted: 04 Aug 2019 at 4:05pm
Ok, i think i just found it [URL=https://www.jzelectronic.de/jz2/news.php?sid=02d7affbf97b77d7b7edb39d6b6c16e2dd1ba1872df91985ed1ca4cde2dfe669&lid=1564471560&auswahl=anzeige2&z=1&ssl=1] here [/URL] . Is it safe to get updates from this site? Never used anything but official asrock.
Back to Top
sebastianer View Drop Down
Newbie
Newbie
Avatar

Joined: 27 Jul 2019
Status: Offline
Points: 37
Post Options Post Options   Thanks (0) Thanks(0)   Quote sebastianer Quote  Post ReplyReply Direct Link To This Post Posted: 04 Aug 2019 at 7:18pm
I think it should be fine.

In my case I tried (B450 ITX): P3.30, L3.33, L3.41, P3.40, L3.42 (in that order).

Only real difference I noticed is between P3.30 and the other 4 versions. Because the AGESA in P3.30 is older and support less RAM frequency.

- But the POST low success % issue is present in all of them. Even if I use default UEFI settings. Motherboar can't properly POST always or come back from Sleep state.
MB: ASRock B450 ITX (P3.70)
CPU: Ryzen 7 3700X
RAM: Ballistix BLS2K8G4D32AESTK
SSD: Crucial P1 500 NVME
GPU: Gigabyte G1 GTX1080
PSU: Enermax ERX530AWT --> Corsair RM650x (CP-9020178)
Back to Top
bluemokona View Drop Down
Newbie
Newbie
Avatar

Joined: 02 Aug 2019
Location: Singapore
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote bluemokona Quote  Post ReplyReply Direct Link To This Post Posted: 05 Aug 2019 at 2:42pm
Originally posted by bluemokona bluemokona wrote:

Hi all!

Just new here. I have freshly built w/ specs Ryzen 3600 and Asrock b450m Steel Legend. However, when turning it ON it doesn't have display and USB power but the fans and LEDs are ON. I have tried removing all the parts (RAM, GPU, m2, etc) retaining only the CPU but still the same results. Is this related to upgrade first the BIOS?

Thank you in advance



Solved already! Thanks for the tips! Bought a second hand Athlon 200ge, then installed windows and installed the pre-requisite then the latest Bios. Attached the Ryzen 3600, then clean install Windows. So far it is still running.
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5779
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 05 Aug 2019 at 7:51pm
An interesting read:
https://community.amd.com/community/gaming/blog/2019/07/30/community-update-5-let-s-talk-clocks-voltages-and-destiny-2
Back to Top
AsiJu View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Aug 2019
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote AsiJu Quote  Post ReplyReply Direct Link To This Post Posted: 05 Aug 2019 at 8:06pm
ASRock X370 Killer SLI
Bios version: P5.40
CPU: Ryzen 7 3800X
Memory: G.Skill (2x8GB) Trident Z, DDR4 3000MHz, CL14, 1.35V
(F4-3000C14D-16GTZ)
SSD: Crucial MX100
GPU: MSI GeForce RTX 2070 Armor

having same issues as many, getting boot cycles on cold boot, PC won't POST with memory above 2133 MHz, PC may hang at POST.

Waiting for a BIOS / AGESA update, patiently...
Back to Top
 Post Reply Post Reply Page  <1 910111213 106>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.078 seconds.