ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Ryzen 3000 series support
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Ryzen 3000 series support

 Post Reply Post Reply Page  <12345 21>
Author
Message
Xcomp666 View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Jul 2019
Location: Canada
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xcomp666 Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jul 2019 at 1:00am
Hey Guys ! Where can I find those beta bios for B450 Fatal1ty Gaming ITX/ac?
Asrock CS did not reply any email !!!
Back to Top
mrxt1 View Drop Down
Newbie
Newbie
Avatar

Joined: 19 Jul 2019
Location: Poland
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote mrxt1 Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jul 2019 at 2:48am
Do you hava an ability to do a full copy of bios file from the chip using an external programmer?
Back to Top
Vakich View Drop Down
Newbie
Newbie


Joined: 06 Dec 2017
Status: Offline
Points: 29
Post Options Post Options   Thanks (0) Thanks(0)   Quote Vakich Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jul 2019 at 2:48pm
Asrock AB350 Pro 4

Mine Ryzen 3600 processor turned up to be broken. Tried to boot it with many others motherboards like asus, gigabyte and msi with latest bios and no luck. So i am sorry to say that it was Asrock problem that my processor didn't boot.
Back to Top
keyvankr View Drop Down
Newbie
Newbie


Joined: 26 Jul 2019
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote keyvankr Quote  Post ReplyReply Direct Link To This Post Posted: 26 Jul 2019 at 4:57am
not only was it not working with P3.30 Asrock Fatality B450 Gaming-ITX/AC which I had to bypass by using a M.2 to USB sata adapter, now with P3.40 nothing even works...if hardware is going to be like games nowadays (unfinished & untested), then I won't be buying it day one. Thanks for steering me away from ANYTHING related to this brand. How a multi million dollar company manages to have such poor QA (not even once, but twice so there's no "bad luck") is beyond me.
quote from the booklet:
"My vision for Ftal1ty hardware is to allow gamers to focus on the game without worrying about their equipment, something I've preached since I began competing. I don't want to worry about my equipment. I want to be there - over and done with- so I can focus on the game. I want to be the fatest and most stable computer equipment on the face of the planet, so quality is what Fatal1ty Brand products represent.
queue the "curb your enthusiasm" song
Back to Top
Evil Genius View Drop Down
Newbie
Newbie


Joined: 26 Jul 2019
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Evil Genius Quote  Post ReplyReply Direct Link To This Post Posted: 26 Jul 2019 at 8:41pm
I'm running a 3700x on an X370 Killer SLI with BIOS 5.40 and 4x 4GB DDR4-2133 ECC. As I'm having trouble with Prime95 crashing, I'm trying out some BIOS settings to see if they have a positive effect.

When I disable SMT, the board no longer boots. I have to clear the CMOS to get it to boot again, which it will after some crashes in the BIOS.

Could some of you Asrock guys investigate?
Back to Top
Bred View Drop Down
Newbie
Newbie


Joined: 14 May 2019
Status: Offline
Points: 19
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bred Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2019 at 12:59am
Originally posted by Bred Bred wrote:

Hello :)

Problems found on :

MB : Asrock B450M Steel Legend
CPU : 3600X (replacing ryzen 3 1200)
Bios : 2.30

DDR4 kit tested :

1) Corsair vengeance RGB 2x8Go (CMR16GX4M2C3000C15W) - 3000Mhz C15
2) Ballistix sport 2x8Go (BL82K8G4D30AE8BK) - 3000Mhz C15


With the last bios 2.30, none of these two DDR4 kit work at XMP frequencies anymore, the first kit works now at 2133Mhz and the second at 2400Mhz ... manually settings or XMP profile don't applicate.

With the previous bios I do not have these problems if I remember well and on my MB asus prime X370-pro (bios 5008) + ryzen 5 1600 I don't have issues..

I bought recently this kit :

3) G.Skill 2x8Go 3600Mhz (16-16-16-36) Trident Z K2 (F4-3600C16D-16GTZKW
hope it will work better



Thx


Hello again.

It seems the last bios released recently (2.50) fixed the XMP settings, one of the two memory kit mentionned before (the corsair) works again at XMP frequencies (3000Mhz).

I've not received yet my new kit, and not tested the second kit^^.
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5266
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2019 at 1:32am
Things are coming along, it just takes time. Unfortunately there are multiple stages in getting a BIOS update out the door, even just as a Beta. There are so many hardware configurations to test and every one of them needs to be tested in multiples of 3 (once on each Ryzen CPU generation) on each and every board from the 300 series and up. I do not envy the people working on testing, even only testing say 5 different RAM kits on each config and say 3 different NVMe/M.2 drives thats 24 tests per board minimum that need to be repeated with each and every BIOS change/tweak.

ASRock is on it however and won't quit till they get things sorted for us.

Edited by Xaltar - 27 Jul 2019 at 5:39pm
Back to Top
frenchyaz View Drop Down
Newbie
Newbie


Joined: 23 Jul 2019
Location: 85286
Status: Offline
Points: 8
Post Options Post Options   Thanks (0) Thanks(0)   Quote frenchyaz Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2019 at 2:43am
X470 with BIOS 3.50 XMP setting for Crucial 3600 is working again (former 3.43 BIOS was bringing them to 2133MHz using 3700X Ryzen).

However I populated the board with:
Highpoint 2720SGL
NC364 HP quad nic
Video card

And the board POST, restart, POST, restart, POST, restart and POST then loads Windows. I didn't change the settings, just updated the BIOS. Using a 2700 on this one.
Frenchyaz
Back to Top
sebastianer View Drop Down
Newbie
Newbie
Avatar

Joined: 27 Jul 2019
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote sebastianer Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2019 at 9:30pm
Hi

ASROCK B450 ITX here (P3.40 bios) + 3700X here.

The main issue I have with my rig is that I can't wake up my PC from sleep (after a few minutes of entering sleep mode). And many times I can't POST/BOOT from cold boot as well.


How to replicate this:

- Put PC to sleep (alternatively you can shutdown windows disabling fast "start-up")
- Wait 10-15 minutes
- Wake it up (e.g. by pressing a key of the USB keyboard)
- PC wakes up, screen is black, PC goes back to sleep after a few seconds.

How to escape from this state:
- Turn off the PC and/or turn off the Power Supply
- Turn on the PC
- PC starts boot looping (still no screen), after 1 to 20 minutes boot looping or trying to boot, PC boots (with UEFI default settings) and works perfectly all the time, until the next Windows shutdown or sleep.

Workaround:
Disable sleep. (note that PC consumes 50-65W in idle, versus 2W in sleep state).





MB: ASRock B450 ITX (P3.50)
CPU: Ryzen 7 3700X
RAM: Ballistix BLS2K8G4D32AESTK
SSD: Crucial P1 500 NVME
GPU: Gigabyte G1 GTX1080
PSU: Enermax ERX530AWT --> Corsair RM650x (CP-9020178)
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5266
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jul 2019 at 1:31am
Thanks Sebastainer, is this a fresh OS install or did you upgrade the CPU and keep the original OS? There are significant architectural differences between gen 2 and gen 3 Ryzen that could be causing sleep issues. I would try a fresh OS install (on a spare drive if you have one) and see if the issue persists.
Back to Top
 Post Reply Post Reply Page  <12345 21>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.