ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Ryzen 3000 series support
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Ryzen 3000 series support

 Post Reply Post Reply Page  <1 2930313233 57>
Author
Message
datonyb View Drop Down
Senior Member
Senior Member


Joined: 11 Apr 2017
Location: London U.K.
Status: Offline
Points: 1753
Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 05 Sep 2019 at 1:44am
Originally posted by Xaltar Xaltar wrote:



I got my 3600 up and running on my X370 Taichi without any issues, my RAM
however has never given me any issues from first gen to now though so your
mileage may vary. Annoyingly, I never have the same issues other people do,
when I am trying to help people figure it out that is actually a bad thing...

My x570 Taichi is still being put through it's paces, so far aside from some
memory training on cold boot it's running smoothly. I will be doing a user
review comparing it to my other AM4 boards soon, detailing my experience with
them all and Ryzen 3000.



yes ram will be something i'll be looking deeply into as well as the fclk possibilities of course, hopefully i can help shed some help/light regarding setup
now if i can get as much luck with the 3000 series as i got with 1000 ryzens i dont know yet
and as with first gen i presume maybe a few things we learn at early stage may well 'change' later on with bios updates etc

what sort of luck are you having at the moment with your ram in both the 370 and 570 systems ?

r7 1700 powercolor reddevil vega64 gskill tridentz3866 taichi x370 evga 750watt gold
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5401
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 05 Sep 2019 at 2:38am
Both my kits are samsung B-Die and have just worked out the box since day one,
much to my annoyance. Naturally, my 3600 kit wouldn't work at 3600 on my 1600x +
X370 Taichi setup but I was easily able to get 3333 and even 3400 stable on it.
The 3600 kit worked at it's XMP right out of the box on my 2950x system and did
the same on the X570 Taichi. My 8gb 2800 kit works on anything I put it in, even
the most fussy systems. Enable XMP and go.
Back to Top
datonyb View Drop Down
Senior Member
Senior Member


Joined: 11 Apr 2017
Location: London U.K.
Status: Offline
Points: 1753
Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 05 Sep 2019 at 4:11am
i meant what is the state with your x370 and 3600cpu now ?

ive got the 3866 tridentz which i got 3466 on the ryzen 1700 but that had an excelent memory controller i was hitting 3200cl14 from bios version 2.0 with trident cl15 rams at first before i bought the 3866 kit

im hopng to be able to get decent 3600/3733 on the 3800x so i can try and help /assist others to get stable 3600mhz rams

r7 1700 powercolor reddevil vega64 gskill tridentz3866 taichi x370 evga 750watt gold
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5401
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 05 Sep 2019 at 4:39am
I have yet to try the X370 with my 16gb 3600 kit. It requires taking them out of
my main system so it will have to wait till I don't need it for a few hours. Over
the next few weeks that is exactly the kind of thing I will be testing for my
review
Back to Top
datonyb View Drop Down
Senior Member
Senior Member


Joined: 11 Apr 2017
Location: London U.K.
Status: Offline
Points: 1753
Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 06 Sep 2019 at 1:18am
ITS ALIVE !

x370 taichi - 3800x - 3600mhz ram @cl16

what a bl00dy afternoon i had !
including but not limited to ...............

asrock website going all wrecked and not letting me get to bios page
bios 3.3 knocking out my usb ports .....try flashing without usb ports
AND YES internet bios flash broken as well..no updated bios available.... really nothing newer than 3.1 ? LOL
and then to top it all .ram slot b2 working with the 1700 and bios 5,8 but causing a no boot with the 3800x...total prevention to boot past led codes 33-7a-36-SWITCH-OFF!..........that was a nightmare in itself

ANYWAYS now got both slots a2/b2 to work
quick cinebench results in R20
multi core 4970
single core 515

hwinfo reports at some stage i cannot witness cpu hits 4525mhz on core 0 and core 1
but i can see it hold 4475mhz for a second or two running cinebench
cpu is 100% out the box settings wise at the moment as i lost soooo much time with this silly ram slot issue today

r7 1700 powercolor reddevil vega64 gskill tridentz3866 taichi x370 evga 750watt gold
Back to Top
Exel View Drop Down
Newbie
Newbie


Joined: 29 Aug 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Exel Quote  Post ReplyReply Direct Link To This Post Posted: 06 Sep 2019 at 5:27am
Got my HyperX 3200MHz CL16 memory running fine with Ryzen 3600 and X470 Taichi using XMP settings. Managed even to tighten the timings to CL15 without issues. The memory kit is listed in Taichi's QVL.

That said, the cpu doesn't boost to its 4.2 GHz max clock despite temps being well under control. The closest it has gotten with the 3.60 BIOS is 4.15 GHz, but mostly it tops (briefly) at 4.1 GHz.

Other than that I haven't had compatibility issues with the X470 Taichi.
Back to Top
datonyb View Drop Down
Senior Member
Senior Member


Joined: 11 Apr 2017
Location: London U.K.
Status: Offline
Points: 1753
Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 06 Sep 2019 at 5:35am
Originally posted by Exel Exel wrote:

Got my HyperX 3200MHz CL16 memory running fine with Ryzen 3600 and X470 Taichi using XMP settings. Managed even to tighten the timings to CL15 without issues. The memory kit is listed in Taichi's QVL.

That said, the cpu doesn't boost to its 4.2 GHz max clock despite temps being well under control. The closest it has gotten with the 3.60 BIOS is 4.15 GHz, but mostly it tops (briefly) at 4.1 GHz.

Other than that I haven't had compatibility issues with the X470 Taichi.


maybe because im using the early 7/7/19 driver for chipset before the destiny nerf and the voltage panic nerf

r7 1700 powercolor reddevil vega64 gskill tridentz3866 taichi x370 evga 750watt gold
Back to Top
ryansg8 View Drop Down
Newbie
Newbie


Joined: 29 Aug 2019
Status: Offline
Points: 9
Post Options Post Options   Thanks (1) Thanks(1)   Quote ryansg8 Quote  Post ReplyReply Direct Link To This Post Posted: 07 Sep 2019 at 9:13am
Hey guys, just posting the final update to my b450 itx saga.
I was within the return period for the board from micro center, so I ended up returning it and getting a gigabyte x570 itx motherboard. It works perfect now with the original ram that the b450 refused to boot with. I wish everyone having trouble the best of luck and hopefully asrock sorts out this bios mess soon for you guys that can't return. Kinda stupid though that im using a motherboard that costs more than my cpu! Hopefully it gives me headroom for future upgrades though. Again, best of luck guys! Thank you all for the suggestions and help.
Back to Top
Bol View Drop Down
Newbie
Newbie


Joined: 31 Jul 2019
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bol Quote  Post ReplyReply Direct Link To This Post Posted: 08 Sep 2019 at 1:00am
Last post from me too regarding my B450 gaming itx/ac.
I too gave up and purchased another motherboard. Unlike the previous poster I purchased a rival B450 gaming itx board that after a simple bios update booted perfectly into Windows on the first try with my 3600 installed.

Mine was outside the return window, having used it successfully with a 2200g installed for 8 months. It's now going on eBay with the caveat not to use it with a 3rd gen ryzen cpu. I will get most of my money back, what I won't get back is the month of frustrating time wasted trying to get this to run.
As echoed in this thread previously, other mobo manufacturers can run ryzen 3000 cpu in their board with a simple update, asrock apparently can not.
So for folks who come here for advice and help about the B450 gaming itx, mine is quite simple:
Buy another board.
I won't name the rival manufacturer because I don't think it's right to do so on an official asrock forum.
But a shout to xaltar for his unflinching support and
suggestions, in my case I was flogging a dead horse.
Back to Top
Daveydguk View Drop Down
Newbie
Newbie


Joined: 07 Apr 2019
Status: Offline
Points: 59
Post Options Post Options   Thanks (0) Thanks(0)   Quote Daveydguk Quote  Post ReplyReply Direct Link To This Post Posted: 08 Sep 2019 at 4:16am
Was it a B450 or x570 board you bought regardless of manufacturer ?
Back to Top
 Post Reply Post Reply Page  <1 2930313233 57>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.