ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Ryzen3 2200g not saving vram allocation after BIOS
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Ryzen3 2200g not saving vram allocation after BIOS

 Post Reply Post Reply
Author
Message
PUPESH View Drop Down
Newbie
Newbie


Joined: 08 Aug 2019
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote PUPESH Quote  Post ReplyReply Direct Link To This Post Topic: Ryzen3 2200g not saving vram allocation after BIOS
    Posted: 08 Aug 2019 at 8:28pm
After I updated the BIOS of my Asrock AB350m Pro4 the vram allocation settings are not saving for some reason.

I tried setting it to 64 MB but it reverts it back to default (2 GB vram) and it leaves me with only 6 GB of system memory.

Already tried resseting the CMOS.
Back to Top
csaban View Drop Down
Newbie
Newbie


Joined: 30 Aug 2019
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote csaban Quote  Post ReplyReply Direct Link To This Post Posted: 30 Aug 2019 at 9:15pm
Sorry, I don't have a solution, just wanted to comment that I have the same problem.

I have the same processor with a B450M-HDV R4.0 motherboard with BIOS version 2.30. I just purchased this system one week ago.

The initial setting is 2G for the Vega Chip and I am unable to change to any other value. After saving the changes and going back to the BIOS, the related settings are back to AUTO (from Forces / 1GB).

I have not tried the CMOS reset yet. I was hoping that would help, but looks like it already did not help you.
--
csaban
Back to Top
Vulpie05 View Drop Down
Newbie
Newbie


Joined: 26 Dec 2018
Status: Offline
Points: 40
Post Options Post Options   Thanks (0) Thanks(0)   Quote Vulpie05 Quote  Post ReplyReply Direct Link To This Post Posted: 02 Sep 2019 at 11:13pm
I can't help either, but I was curious and tested this on my B450 Pro4 with a 2200G. Under Advanced->Onboard Devices Configuration->UMA frame buffer size the default setting has been Auto. I believe this setting has been allocating 2 GB for my system. I changed the setting to 64 MB, and it appears to have retained that setting both in Windows and BIOS (version 3.50). I changed back to Auto, and it stayed at 64 MB. I then changed the setting to 2 GB, which worked, and then going back to auto 2 GB was retained.
Back to Top
csaban View Drop Down
Newbie
Newbie


Joined: 30 Aug 2019
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote csaban Quote  Post ReplyReply Direct Link To This Post Posted: 07 Sep 2019 at 10:19pm
Based on your post I tried this again.
Under Advanced\North Bridge Configuration I limited the UMA Frame buffer to 1G, this limited the VRAM to 1G, so I guess that is a success.

I was hoping that I can just change the VRAM under Advanced\AMD CBS\NBIO Common Options\GFX Configuration - but as I said earlier this never takes.

I think I am ok with this Northbridge UMA limit for now.
I'll check online for more information about the settings.

Thank you,
--
csaban
Back to Top
Vulpie05 View Drop Down
Newbie
Newbie


Joined: 26 Dec 2018
Status: Offline
Points: 40
Post Options Post Options   Thanks (0) Thanks(0)   Quote Vulpie05 Quote  Post ReplyReply Direct Link To This Post Posted: 08 Sep 2019 at 11:50pm
Its amazing what a search on the message boards turns up (I say that for myself, not to you).

Several people have asked this question before, and pretty much all responses from ASRock TSD say to do the following:

Under Advanced->AMD CBS->NBIO Options->GFX Config, change the following:
Integrated Graphics Controller->Forces
UMA Mode->UMA_Specified
UMA Frame Buffer size-> (size you want to allocate for APU memory)

This is outlined in the FAQ here: https://asrock.com/support/faq.asp?id=464

I tried this with 64 MB buffer size, and checking Windows task manager it came up as ~56 MB (close enough, I suppose). I also tried setting at 3 GB, and task managed proved this as well.

However, as the FAQ points out, if you want 4 GB or more, you need to change CSM support to disable. When I set the buffer size to disable, task manager shows dedicated video memory as 2.0 GB. I'm assuming bios or Windows did not like the 4.0 GB and reverted back to 2.0 GB. However, when I checked bios it was still set to 4.0 GB.

I then tried changing CSM to disabled, but it didn't work. That is, my computer would post (show the ASRock splash screen), but then boot into Bios. It never would let me get back into Windows. So, I have it set to 3 GB for now, but I want to find out how to get 4 GB of video memory. I have 16 GB total for my computer, so I don't think it is a big stretch to go that high for dedicated video memory.

As for the UMA frame buffer size under Advanced->onboard devices configurator, I'm not sure what that does now. I currently have it set to Auto.

I hope this helps!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.188 seconds.