ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - No display after bios update
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

No display after bios update

 Post Reply Post Reply
Author
Message
Raflur View Drop Down
Newbie
Newbie


Joined: 14 Aug 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Raflur Quote  Post ReplyReply Direct Link To This Post Topic: No display after bios update
    Posted: 14 Aug 2019 at 6:35am
Hi,
I hope someone can help me.
Yesterday asrock released an update for the X399 Phantom Gaming 6 Motherboard. Today I?e tried to to install it over Instant flash.
Everything were looking good till it restarted the pc. I?e waited a few minutes (maybe 5-10), but the Monitors weren? showing anything.
Can I set the bios to back to factory version without the help anything beside the mainboard?
The biggest problem is that I moved to the US and don? have another pc to test or load something.
Everything seems to running beside the fact that I don? get a picture on one of my two monitors.
Thank you for any help
Back to Top
joop1981 View Drop Down
Newbie
Newbie


Joined: 08 Oct 2017
Location: earth
Status: Offline
Points: 27
Post Options Post Options   Thanks (0) Thanks(0)   Quote joop1981 Quote  Post ReplyReply Direct Link To This Post Posted: 18 Aug 2019 at 6:50pm
Take out any hardware item you don't need to start up like 2nd DDR4 memory module if you use a kit, HDD's, remove the second monitor and cable. Power on your monitor.
Back to Top
Raflur View Drop Down
Newbie
Newbie


Joined: 14 Aug 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Raflur Quote  Post ReplyReply Direct Link To This Post Posted: 18 Aug 2019 at 10:42pm
Hi, thank you for the answer, but I tried that already (and of course a few other things since I wrote this thread) and it didn't helped.
My solution was/is I contacted Asrock they said to send it in, but that would take (I think) weeks at least, but I need the PC asap and not in weeks, so I buyed a new board (Gigabyte).
It is sad that Asrock released an Bios which broke my bios, but at least I know that I am never going to buy Asrock boards again.
Again thanks for your help.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.064 seconds.