ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Asrock B450 pro4 not coming on in my house
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Asrock B450 pro4 not coming on in my house

 Post Reply Post Reply Page  <12
Author
Message Reverse Sort Order
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5426
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 23 Aug 2019 at 12:30am
I see you listed your location is Nigeria, having lived and worked in Africa I
have to ask, is your power low at your home at the moment? I know in several countries I have worked in in Africa it was common for people to get as low as
150v instead of 220v. You mentioned UPSes but if they are under powered it
would still be an issue. You need at least a 650w UPS for your system, I am
assuming you connect all your powered peripherals to it too.

If you have multiple UPSes then try connecting a UPS (the most powerful one you
have) to just the PC and use another one to power any other peripherals display, printers, scanners etc).   

When a power transformer is overloaded it will often output voltage bellow it's
operating specifications so if it has been particularly hot in your area (for
example) and people have been heavily using ACs it could explain low power. If
your UPS has been forced to compensate for this low power for a prolonged
period of time it will have drained it's battery. These are just theories but
generally speaking, if a system works in one place but not another there is a
power issue at the location it will not work.

Good luck
Back to Top
alander View Drop Down
Newbie
Newbie
Avatar

Joined: 14 Feb 2019
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote alander Quote  Post ReplyReply Direct Link To This Post Posted: 22 Aug 2019 at 10:55pm
If the technician got it working with all of your same components then it could just be that something is loose or not connected properly.
Back to Top
hekatoncheir View Drop Down
Newbie
Newbie
Avatar

Joined: 22 Aug 2019
Location: Nigeria
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote hekatoncheir Quote  Post ReplyReply Direct Link To This Post Posted: 22 Aug 2019 at 4:41pm
Good day good people. Please I needed your help with my desktop. A computer technician built a pc for me based on my specifications which are:
AMD Ryzen 5 3400g
AsRock b450 Pro 4 motherboard
Adata 4gb ram and Ballistix 4gb ram
ZSseries 650w psu
128gb ssd and 1 tb hdd

When he delivered it to me 3 weeks ago, it was working perfectly up until 2 days ago when I put it to sleep and went to sleep myself. I woke up the next day and turned it on, nothing. No power any where except one of the lights on the fan. Amd fan was off and no case fans came on. I tried another cord and same thing no power. I called in the technician and he brought with him another power supply (corsair 1000w) and another power cord. It did not come on despite testing with another psu. So he took it back to his work place to have a look at it thoroughly. He called m and told me it came on in its work place and that he did not do anything. He sent me pictures of the pc working well and booting into desktop where I saw my desktop picture so all was OK. He brought it back to my home yesterday and again it didn't come on. Nothing. Tried with two different UPS and nothing @ all. All other home appliances are working perfectly. Is there something wrong with my board for it not to work in my home? Thank you. I really need advice on what to do...
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.