ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Windows won't boot from M.2 ssd
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Windows won't boot from M.2 ssd

 Post Reply Post Reply
Author
Message
polarexpress View Drop Down
Newbie
Newbie


Joined: 25 Aug 2019
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote polarexpress Quote  Post ReplyReply Direct Link To This Post Topic: Windows won't boot from M.2 ssd
    Posted: 25 Aug 2019 at 11:02pm
Hi,

I recently build mini itx with asrock b450 gaming/itx motherboard.
Windows 10 has succesfuly booted HDD but when I install to M.2 ssd won't boot up.

While windows setup in M.2 SSD, I disabled CMS from boot menu.

Did you have any experince with this similar sitution ?
Back to Top
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Gemany, Berlin
Status: Offline
Points: 410
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Posted: 26 Aug 2019 at 12:15am
Check this in the bios:

Exit->Boot Override:
There should be an entry with the Windows Bootmanager (your M2 SSD)

Boot->Boot Options Priorities:
Select Windows Bootmanager as Boot Option #1
R7 2700X
Scythe Mugen5
Fata X370 Pro Gaming
G-Skill 2 x F4-3200C14-16GTZ
GeForce GTX 1080 Ti
NVME 960 PRO 512GB, 960 EVO 1TB
PS/2 Kb, USB Mouse
DarkPowerProP9 750W
Back to Top
polarexpress View Drop Down
Newbie
Newbie


Joined: 25 Aug 2019
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote polarexpress Quote  Post ReplyReply Direct Link To This Post Posted: 26 Aug 2019 at 1:30am
Unfortunately I did as you explained both options but nothing.

SSD : Adata XPG SX6000 Lite 128GB 1800/600 MB/s PCIe M.2 SSD (ASX6000LNP-128GT-C)

Back to Top
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Gemany, Berlin
Status: Offline
Points: 410
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Posted: 26 Aug 2019 at 2:43am
And you did remove your HDD when installing and now?
Another bios entry to check:
Advanced\CPU Configuration\AMD fTPM switch disabled?

BTW: Topic: How To Install Windows On A PCIe SSD
http://forum.asrock.com/forum_posts.asp?TID=1236&title=how-to-install-windows-on-a-pcie-ssd
R7 2700X
Scythe Mugen5
Fata X370 Pro Gaming
G-Skill 2 x F4-3200C14-16GTZ
GeForce GTX 1080 Ti
NVME 960 PRO 512GB, 960 EVO 1TB
PS/2 Kb, USB Mouse
DarkPowerProP9 750W
Back to Top
polarexpress View Drop Down
Newbie
Newbie


Joined: 25 Aug 2019
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote polarexpress Quote  Post ReplyReply Direct Link To This Post Posted: 26 Aug 2019 at 6:06pm
I removed HDD and I installed again following options;

Check Advanced\CPU Configuration\AMD fTPM switch disabled
Check Launch Storage OProm UEFI on CMS page
Check selected only UEFI USB storage for installation
Check Sata mode ACHI or Raid

Windows has been installed automatically with GPT formatted

After installation return to bios and I check the boot options m.2 SSD
But won't boot up again from SSD.It's says on screen please insert disk or usb storage.......


Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.031 seconds.