ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Bad Wifi performance
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Bad Wifi performance

 Post Reply Post Reply
Author
Message
Seeker05 View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote Seeker05 Quote  Post ReplyReply Direct Link To This Post Topic: Bad Wifi performance
    Posted: 11 Sep 2019 at 2:06pm
Hi,

I have built a PC B450 ITX/AC, everything seems fine, but I get poor WIFI performance. Even close to the router but the wifi speed is still poor. I reinstall WIN10 but no help. For my case, is there anything I can try more?
Thanks,
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 2092
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 11 Sep 2019 at 2:27pm
Dear Seeker05,

Greetings, this is ASRock TSD.


Referring to your question about Wi-Fi speed, kindly remove the Wi-Fi metal case from the motherboard to check if the cables of the antennas are connected tightly to the Wi-Fi card.

Also, kindly install the Intel Wireless Lan driver from the link below:
https://www.asrock.com/MB/AMD/Fatal1ty%20B450%20Gaming-ITXac/index.asp#Download


Thanks!

All the best,
ASRock TSD
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.063 seconds.