ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - B450 Pro4 CSM Boot Loop
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

B450 Pro4 CSM Boot Loop

 Post Reply Post Reply
Author
Message
Vulpie05 View Drop Down
Newbie
Newbie


Joined: 26 Dec 2018
Status: Offline
Points: 40
Post Options Post Options   Thanks (0) Thanks(0)   Quote Vulpie05 Quote  Post ReplyReply Direct Link To This Post Topic: B450 Pro4 CSM Boot Loop
    Posted: 13 Sep 2019 at 11:20am
I have a B450 Pro4 motherboard (bios version 3.50), Ryzen 2200G, no discrete GPU, 16GB FlareX memory 3200C14(2x8 GB, manually timed at 3200 with fast settings), 500 GB SSD, Windows 10 Home 1903. I want to allocate 4 GB or more of memory for the Vega 8 graphics. Per the FAQ, I am supposed to disable CSM. When I disable CSM, save and quit, I get the ASRock splash screen, and then I'm back into bios, no matter how many times I save and quit. Once I revert CSM back to enable, I'm able to boot into Windows. Any ideas what I am doing wrong?
Back to Top
cx5 View Drop Down
Newbie
Newbie
Avatar

Joined: 15 Sep 2017
Location: Hong Kong
Status: Offline
Points: 151
Post Options Post Options   Thanks (0) Thanks(0)   Quote cx5 Quote  Post ReplyReply Direct Link To This Post Posted: 16 Sep 2019 at 8:54am
Good morning @Vulpie05,

Could by any change you are using MBR and hence not able to use CSM off, see https://docs.microsoft.com/en-us/windows-hardware/drivers/bringup/switch-from-legacy-mbr-disk-to-gpt-disk-with-windows-10
1700XtaichiX370HISvega64CX750MOptane900P@M2ultraRISER 420x140x28>GPU>420x140x86>CPU coreV71
CMK32GX4M2B3000C15@2933,141515153252573231010444401410631661447@1.34v84ns
3266@1.55Vsoc1.12v74ns C1618193860
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.