ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X370 Taichi 5.80 issue with DisplayPort & CSM
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X370 Taichi 5.80 issue with DisplayPort & CSM

 Post Reply Post Reply
Author
Message
jinsk8r View Drop Down
Newbie
Newbie


Joined: 16 Sep 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote jinsk8r Quote  Post ReplyReply Direct Link To This Post Topic: X370 Taichi 5.80 issue with DisplayPort & CSM
    Posted: 16 Sep 2019 at 11:49pm
TL;DR: Monitor doesn't display until login screen when using DisplayPort with EFI bios (CSM disabled) and I need a workaround.

I once updated my 1080 Ti's GOP (https://www.nvidia.com/en-us/drivers/nv-uefi-update-x64/) to solve the issue with CSM disabled & DisplayPort (that when using DP with EFI bios (CSM disabled), monitor doesn't show up until login screen), and it solved it (partly, sometime it came up again, but not much). And now after updated my X370 Taichi Bios to version 5.80, the issue came back again.So I did a few searches and turned out that nVidia Firmware Update Tool hasn't been updated for a few years, and that I need to flash my 1080 Ti's BIOS if I want to update GOP manually (https://www.win-raid.com/t892f16-AMD-and-Nvidia-GOP-update-No-requests-DIY.html).
Here comes some another issues, when I use NVFlash64 --protectoff my computer freeezes, black screen and I need to hard reset, so I don't want to flash it just in case somethsding goes wrong ( I dont have iGPU). I tried to save BIOS using NVFlash, freezes; tried GPU-Z to save BIOS, freezes; and that also happens when I try to update nVidia drivers, I need to use DDU to remove the driver everytime I want to update it. I think it's software or Windows related to I turned off Windows Defender, Afterburner, AIDA64 and nothing helps. Anyone has experience in this?

I think I need to flash the BIOS in DOS, can someone give me a guide to NVFlash in DOS? Thank you.
Back to Top
jinsk8r View Drop Down
Newbie
Newbie


Joined: 16 Sep 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote jinsk8r Quote  Post ReplyReply Direct Link To This Post Posted: 17 Sep 2019 at 12:37am
EDIT: I flashed the new BIOS with updated GOP for my 1080 Ti in Safe Mode, all went well, but it doesn't fix the issue with CSM & DisplayPort, definitely 5.80 and and 5.60 BIOS problem.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.031 seconds.