ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X570 Taichi - Wake On Lan does not work
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X570 Taichi - Wake On Lan does not work

 Post Reply Post Reply
Author
Message
AndSol View Drop Down
Newbie
Newbie


Joined: 29 Sep 2019
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote AndSol Quote  Post ReplyReply Direct Link To This Post Topic: X570 Taichi - Wake On Lan does not work
    Posted: 29 Sep 2019 at 3:42am
Hi,

I just recently acquired X570 Taichi, the problem that I have is that I can't setup Wake On Lan, I have been trying to figure what is the problem the whole day. Here is what I tried:

1. BIOS setting:
Step1: Power on the system.
Step2: When POST screen is displaying then press the keyboard "Del" key to enter to the BIOS setting.
Step3: Switch to Advanced page, select ACPI Configuration, change PCIE Devices Power On to Enabled.
Step4: Press "F10" key to save the BIOS setting and restart the system.

2. Network Adapter
I have ticked the following options in power management at the properties section.
Allow the computer to turn off this device to save power,
Allow this device to wake the computer,
Only allow a magic packet to wake the computer,

In the Intel ProSet Adapter Configuration Utility
I have enabled Wake on Magic Packet, Wake on Magic Packet from power-off state

I have downloaded the latest intel network drivers from intel webpage.

I have tried downloaded Wake-On-Lan Packet Sniffer and confirmed that the packets are being sent to machine.

---------------------------Wake-On-LAN Magic Packet---------------------------

Time received:
      09/28/19      20:27:43
UDP Header:
     |-Source IP     :     192.168.0.50
     |-Destination IP     :     192.168.0.111
     |-Source Port     :     34031
     |-Destination Port     :     9
     |-UDP Length     :     110
     |-UDP Checksum     :     52302
MAC Address:
      70 85 C2 DD 5F 5A
Raw Data (102 bytes):
      FF FF FF FF FF FF 70 85 C2 DD 5F 5A 70 85 C2 DD
      5F 5A 70 85 C2 DD 5F 5A 70 85 C2 DD 5F 5A 70 85
      C2 DD 5F 5A 70 85 C2 DD 5F 5A 70 85 C2 DD 5F 5A
      70 85 C2 DD 5F 5A 70 85 C2 DD 5F 5A 70 85 C2 DD
      5F 5A 70 85 C2 DD 5F 5A 70 85 C2 DD 5F 5A 70 85
      C2 DD 5F 5A 70 85 C2 DD 5F 5A 70 85 C2 DD 5F 5A
      70 85 C2 DD 5F 5A


---------------------------Wake-On-LAN Magic Packet---------------------------

Time received:
      09/28/19      20:40:04
UDP Header:
     |-Source IP     :     192.168.0.50
     |-Destination IP     :     192.168.0.111
     |-Source Port     :     59005
     |-Destination Port     :     7
     |-UDP Length     :     110
     |-UDP Checksum     :     27330
MAC Address:
      70 85 C2 DD 5F 5A
Raw Data (102 bytes):
      FF FF FF FF FF FF 70 85 C2 DD 5F 5A 70 85 C2 DD
      5F 5A 70 85 C2 DD 5F 5A 70 85 C2 DD 5F 5A 70 85
      C2 DD 5F 5A 70 85 C2 DD 5F 5A 70 85 C2 DD 5F 5A
      70 85 C2 DD 5F 5A 70 85 C2 DD 5F 5A 70 85 C2 DD
      5F 5A 70 85 C2 DD 5F 5A 70 85 C2 DD 5F 5A 70 85
      C2 DD 5F 5A 70 85 C2 DD 5F 5A 70 85 C2 DD 5F 5A
      70 85 C2 DD 5F 5A

But as soon as I put computer to sleep or turn it off, it will not wake up until I switch on it manually. Could please someone help me to figure it out I literraly don't know what else I can try.

Thank you in advance.
Back to Top
AndSol View Drop Down
Newbie
Newbie


Joined: 29 Sep 2019
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote AndSol Quote  Post ReplyReply Direct Link To This Post Posted: 29 Sep 2019 at 9:18pm
As a matter of fact I have NAS on my network that also has WOL, and when I send magic packet to it, it wakes up, unlike my pc.
Back to Top
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Germany, Berlin
Status: Offline
Points: 706
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Posted: 29 Sep 2019 at 10:27pm
In my bios i also have:
Advanced\AMD PBS\LAN Power Enable
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE
Back to Top
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Germany, Berlin
Status: Offline
Points: 706
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Posted: 01 Oct 2019 at 6:14pm
And check, that "Fast Start" option on windows 10 shutdown is disabled.
Furthermore, there are entries in the Asrock-FAQ:
https://www.asrock.com/support/faq.asp?k=wake+on+lan
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE
Back to Top
robb213 View Drop Down
Newbie
Newbie
Avatar

Joined: 24 May 2020
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote robb213 Quote  Post ReplyReply Direct Link To This Post Posted: 24 May 2020 at 2:03am
I'll necro this with useful info for others. Step #1, #2, #3 are just a Google search for those who don't know.

1) Enable wake on magic packets for your NIC within Windows via adapter.
2) Allow the NIC (aka "this device") to wake the machine.
3) Disable "Fast startup" in Windows.
4) Enable "Boot from Onboard LAN" in your BIOS/EFI. On reboot you can remove/disable all the extra NIC boot options for PXE, HTTP, etc. You will also see a new section appear under the Advanced tab that is the name of your NIC. I.e. Intel(R) I211 Gigabit Network Connection. You will have a Wake on Lan setting within this.
5) Disable Advanced\AMD PBS\Clock Power Management (CLKREQ#).
6) Enable "PCIE Device Power On" in Advanced--one of the sub-menus.


After having WoL work for 6+ months, it just stopped working. This was likely the fact I updated the Intel NIC driver directly from Intel. As a result I had to enable boot from onboard lan and disable CLKREQ# even though I had it enabled for months. I'm surprised WoL was only visible when boot from onboard LAN was enabled as that type of setting is typically reserved for HTTP or PXE boot environments, like the Microsoft SCCM environment I manage at work.
Back to Top
Sevenoneone View Drop Down
Newbie
Newbie


Joined: 13 Apr 2021
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote Sevenoneone Quote  Post ReplyReply Direct Link To This Post Posted: 13 Apr 2021 at 9:10pm
Necro-ing a necro... Joined because this post helped me get WOL working before, and then it broke for me again. Maybe due to windows update or other reason, I'm not sure. One thing that helped get Wake On LAN back in action was installing the latest Intel drivers 26.2, and then the Intel ProSet software which reveals a setting Wake on Magic Packet from power off
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.063 seconds.