ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - No XMP profile, no option to change timings
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

No XMP profile, no option to change timings

 Post Reply Post Reply
Author
Message
Peppa View Drop Down
Newbie
Newbie


Joined: 03 Oct 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Peppa Quote  Post ReplyReply Direct Link To This Post Topic: No XMP profile, no option to change timings
    Posted: 04 Oct 2019 at 12:19am
I have the following PC build:

Ryzen 5 1600
Asrock B450 pro4
2 sticks of DDR4 2666MHz Samsung (OEM) T-die Dual Rank memory running in dual channel with timings 20-19-19-19-43,unbuffered (M378A1G43TB1-CTD)
(one of the ram stick with stock timings 20-19-19-19-43, another with stock timings 19-19-19-43). Bios version is p3.20 which came with my MB.

I'm new to overclocking, so as a first step I decided at least to enable the 19-19-19-19-43 timing, which I know they both support 100%, because I checked this in Thyphoon Burner.

I went to BIOS and there choose OC Tweaker. But there wasn't any XMP profile. All youtubers who did overclocking on Asrock MBs had this option. I was surprized but thought this won't be a problem and I will change timing manually. So I went into DRAM timing configuration. There are two columns, one of which lists the corresponding timings, and another says 'Auto' opposite to each timing in the first column. The first column is not editable directly. So I pressed the 'Auto' on the second column corresponding to the 1st timing, the one I wanted to change from 20 to 19, and typed 19. Well, the 'Auto' sign changed to 19, but the first column remained at 20. I was a little surprized, but decided to save and exit. Checked the timings in Windows and it was 20-19-19-19-43 as before.

Then I searched if anybody had this problem before. There were several people who had it in 2017-2018, but their problem was solved by upgrading BIOS. I went to support page of my MB and found all BIOS updates. All of the updates that came after mine had a warning that it won't be possible to revert BIOS upgrade to previous version in case something went wrong, and they also advized not to do any BIOS upgrade if the system was running smoothly. So I didn't upgrade BIOS.

Another set of people said that there was another option to change timings in Advanced -> AMD CBS. I went there, checked every folder, but couldn't find anything related to DRAM timings.

I don't think the problem is in the RAM. I read around 50 reviews by other people who purchased the RAM M378A1G43TB1-CTD in the local vendor, and they all were able to OC it, some of them on Ryzen CPUs.

I'm completey lost here. Did i missed anything obvious? How do I overclock RAM in my system?
Back to Top
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Germany, Berlin
Status: Offline
Points: 706
Post Options Post Options   Thanks (1) Thanks(1)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Posted: 04 Oct 2019 at 1:32am
There is a dependency for tCL to GearDown mode.
If GearDown mode is enabled, only even tCL values are valid, so it will be rounded up to the next even value (in some configurations).

But the XMP profile thing is strange...
You have no Load XMP setting?
Loading bios defaults and restart -> no change?
CMOS clear -> no change?

You should learn more about DRAM configuration for Ryzen.
https://www.overclock.net/forum/13-amd-general/1640919-new-dram-calculator-ryzena-1-6-2-overclocking-dram-am4-membench-0-8-dram-bench.html
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE
Back to Top
gizmic View Drop Down
Groupie
Groupie
Avatar

Joined: 13 Jun 2018
Location: Hong Kong
Status: Offline
Points: 661
Post Options Post Options   Thanks (1) Thanks(1)   Quote gizmic Quote  Post ReplyReply Direct Link To This Post Posted: 04 Oct 2019 at 2:23am
someone used to have this problem with oem ram (ram without xmp)

load up the default corsair xmp so the manual dram timings will be enabled

Back to Top
Peppa View Drop Down
Newbie
Newbie


Joined: 03 Oct 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Peppa Quote  Post ReplyReply Direct Link To This Post Posted: 04 Oct 2019 at 3:40am
Indeed, seems like only even tCL values are valid. Manually setting it to 18 worked.

So, problem solved. Thanks.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 9.920 seconds.