ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Z390 Taichi Ultimate + Thunderbolt 3 AIC issue
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Z390 Taichi Ultimate + Thunderbolt 3 AIC issue

 Post Reply Post Reply
Author
Message
adde1024 View Drop Down
Newbie
Newbie


Joined: 04 Nov 2019
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote adde1024 Quote  Post ReplyReply Direct Link To This Post Topic: Z390 Taichi Ultimate + Thunderbolt 3 AIC issue
    Posted: 04 Nov 2019 at 7:31pm
Hi,

I have just upgraded my build to a Z390 Tacihi Ultimate with Intel 9600k processor. Everything is working fine with all cores overclocked to 5Ghz.

The installation and setup was done on a hdmi screen with the integrated graphics.

After that everything is finished I wanted to add a thunderbolt 3 AIC card from Asrock.

I did the following:
- Connected the Thunderbolt 3 AIC card to the last PCI slot
- Connected large displaypor from the Thunderbolt card to the large displayport connector in the integrated GPU
- Connected the internal cable between the card and the MB
- Connected a thunderbolt 3 monitor with a thunderbolt 3 cable.

Without doing anything in the BIOS its working. I'm just typing on it now.

But I can't get 5K. As soon as I enable the "Thunderbolt discrete" option in the bios my computer wont start. I need to reset the bios to make it work.

What is going on?

Do I need to enable in the Bios to get the full interface performance?

Right now I can only us my 5k monitor in 4K resolution.

Any help would be appreciated
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.062 seconds.