ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - HDD no detected in bios
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

HDD no detected in bios

 Post Reply Post Reply
Author
Message
Rubi View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote Rubi Quote  Post ReplyReply Direct Link To This Post Topic: HDD no detected in bios
    Posted: 08 Nov 2019 at 12:02pm
Hello, my new B450 Gaming K4 cannot detect any sata hdd in BIOS, only NVME M.2 is okay.
And it contain my WIN10 OS, but no HDD detected.

Please help me about this issue.
Thank you!!
Back to Top
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Germany, Berlin
Status: Offline
Points: 547
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Posted: 08 Nov 2019 at 6:11pm
Bios setup properly?
Advanced\Storage Configuration
SATA Controller(s): Enabled
SATA mode: AHCI mode
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 2155
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 08 Nov 2019 at 6:13pm
Dear Rubi,

Greetings, this is ASRock TSD.


According to your question, we have some tips for you to check the HDD detection.

1. Please enter BIOS setup and press [F9] to load BIOS default settings.

2. Under BIOS setup > Advanced tab > Storage devices, please check if the HDD is detected.

3. In BIOS > Boot tab, please check if the HDD is recognized under Boot Option.

4. Power on the system and press [F11] to enter Boot Menu to check if the HDD is recognized.

5. Unplug the AC power and install the HDD to other SATA ports to verify; be sure to connect a SATA power to your HDD.


Thanks!

All the best,
ASRock TSD
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.