ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Can't change OC settings in bios
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Can't change OC settings in bios

 Post Reply Post Reply
Author
Message Reverse Sort Order
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Germany, Berlin
Status: Offline
Points: 706
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Topic: Can't change OC settings in bios
    Posted: 16 Nov 2019 at 6:08am
I posted:
Just leave all clock and VCore settings in the bios at default.
Sorry, i forgot, that PBO could be activated by default respectively is ON by AUTO.
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE
Back to Top
skorphil View Drop Down
Newbie
Newbie


Joined: 04 Nov 2019
Status: Offline
Points: 9
Post Options Post Options   Thanks (1) Thanks(1)   Quote skorphil Quote  Post ReplyReply Direct Link To This Post Posted: 16 Nov 2019 at 4:20am
Asrock support have answered me and problem has been solved!

I had to disable "Core Performance Boost" in the bios (
Path: Advanced\AMD CBS\CPU Common Options)

Now it is working as expected. Thanks everyone for support!
Back to Top
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Germany, Berlin
Status: Offline
Points: 706
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2019 at 5:08am
Strange. That should work.
When i posted that i just tested it at the same time.
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE
Back to Top
skorphil View Drop Down
Newbie
Newbie


Joined: 04 Nov 2019
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote skorphil Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2019 at 3:38am
Originally posted by Ray62 Ray62 wrote:

Just leave all clock and VCore settings in the bios at default.
Under windows, choose the energy power plan "AMD Ryzen Balanced", goto extended settings and change the max settings for the processor.
This is typically at 100%.
You can run CPU-Z and HWINFO in parallel.
Reduce the max value, the change should be immediately be seen in the tool when you press the takeover button.
To be sure that the clock is reduced under load you can run CPU-Z stress test and HWINFO for showing clocks while you change the max value.


It's not working. CPU frequency do not depend on this. I set at about 70% max and minimal like 60% and still have 3500mhz and start throttle at 95C Tctl. Tried to reboot - no results.
Back to Top
Ray62 View Drop Down
Groupie
Groupie
Avatar

Joined: 01 Jul 2018
Location: Germany, Berlin
Status: Offline
Points: 706
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ray62 Quote  Post ReplyReply Direct Link To This Post Posted: 13 Nov 2019 at 2:45am
Just leave all clock and VCore settings in the bios at default.
Under windows, choose the energy power plan "AMD Ryzen Balanced", goto extended settings and change the max settings for the processor.
This is typically at 100%.
You can run CPU-Z and HWINFO in parallel.
Reduce the max value, the change should be immediately be seen in the tool when you press the takeover button.
To be sure that the clock is reduced under load you can run CPU-Z stress test and HWINFO for showing clocks while you change the max value.
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE
Back to Top
skorphil View Drop Down
Newbie
Newbie


Joined: 04 Nov 2019
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote skorphil Quote  Post ReplyReply Direct Link To This Post Posted: 13 Nov 2019 at 2:05am
Ryzen 1700x
ASRock Fatal1ty B450 Gaming-ITX/ac

Hi, please help me with advice. I'm noob at overclooking and facing strange unlogical stuff and want it to over.
It's all started with poor cooling for my Ryzen 1700x (because of small case and poor cooler) - i've noticed it starts throttling and got an idea to just downclock it(reduce frequency and voltage), to get lower tdp and prevent it from overheating. I thought it was the simplest solution, but hell no...

I started from Ryzen Master Utility. I set 3300mhz and 1.2v, hit apply and... nothing changed. The Ryzen Master and HWinfo still shows peak frequency at 3500mhz, voltage constantly changing 1.2-1.4v and prime95 still cause overheating and cpu start throttle(I noticed it because peak frequency in ryzen master starts to decreasing after CPU hit 95C(Tctrl)
BUT motherboard overclooking utility (F-stream tuning) show thet CPU frequency is 3300 and voltage 1.2

Then i tried to set higher clocks in Ryzen Master... 3600mhz, hit apply and it works somehow. RM started to show peak frequency as 3600 and 1.2v. Then i tried again to decrease clock to 3300mhz, hit apply and it works! Great.

After rebooting cpu frequency were resetted(ryzen master do not save settings, so its ok) and i tried again to start with setting lower frequency without success.
So, in Ryzen master utility the only way to downclock CPU is firstly apply higher clocks and then apply lower clocks. This is already super unlogical.

Ok, after i set CPU to 3300 and 1,2v I've run prime95 and prove that everything working fine - no overheating, no throttling. Great, now i want to set this values in my bios and forget about it.

I opened bios -> OC tweaker -> CPU frequency and voltage -> manual... set 3300 and 1.2, then saved changes, reboot...

after rebooting i opened Ryzen master and... frequency still 3500mhz. Still overheating in prime95... so bios settings somehow ignored.
And the only way to downclock my cpu at the moment is every boot open ryzen master, then increase frequency and then decrease it.

What wrong with it? How can i just set the frequency one time in the bios and forget about this monitoring, manual tuning every time... what i'm doing wrong? What can override the bios settings, how to disable this overriding?

Please, help me to end this ))))

I tried to update bios, tried to uninstall Ryzen Master and F-stream utility. Everything is useless. Bios reported cpu working at 3300, but in the windows it is working at 3492.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.063 seconds.