Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X570 Creator Motherboard trouble
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X570 Creator Motherboard trouble

 Post Reply Post Reply
DicusBarbavici View Drop Down

Joined: 01 Apr 2020
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote DicusBarbavici Quote  Post ReplyReply Direct Link To This Post Topic: X570 Creator Motherboard trouble
    Posted: 01 Apr 2020 at 7:10pm
Last week I put together a new computer as an audio workstation. Running Ableton using a Focusrite Clarett Thunderbolt 2 Interface. At least that was the plan. I have stumbled upon two major problems and after three days of tinkering start to think it might maybe be a faulty Motherboard. Any suggestions would be very welcome.

ASRock x570 Creator
AMD Ryzen 9 3900x boxed
Powercolor Red Devil 5700XT
2x32GB 3000 MT/S Corsair DDR4
Windows 10

Problem 1
No Thunderbolt connection. I am using an apple TB2 to TB3 connector to get my focusrite Clarett 8Pre interface to work but to no avail. I have had a couple of different stages of not working. But whichever BIOS I flash, whatever driver combinations I try it does not seem to work.
The only other Thunderbolt device I have is a Ethernet to TB2 connector which I connected to the Apple TB2 to TB3 connector which also did not get recognized in any way on my computer.

Problem 2
DDR4 memory not being recognized and XMP profile not working. I just receive the new Corsair DDR which are on the Qualified Vendor List, as the memory I had before G.Skill Ripjaws 2x16 3600Mhz did only work at 2166Mhz and selecting the XMP profile made my bios restart 4 times after which the bios reverted back to non XMP and actually got to the post message. The new Corsair DDR4 only recognizes one of the two modules (in A2, not the one in B2) and is not able to run on anything else then 2166Mhz either.

Problem 3
Which is probably very related to problem 2 it takes a long time for the post message to display. Somewhere between 20 and 30 seconds. After post everything is quick but till then it takes long. Also once in every three tries the computer does not even get to post and I have to kill it and restart. I had hoped to fix this by switching to memory that was on the QVL but problem remains. this is the reddit post I did previous to trying the corsair memory slot which made problem 2 en 3 evident. Has got some more in depth about the thunderbolt things I have already tried.

If anyone has got any suggestions they are very welcome.

I paid quite a bit of money for this motherboard, the X570 Creator isn't cheap and had hoped to have a solid Thunderbolt experience and definitely did not expect these memory problems. Could it be a faulty motherboard or are these three resolvable problems?

Back to Top
asrocker123456 View Drop Down

Joined: 15 Aug 2020
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote asrocker123456 Quote  Post ReplyReply Direct Link To This Post Posted: 15 Aug 2020 at 8:27am
I am having the same issue. 3900X with TridentZ Neo Ram F4-3600-C16D-32GTZNC

4 sticks of 16 gb

CPU-Z shows
1 stick, JEDEC 1018 mhz,
1 stick, JEDEC 1066 mhz
1 stick, JEDEC 1066 mhz
1 stick, XMP 1800 Mhz

For your boot problem, turn off fast boot in window, and turn on fast boot in the bios. There might be more settings but that worked for me. If it doesn't work search "fast boot"

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.