ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - onboard Ethernet port no function
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

onboard Ethernet port no function

 Post Reply Post Reply
Author
Message
Skitty View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote Skitty Quote  Post ReplyReply Direct Link To This Post Topic: onboard Ethernet port no function
    Posted: 12 May 2020 at 5:43pm
Good afternoon, today I install my system with X570 Phantom Gaming 4 R5, 3600 CPU with WIN10.
But now I am unable to surf on the internet, after running trouble shooting it says that there is no adapter drive.
So i cannot install LAN driver on it even download from INTEL official website.
No sure if software or motherboard problem, could anyone help me?

Best Regards,
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 3502
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 12 May 2020 at 7:40pm
Dear Skitty,

Greetings, this is ASRock TSD.


According to your question, we provide some suggestions for you to check the Network connection.

1. Please enter to BIOS setup and load BIOS default setting via [F9] key to verify.

2. Under Device Manager, please extend the Network Adapter and check if system can detect Intel(R) I211 Gigabit Network Connection(your network device)
If so, please right click it to uninstall it and restart the system.
After that, please download Intel LAN driver ver.23.5.2 from following link and reinstall it.
http://asrock.pc.cdn.bitgravity.com/Drivers/Intel/LAN/Intel_LAN(v23.5.2).zip

3. If possible, please reinstall a clean Windows 10 OS and check if the Ethernet can work with Windows 10 inbox driver.


Thanks!

All the best,
ASRock TSD
Back to Top
datonyb View Drop Down
Senior Member
Senior Member


Joined: 11 Apr 2017
Location: London U.K.
Status: Offline
Points: 2299
Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 12 May 2020 at 10:42pm
i would also suggest
downloading the LATEST chipset drivers for x570 DIRECT FROM AMD
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold
Back to Top
Skitty View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote Skitty Quote  Post ReplyReply Direct Link To This Post Posted: 15 May 2020 at 12:04pm
Actually the reason is that onboard LAN port is broken so that no matter which lan cable i cannot install into it properly.
I have replace a new one from seller and everything is well.
Thanks all!!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.063 seconds.