ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Graphics Card
  New Posts New Posts RSS Feed - RX 5700 XT Taichi OC+ LEDs not working
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

RX 5700 XT Taichi OC+ LEDs not working

 Post Reply Post Reply
Author
Message
KP2727 View Drop Down
Newbie
Newbie


Joined: 19 Jun 2020
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote KP2727 Quote  Post ReplyReply Direct Link To This Post Topic: RX 5700 XT Taichi OC+ LEDs not working
    Posted: 19 Jun 2020 at 6:35pm
I just upgraded to this new GPU from an Nvidia GTX 1060. I plugged it into my MSI Z370 GAMING PLUS motherboard, and installed the drivers and software I needed. Initially, the RGB lights were on and working. I downloaded Polychrome Sync so I could change the colors, but nothing I did in the program would actually change anything.

After a reboot of my computer, the program doesn't work at all. It keeps giving me an error saying "There is no Asr graphics card and Asr USB LED header!" At some point while trying to fix the problem, the LED lights just stopped turning on at all, so now it doesn't show any light.

I've run DDU to ensure any remnants of my old GPU was gone, I've updated the vBIOS for this GPU, I've uninstalled and reinstalled the drivers and the Polychrome Sync software numerous times, and I'm at my wit's end with no idea of what to do next. At this point, I'll accept just getting the lights back on. Any help would be greatly appreciated!
Back to Top
PatoLeon View Drop Down
Newbie
Newbie
Avatar

Joined: 21 Jun 2020
Location: Chile
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote PatoLeon Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jun 2020 at 1:29pm
I do have the same issue, so any answer from AsRock would be great (besides send it back to seller for warranty). I saw there was a Led Firmware, but the link seems to be broken.
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 3427
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jun 2020 at 5:32pm
Dear KP2727,

Thank you for choosing ASRock.

Regarding your case, please follow the steps to try.
1. Install the latest AMD VGA driver from AMD official website.
2. Update the latest VBIOS.
VBIOS download link:
http://www.asrock.com/Graphics-Card/AMD/Radeon%20RX%205700%20XT%20Taichi%20X%208G%20OC+/index.asp#BIOS
Update method:
http://www.asrock.com/support/BIOSVGA.asp£cat=Taichi
3. Update the LED firmware.
Download link: https://download.asrock.com/TSD/Desktop/RGBFW/GPU/RX5700XT_TCX.zip
Update method:
A. Download the LED firmware and unzip it.
B. Run CMD as administrator.
C. Get into the LED firmware folder.
D. Run [Update_VGA_TAICHI_191101]

Thank you!
Yours truly,
ASRock TSD

Edited by ASRock_TSD - 06 Apr 2021 at 9:15pm
Back to Top
SithSlayer96 View Drop Down
Newbie
Newbie
Avatar

Joined: 23 Dec 2020
Location: Colombia
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote SithSlayer96 Quote  Post ReplyReply Direct Link To This Post Posted: 23 Dec 2020 at 12:06am
hi i have the same problem with my RX5700XT Taichi, i installed the Asrock RGB polychrome, a CMD appears and show it was updating the firmware, but actually, the RGB of my GPU doenst work after that... and now the Asrock RGB Utility Says "there is no Asrock GPU detected"
Back to Top
logmax View Drop Down
Newbie
Newbie


Joined: 29 Dec 2020
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote logmax Quote  Post ReplyReply Direct Link To This Post Posted: 29 Dec 2020 at 5:09pm
Originally posted by SithSlayer96 SithSlayer96 wrote:

hi i have the same problem with my RX5700XT Taichi, i installed the Asrock RGB polychrome, a CMD appears and show it was updating the firmware, but actually, the RGB of my GPU doenst work after that... and now the Asrock RGB Utility Says "there is no Asrock GPU detected"

I have exactly the same problem. Please for some solution to the problem. The motherboard and video card are of the Asrotsk Tich series. Thanks.
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 3427
Post Options Post Options   Thanks (1) Thanks(1)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 30 Dec 2020 at 10:48am
Dear logmax,

Thank you for choosing ASRock.
Please refer to the steps to re-flash the LED FW.
1. Only install one graphics card and boot up the system.
2. Download the FW update tool from the following link.
https://download.asrock.com/TSD/Desktop/RGBFW/GPU/RX5700XT_TCX.zip
3. Unzip the file to the C driver.
4. Run the CMD as administrator.
5. Go to the VGA_FW_Taichi folder by enter the following command.
cd C:\VGA_FW_Taichi
6. Enter the following command to start the FW update process.
Update_RX5700_XT_Taichi.cmd
7. After update the FW, please download the latest Polychrome SYNC from the following link.
https://download.asrock.com/Utility/RGB/PolychromeSYNC(v1.0.14).zip

Thank you!
Yours truly,
ASRock TSD

Edited by ASRock_TSD - 06 Apr 2021 at 9:15pm
Back to Top
logmax View Drop Down
Newbie
Newbie


Joined: 29 Dec 2020
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote logmax Quote  Post ReplyReply Direct Link To This Post Posted: 30 Dec 2020 at 6:00pm
Thank you very much. Everything went OK and now there are no such problems with RGB synchronization. Now, however, there is another major problem after the update. When the card is on the OC BIOS does not load. When you move to Silent bios everything is correct. Can you give me some advice or resolved. Thanks.
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 3427
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 31 Dec 2020 at 10:26am
Dear Logmax,

Thank you for your reply.

Regarding your case, you can try to boot up the system with OC BIOS and use onboard graphics to re-flash the vBIOS.
Download link:
https://www.asrock.com/Graphics-Card/AMD/Radeon%20RX%205700%20XT%20Taichi%20X%208G%20OC+/index.asp#BIOS

Thank you!
Yours truly,
ASRock TSD
Back to Top
DBoss_Tech View Drop Down
Newbie
Newbie


Joined: 04 Apr 2021
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote DBoss_Tech Quote  Post ReplyReply Direct Link To This Post Posted: 04 Apr 2021 at 5:25am
Would you mind posting an updated link to the rgb fw for the 5700xt Taichi. The previous links are no longer working.
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 3427
Post Options Post Options   Thanks (1) Thanks(1)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 06 Apr 2021 at 9:16pm
Dear DBoss_Tech,

Please refer to the link below for the FW for RX5700XT Taichi
https://download.asrock.com/TSD/Desktop/RGBFW/GPU/RX5700XT_TCX.zip

With thanks,
ASRock TSD
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.078 seconds.