ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - APP Shop - This utility is not for this platform!
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

APP Shop - This utility is not for this platform!

 Post Reply Post Reply Page  <12
Author
Message
Odey View Drop Down
Newbie
Newbie


Joined: 27 Jun 2020
Location: Belgium
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote Odey Quote  Post ReplyReply Direct Link To This Post Posted: 03 Jul 2020 at 12:46am
After a clean windows installation, steps 1-5 were successful. But step 6 failed. Still same problem: installation of APP Shop succeeds, but error message when executing: "This utility is not for this platform!"
Back to Top
Krx View Drop Down
Newbie
Newbie


Joined: 06 Mar 2020
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote Krx Quote  Post ReplyReply Direct Link To This Post Posted: 26 Jul 2020 at 7:16pm

Same issue
App Shop and Phantom game tuning was working before
and since last week both stopped working.

Upon launch it throws this:

Error 0xfffe
"This Utility is not for this platform!"

Tried to reinstall latest versions, but nothing.

Also this mobo has constant problems with intel lan goin to sleep
and Win 10 cannot find it on next restart.
Only after fiddling with deep sleep settings in uefi and several restarts with 4 min of waiting with unplugged PC it works again,
untill it decides to stop again.

Also every so, windows or uefi forgets default boots sequence and
I need to reset it again and again.

This mobo is bad!

Ryzen 9 3900X
Windows 10 pro latest
X750 Phantom Gaming 4
Bios P3.00 - 06/17/2020


This mobo is bad!
Back to Top
Odey View Drop Down
Newbie
Newbie


Joined: 27 Jun 2020
Location: Belgium
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote Odey Quote  Post ReplyReply Direct Link To This Post Posted: 01 Aug 2020 at 2:02am
My problem has been solved by following exactly the same steps as in the ASRock test procedure:

mail from ASRock support:

----------------
Here is how we test

1.       BIOS defaults (F9)

2.       Download the latest Windows 10 (ISO) version via the media creation tool, and don't put it on DVD or USB stick

3.       Format a USB stick under NTFS

4.       Double click on the ISO file (it will open as a virtual DVD)

5.       Copy the content from this virtual DVD to the USB stick

6.       Start the system, and press F11 to get into the boot menu

7.       Select the UEFI USB device (see screenshot), this will install Windows in GPT mode (please connect only the device you want to install Windows on)

8.       Do a custom install, and wipe all partitions from the drive, then continue the installation

Once the Windows installation is complete, please go to the download page on our website

https://www.asrock.com/mb/AMD/B550%20Pro4/index.asp#Download



You need to download the following drivers/tools, I put them in the same order you need to install them

1.       AMD chipset driver, this must always be installed before installing any other software or drivers.

2.       Realtek High Definition Audio Driver

3.       Realtek LAN driver

4.       Nahimic3 Utility

5.       ASRock Polychrome RGB

6.       Appshop

In fact you don't need the appshop, because all drivers and BIOS releases can be found on our website

When the ASRock Plochrome RGB tool is installed, it will always detect the hardware and run a firmware check after you close and restart it, it will update the firmware on the RGB controller on the board, please give it a few minutes

----------------

My experience:

Differences between my previous (failed) try:
This drive was never used before and clean vs. Windows was already installed on the drive*
I installed Windows from a USB stick vs. Clean installation of Windows from Start > Settings > Reset this PC > Get started *Pop-up* Remove everything
Local Microsoft Account vs. Existing Online Mircosoft Account
No license activated vs. Valid license activated
Language: English (US) vs. Default recommended option: Nederlands/Dutch
(Left: successful vs Right: failed installation)

*The old SSD came from a completely different setup (Intel based, not AMD)

The Ethernet cable was connected all the time during both installations.
With the successful method with the USB stick, I never had to enter an activation code or log in with my microsoft account,
but my digital license was successfully activated on this computer.
The license was probably taken over automatically via USB and verified because the ethernet cable was still plugged in.
Back to Top
Krx View Drop Down
Newbie
Newbie


Joined: 06 Mar 2020
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote Krx Quote  Post ReplyReply Direct Link To This Post Posted: 01 Aug 2020 at 3:22am
Hi

So to fix just one (other ones works perfectly normal) faulty program, which was working fine before and suddenly just stopped working, I "only" need to do:

- format
- clean windows install
- install all drivers
- install all (many) programs I currently use
- fine tune windows and programs to meet my work habit?

In my case, this is approx 5 days of wasted time.

And there is no guarantee that Asrock program will not stop working in 6 months after fresh install, like it did it before.

I solved my issue by switching to MSI Afterburner instead, in like 15 mins of setup and fine tunning.

Thanks for the info though

Best Regards
Back to Top
Odey View Drop Down
Newbie
Newbie


Joined: 27 Jun 2020
Location: Belgium
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote Odey Quote  Post ReplyReply Direct Link To This Post Posted: 01 Aug 2020 at 5:07am
Thank you too for the information!
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.