ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Realtek 2.5Gbe RTL8125 NDIS Reset Problem
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Realtek 2.5Gbe RTL8125 NDIS Reset Problem

 Post Reply Post Reply Page  <1 3456>
Author
Message
matthys70 View Drop Down
Newbie
Newbie


Joined: 01 Jan 2021
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote matthys70 Quote  Post ReplyReply Direct Link To This Post Posted: 02 Jan 2021 at 3:46am
Just an update:

Driver version 10.45.928.2020 didn't work either. But I found this as well and trying now:

Go to the advanced properties tab of the Realtek Gaming 2.5 GbE. Set these properties to disabled. Advanced EEE, Energy-Efficient Ethernet, Gigabit Lite, Green Ethernet, Power Saving Mode.
Back to Top
matthys70 View Drop Down
Newbie
Newbie


Joined: 01 Jan 2021
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote matthys70 Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2021 at 6:27pm
I had to give up and bought the TP-LINK TG-3468 Gigabit PCIe Network Adapter for around 10 Euro which works great.

One update though, data activity is still blinking but no connection. If you unplug cable and plug back, it will work again (for some time).
Back to Top
bbandor View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Sep 2020
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote bbandor Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2021 at 8:05pm
https://drive.google.com/file/d/1O7-MzgByjVL30PEemhRsObxmb4G85RAS/view?usp=sharing

This beta driver should resolve the issue, I've found it on the MSI forums
Back to Top
bbandor View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Sep 2020
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote bbandor Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2021 at 8:11pm
https://forum-en.msi.com/index.php?threads/realtek-pcie-2-5gbe-family-controller-resetting.345823/page-4


And here is the forum post
Back to Top
Uqen View Drop Down
Newbie
Newbie


Joined: 10 Jan 2021
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Uqen Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2021 at 10:48pm
I've already posted this on the msi forun & on github (also have a reddit post aswell https://www.reddit.com/r/HomeNetworking/comments/kqbs7l/regarding_realteks_network_cards/):
It seemed to have worked for me in the beginning, but after 1 hour of playing games it returned. In games like Overwatch it still happens every 10 minutes or so. Did not fix it for my asrock b450m pro4 with the realtek gbe family controller. Please, can anyone try it in games? Especially in Blizzard games (such as Overwatch) it happens alot.
Back to Top
pokuly View Drop Down
Newbie
Newbie


Joined: 11 Jan 2021
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote pokuly Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 2021 at 9:57am
Originally posted by Uqen Uqen wrote:

I've already posted this on the msi forun & on github (also have a reddit post aswell https://www.reddit.com/r/HomeNetworking/comments/kqbs7l/regarding_realteks_network_cards/):
It seemed to have worked for me in the beginning, but after 1 hour of playing games it returned. In games like Overwatch it still happens every 10 minutes or so. Did not fix it for my asrock b450m pro4 with the realtek gbe family controller. Please, can anyone try it in games? Especially in Blizzard games (such as Overwatch) it happens alot.

At the MSI forum you and one more person posted about still having the NDIS error.
You and the other person have motherboards that seem to have different Realtek chips as the threads are about, the 1GbE RTL8111.
No idea if the fix can be the same for the RTL8111.

For me the new beta driver obviously fixed the NDIS event of my RTL8125.
Nonetheless there seem to be different problems.
My first B550 Steel Legend had also a problem without the NDIS event.
It sometimes hung the network for no obvious reason. I needed a reboot or a disable/enable of the network adapter in the device manager to reactivate it.
This first board went back because of the onboard USB2 ports were broken.
My new replacement board did never hang up hard in the few days i have but created the NDIS event.
The new beta driver fixed that for me. For the hard hangs i will have to wait because it may take several days to pop up.
What i noticed is that the old board had a serial starting with M80-... while my new board is Made in Vietnam and has completely different serial number syntax. Also the serial is not embedded in the BIOS.
B550 Steel Legend / J5005-ITX
Back to Top
Uqen View Drop Down
Newbie
Newbie


Joined: 10 Jan 2021
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Uqen Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 2021 at 10:56am
yeah, we have different realtek chips.
I'm just disappointed that the fix did not completely fix it for our network chips, since we use the same drivers & (i presume) had the exact same problems and the exact same time. all in all not quite sure where to go from here, will probably wait a bit for the official driver release
Back to Top
pokuly View Drop Down
Newbie
Newbie


Joined: 11 Jan 2021
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote pokuly Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 2021 at 11:25am
Since the NDIS event behaves similar with the 8125 and your 8111 it may indeed be the same fix but the Realtek team didn't activate it for the 8111.
I wish you good luck your posting efforts somehow get communicated to the right people.
B550 Steel Legend / J5005-ITX
Back to Top
Uqen View Drop Down
Newbie
Newbie


Joined: 10 Jan 2021
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Uqen Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 2021 at 11:54am
thank you very much. I've already emailed them with the exact same theory in mind. Just have to hope that the right people see it!
Back to Top
pokuly View Drop Down
Newbie
Newbie


Joined: 11 Jan 2021
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote pokuly Quote  Post ReplyReply Direct Link To This Post Posted: 13 Jan 2021 at 10:31pm
Driver 10.046.1231.2020 is WHQL now.
https://www.station-drivers.com/index.php?option=com_remository&Itemid=352&func=fileinfo&id=4750&lang=en
B550 Steel Legend / J5005-ITX
Back to Top
 Post Reply Post Reply Page  <1 3456>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.