ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - AM4 BIOS info
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

AM4 BIOS info

 Post Reply Post Reply Page  123 5>
Author
Message
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 5883
Post Options Post Options   Thanks (1) Thanks(1)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Topic: AM4 BIOS info
    Posted: 06 Aug 2020 at 2:48am
Hey guys, I have noticed a lot of you have been sharing your experiences with
BIOS updates and changes, improvements and bugs you have found. For that reason
I have decided to make a sticky thread that we can use to keep all this useful
info in one place.

Rules:

1. Only share info about BIOS versions you have tested.
2. Do not post questions asking for info on when new BIOS versions will be
released etc, keep it on topic.
3. Do not ask what BIOS version is best for your particular board/combo, make
your own thread for that or read the thread for the info you need.
4. Keep the thread clean and on point so it remains informative.

If this thread proves useful and stays on topic it could become an invaluable
resource for ASRock's tech support department.

Thank you all for sharing and keeping this community thriving

Edited by Xaltar - 06 Aug 2020 at 2:49am
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 5883
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 06 Aug 2020 at 2:50am
Sample format:

Board model:
BIOS version:
CPU:
RAM:

Notes:

Edited by Xaltar - 06 Aug 2020 at 2:50am
Back to Top
aShakyamuni View Drop Down
Newbie
Newbie


Joined: 11 Aug 2020
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote aShakyamuni Quote  Post ReplyReply Direct Link To This Post Posted: 11 Aug 2020 at 9:01am
Board model: X470 Taichi
BIOS version: P3.90
CPU: R5 3600
RAM: Ballistix Sport LT CL-15 32GB (2x 16GB) 288-Pin dual rank BLS2K16G4D30AESC

Notes: Computer will not boot when I Push the power button. Lights, fans come on, then fans stop, lights stay on, no boot. I need to turn off then on the power supply switch, and eventually 2-6 tries the computer boots. Once, I had to reset bios. I built this yesterday.

This board came back from an RMA.

The non-boot sequence: When I push power button, lights come on, some fans turn then stop turning. Oddly, the rear exhaust fan is the only one that keeps spinning. Sometimes no fans, always the colored mb lights and power light come on.

In my experience, this seriously points to motherboard failure, especially with that one fan spinning and the rest stopping. I will replace the ram and try this again (this is known good working ram). Someone mentioned this same problem and suggested to boost the ram voltage. So, maybe this is a ram compatibility problem.
live in the state of let-go
Back to Top
gizmic View Drop Down
Groupie
Groupie
Avatar

Joined: 13 Jun 2018
Location: Hong Kong
Status: Offline
Points: 661
Post Options Post Options   Thanks (0) Thanks(0)   Quote gizmic Quote  Post ReplyReply Direct Link To This Post Posted: 11 Aug 2020 at 2:18pm
Board model: X470 Taichi Ultimate
BIOS version: 4.20
CPU: 3950X
RAM: G.Skill F4-4000C18-8GTZR (8GBX2) @ 3600 CL 16

Notes: Enabled eco mode and NEW Dram low latency function. Seems 4.XX onwards the random bios restart bug have been solved.

The only problem i'm having which isn't a problem for me but may cause problems for new builders. On default Auto my SoC voltage is set to 1.2v which causes stuttering in videos be it mp4, avi and youtube and sound cracking.

Solution manual set SoC to 1.1v
Back to Top
John291 View Drop Down
Newbie
Newbie


Joined: 13 Jul 2019
Location: gb
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote John291 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Aug 2020 at 4:30pm
Board model: X470 Taichi
BIOS version: 4.20
CPU 3700X
TeamGroup Dark Pro "8Pack Edition" 4x8 32GB PC4-25600C14 3200
Running at 3600 C16 Volt 1.36
Manual Soc 1.05
VDDG CCD Voltage 0.950
VDDG IOD " " " 0.950
CLDO VDDP " " " 0.950

NO PROBLEM
jbailey
Back to Top
vekspec View Drop Down
Newbie
Newbie


Joined: 09 Jul 2020
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote vekspec Quote  Post ReplyReply Direct Link To This Post Posted: 12 Aug 2020 at 1:41am
Board model: X570 Extreme4
BIOS version: 2.80
CPU: Ryzen 7 3700X
RAM: 16GB Gskill Trident Z Neo 3600 (F4-3600C16D-16GTZNC)

Notes:

Upon installing 2.80 bios, XMP profile no longer works and selecting it would cause the system to end up in an endless loop rebooting over and over with the CPU fan (Prism) to be run at max speed. Manually selecting 3600 Speed in BIOS cause the same issue. Reverting back to 2.6 resolves issue.
Ryzen 7 3700X (Prism) | ASRock X570 Extreme4 | 16GB 3600 GSKILL NEO RGB | x2 1TB Samsung 970 EVO | RTX 2070S EVGA XC Ultra | Corsair TX650M | Asus TUF VG27AQ 165hz 1440P
Back to Top
AndersWSP View Drop Down
Newbie
Newbie
Avatar

Joined: 12 Aug 2020
Location: Denmark
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote AndersWSP Quote  Post ReplyReply Direct Link To This Post Posted: 12 Aug 2020 at 5:31am
Board model: x570 Phantom Gaming 4
BIOS version: 3.10
CPU: 3600
RAM: G.Skill TridentZ Neo DDR4-3600 C16 DC (AMD) - 16GB (2x8)

Notes:
Updated BIOS in an attempt to solve cpu not boosting to advertised speeds. Still does not boost to 4,2 - but now previously working XMP 3600 profile results in machine not booting a few times until it reverts to lower speeds.

3600 memory still -kind of-works when set from Ryzen Master, but can no longer hit timings from before.
Insert something funny.
Back to Top
ThreeDee View Drop Down
Groupie
Groupie
Avatar

Joined: 24 Jul 2019
Location: Billings,MT
Status: Offline
Points: 564
Post Options Post Options   Thanks (0) Thanks(0)   Quote ThreeDee Quote  Post ReplyReply Direct Link To This Post Posted: 12 Aug 2020 at 1:09pm
Board model:x570 Steel Legend
BIOS version:2.80
CPU:3700x
RAM:2 x 16GB Hynix chipped HyperX Predators 3200mhz CAS 16

Notes:I don't recall what exactly, but there were missing settings with 2.80 vs 2.60. On 2.80, I can only do XMP profile or slower on RAM vs 2.60 I can run my memory @ 3800mhz CAS 18 w/fclk 1900 (1:1). Reverted back to 2.60
|Ryzen 3700x|ASRock X570 Taichi-BIOS 3.40|2x16GB HyperX Predator PC3200@PC3600(CAS16)1:1 IF|ASRock RX 5700XT|2 x PCIe 4.0 M.2 Drives for OS & Games|850 WTT EVGA GQ 80+ Gold PSU|Noctua NH-D15|
Back to Top
CopyThat View Drop Down
Newbie
Newbie
Avatar

Joined: 29 Sep 2018
Status: Offline
Points: 25
Post Options Post Options   Thanks (0) Thanks(0)   Quote CopyThat Quote  Post ReplyReply Direct Link To This Post Posted: 12 Aug 2020 at 2:43pm

Board model: X570 Extreme4
BIOS version: 2.80
CPU: Ryzen 7 3800X
RAM:G Skill RipjawsV F4-3600C16-8GVKC

Notes: 2.80 had problems with missing pages in BIOS, Boot loops, incorrect overclocking. Reverted to 2.60.
Back to Top
A Computer Guy View Drop Down
Newbie
Newbie


Joined: 25 Nov 2019
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote A Computer Guy Quote  Post ReplyReply Direct Link To This Post Posted: 13 Aug 2020 at 7:12am
Board model: X470 Master SLI/ac
BIOS version: P3.70
CPU: Ryzen 7 3800X or Ryzen 9 3950x
RAM: Crucial 16GB DDR4 SDRAM ECC Unbuffered DDR4 2666 (PC4 21300) CT16G4WFD8266

- The BIOS has really improved since P1.90
- BIOS/UEFI version P3.70 allowed this ram to work flawlessly and OC to DDR4-3200. (64GB)
- The BIOS option doesn't seem to allow memtest86 ecc error injection function to work
- It would be nice if the BIOS could use the onboard rgb as trouble shooting LEDs
- The online bios update was a nice feature, if they bring it back it would be nice to use it for the rgb firmware too
- Many ram options don't have any description for their function

Back to Top
 Post Reply Post Reply Page  123 5>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.