ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Nahimic driver outdated
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nahimic driver outdated

 Post Reply Post Reply Page  123 6>
Author
Message Reverse Sort Order
noelman8 View Drop Down
Newbie
Newbie


Joined: 30 Oct 2020
Status: Offline
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote noelman8 Quote  Post ReplyReply Direct Link To This Post Topic: Nahimic driver outdated
    Posted: 14 Jan 2021 at 8:30am
ASRock recently released this Nahimic 3 v1.5.2 utility package for certain ASRock B560 series boards & possibly for other recently released mobos

https://download.asrock.com/Utility/Nahimic/Nahimic3(v201125).zip

but it appears to be for next gen ASRock boards with recent chipsets like Z590/B560/H570 and uses Nahimic APO4 integration files instead of the Nahimic APO3 files and may not work for slightly older boards with Z490/H470/B550 chipsets. the Nahimic 3 v1.5.x app can use either the APO3 or APO4 set of integration files (but not both).
Back to Top
goldv2 View Drop Down
Newbie
Newbie
Avatar

Joined: 08 Dec 2020
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote goldv2 Quote  Post ReplyReply Direct Link To This Post Posted: 09 Dec 2020 at 4:46am
Originally posted by MadScientist MadScientist wrote:

Originally posted by goldv2 goldv2 wrote:

@MadScientist
I got Nahimic to work with my monitor's speakers, and after uninstalling my speakers device and restarting my computer, it finally works on my headset. However, I can't notice a different whenever I turn on surround sound while listening to music and listening to the test provided inside of Nahimic. Nonetheless, I can use the equalizer now and sound equalization.


Besides myself and others you are not the only one. http://forum.asrock.com/forum_posts.asp?TID=17422&title=nahimic-does-not-work-b550m-pro4
Several complaints on the reddit?Asrock forum about this.
MB companies should do away with this Nahimic crap and bring back the old Realtek Audio Console.



I have the Realtek Audio Console, but it's not as rich in features like the Nahimic App. When I installed the Realtek drivers, the Realtek Audio Console installed by itself through the WS.
Rafael Almeida
Back to Top
MadScientist View Drop Down
Newbie
Newbie


Joined: 17 Aug 2020
Location: TN
Status: Offline
Points: 64
Post Options Post Options   Thanks (0) Thanks(0)   Quote MadScientist Quote  Post ReplyReply Direct Link To This Post Posted: 09 Dec 2020 at 4:22am
Originally posted by goldv2 goldv2 wrote:

@MadScientist
I got Nahimic to work with my monitor's speakers, and after uninstalling my speakers device and restarting my computer, it finally works on my headset. However, I can't notice a different whenever I turn on surround sound while listening to music and listening to the test provided inside of Nahimic. Nonetheless, I can use the equalizer now and sound equalization.


Besides myself and others you are not the only one. http://forum.asrock.com/forum_posts.asp?TID=17422&title=nahimic-does-not-work-b550m-pro4
Several complaints on the reddit?Asrock forum about this.
MB companies should do away with this Nahimic crap and bring back the old Realtek Audio Console.
Back to Top
goldv2 View Drop Down
Newbie
Newbie
Avatar

Joined: 08 Dec 2020
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote goldv2 Quote  Post ReplyReply Direct Link To This Post Posted: 09 Dec 2020 at 3:59am
@MadScientist
I got Nahimic to work with my monitor's speakers, and after uninstalling my speakers device and restarting my computer, it finally works on my headset. However, I can't notice a different whenever I turn on surround sound while listening to music and listening to the test provided inside of Nahimic. Nonetheless, I can use the equalizer now and sound equalization.

Something weird that is happening with me is that whenever I unplug my headset from the MB IO, it still shows up as available on my sound control panel. Not sure why that is.
Rafael Almeida
Back to Top
goldv2 View Drop Down
Newbie
Newbie
Avatar

Joined: 08 Dec 2020
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote goldv2 Quote  Post ReplyReply Direct Link To This Post Posted: 09 Dec 2020 at 2:14am
So I have everything up to date and it should be working. I can also open the Nahimic WS app and it doesn't say that my drivers are outdated. However, none of the effects work, like bass boost, voice, treble, nor surround sound. Some effects do work on the microphone, but not all.

I hypothesized that that could have ben the problem, but I do have the default devices set to the ones I am using. I think I heard someone saying that if you change the defaults and then change back it should work again, so I will to reinstall Nahimic and do that.
Rafael Almeida
Back to Top
mapleglass View Drop Down
Newbie
Newbie


Joined: 18 Nov 2020
Status: Offline
Points: 8
Post Options Post Options   Thanks (0) Thanks(0)   Quote mapleglass Quote  Post ReplyReply Direct Link To This Post Posted: 09 Dec 2020 at 1:18am
Wow, that is wild! Yeah, I plugged a pair of headphones into the motherboard, selected them for audio output, restarted Nahimic, and it loads up.

Unplugged the headphones, and it's still all good. I am using audio over HDMI, so it's not a bluetooth-specific thing FYI.



Just wow.
Back to Top
MadScientist View Drop Down
Newbie
Newbie


Joined: 17 Aug 2020
Location: TN
Status: Offline
Points: 64
Post Options Post Options   Thanks (0) Thanks(0)   Quote MadScientist Quote  Post ReplyReply Direct Link To This Post Posted: 08 Dec 2020 at 11:20pm
@Manp
Congrats at finally getting Nahimic to work, although I have found little difference in the sound quality of my 2.1 Logitech speakers when enabling it and changing its settings and/or its equalizer.
@goldv2
Try going to Settings-System-Sound and up on the right corner of the page click on Sound Control Panel and make sure that the default device is set to what you are using. Mine is set to Speakers.
Back to Top
goldv2 View Drop Down
Newbie
Newbie
Avatar

Joined: 08 Dec 2020
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote goldv2 Quote  Post ReplyReply Direct Link To This Post Posted: 08 Dec 2020 at 3:13pm
I recently got a B550M PRO4 and I tried installing Nahimic, and I can't get it to work either. I have installed the Realtek drivers that are available on the support page, that comes with the Realtek Audio Console. My current Realtek driver version is 6.0.9030.1. I installed the latest Nahimic drivers with the Nahimic Companion v1.1.1. Inside the companion I can see that my Nahimic version is 1.5.2 and the Driver version (SWC) is 3.1.0. I find it interesting that the Nahimic app that was installed from the Windows Store says that it only supports MSI, GIGABYTE, and 8th gen Intel CPUS.

Could anyone help me getting this app to work properly?
Rafael Almeida
Back to Top
Manp View Drop Down
Newbie
Newbie


Joined: 24 Oct 2020
Status: Offline
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote Manp Quote  Post ReplyReply Direct Link To This Post Posted: 07 Dec 2020 at 7:23pm
Originally posted by garcon garcon wrote:

I also couldn't run the Nahimic App with:
Nahimic v1.5.2 + Realtek driver v9066.1_UAD_WHQL_Nahimic + Nahimic Companion Driver v3.1.0.

But once I switched my audio output device from my bluetooth headphones to the wired headphones (connected to the audio jack on motherboard IO), the app works fine for me.

Now I switched the audio device back to the bluetooth headphones and unplugged the cable. The Nahimic app still works well.


me that actually worked. i had to connect a random pair of headphones to be able to change output device but once i did that the app started working.

thanks for sharing man!
Back to Top
garcon View Drop Down
Newbie
Newbie
Avatar

Joined: 07 Dec 2020
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote garcon Quote  Post ReplyReply Direct Link To This Post Posted: 07 Dec 2020 at 6:01pm
I also couldn't run the Nahimic App with:
Nahimic v1.5.2 + Realtek driver v9066.1_UAD_WHQL_Nahimic + Nahimic Companion Driver v3.1.0.

But once I switched my audio output device from my bluetooth headphones to the wired headphones (connected to the audio jack on motherboard IO), the app works fine for me.

Now I switched the audio device back to the bluetooth headphones and unplugged the cable. The Nahimic app still works well.
Back to Top
 Post Reply Post Reply Page  123 6>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.