ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Please help BIOS update but stuck in black screen
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Please help BIOS update but stuck in black screen

 Post Reply Post Reply
Author
Message
rocktock View Drop Down
Newbie
Newbie


Joined: 17 Oct 2020
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote rocktock Quote  Post ReplyReply Direct Link To This Post Topic: Please help BIOS update but stuck in black screen
    Posted: 17 Oct 2020 at 10:22am
Hi ASRock Forum,

I have a problem that I really can? fix and I really require your assistance.

I am currently on a ASRock x99 Extreme4/3.1

My original BIOS A version was P1.3 and I went into the BIOS to update it from P1.3 to P3.0 via the flash method (I downloaded the P3.0 instant flash version from your x99 Extreme4/3.1 support page). A successful message came up and when it asked me to press enter to restart, it restarted but then got stuck in a black screen (it wouldn? get to the POST screen with the ASRock logo, it just stays in a black screen like it cant post). I have tried everything after that point, clearing/removing the CMOS battery (left it out for 8 hours and did the jumper clearing (pin 2-3) ), going into BIOS B ( backup version is at P1.3) and trying to do the ?ecure Backup UEFI?? When I attempt to do that, it says it will begin after I press OK, and then it reboots but now gets stuck in the ASRock post screen (with the options on the bottom right side - F2/DEL, F11, etc) and I have no keyboard input at that point.

My question is, how can I successfully downgrade the BIOS A? version to BIOS B? version? Do I need a new BIOS Chip so it would fix it? I have lots of pictures of my original BIOS state when it was working and all of the different issues I came across, which I can supply to you if it would help solve the issue.

Please help me. I have tried everything. I really need an expert? help.

Thank you
Back to Top
rocktock View Drop Down
Newbie
Newbie


Joined: 17 Oct 2020
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote rocktock Quote  Post ReplyReply Direct Link To This Post Posted: 17 Oct 2020 at 10:28am
I also have a DVI cable connected to the PC, if that helps determining the issue
Back to Top
rocktock View Drop Down
Newbie
Newbie


Joined: 17 Oct 2020
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote rocktock Quote  Post ReplyReply Direct Link To This Post Posted: 18 Oct 2020 at 4:30am
If anyone out there could help, I would really appreciate it
Back to Top
rocktock View Drop Down
Newbie
Newbie


Joined: 17 Oct 2020
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote rocktock Quote  Post ReplyReply Direct Link To This Post Posted: 18 Oct 2020 at 2:15pm
Update: There is a RED LED light above the BIOS A chip, still can? post
Back to Top
rocktock View Drop Down
Newbie
Newbie


Joined: 17 Oct 2020
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote rocktock Quote  Post ReplyReply Direct Link To This Post Posted: 18 Oct 2020 at 2:16pm
Cannot* it seems certain characters are turning into ? And a box
Back to Top
RLGL View Drop Down
Groupie
Groupie
Avatar

Joined: 29 Jul 2018
Location: MN
Status: Offline
Points: 352
Post Options Post Options   Thanks (1) Thanks(1)   Quote RLGL Quote  Post ReplyReply Direct Link To This Post Posted: 18 Oct 2020 at 9:37pm
Contact Asrock support by phone. They should be able to help.
Asrock Z370 Gaming K6,Intel i7 8700K,
Asrock x570 Taichi

Back to Top
rocktock View Drop Down
Newbie
Newbie


Joined: 17 Oct 2020
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote rocktock Quote  Post ReplyReply Direct Link To This Post Posted: 19 Oct 2020 at 7:50pm
Okay, I will contact them in the morning. Thanks
Back to Top
rocktock View Drop Down
Newbie
Newbie


Joined: 17 Oct 2020
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote rocktock Quote  Post ReplyReply Direct Link To This Post Posted: 20 Oct 2020 at 7:59am
They said it seems like a MOBO defect, how is that possible if it was good until the update? Can a update fry out your mobo like that?
Back to Top
RLGL View Drop Down
Groupie
Groupie
Avatar

Joined: 29 Jul 2018
Location: MN
Status: Offline
Points: 352
Post Options Post Options   Thanks (0) Thanks(0)   Quote RLGL Quote  Post ReplyReply Direct Link To This Post Posted: 20 Oct 2020 at 9:51pm
Originally posted by rocktock rocktock wrote:

They said it seems like a MOBO defect, how is that possible if it was good until the update? Can a update fry out your mobo like that?


Yes, very common.
Asrock Z370 Gaming K6,Intel i7 8700K,
Asrock x570 Taichi

Back to Top
rocktock View Drop Down
Newbie
Newbie


Joined: 17 Oct 2020
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote rocktock Quote  Post ReplyReply Direct Link To This Post Posted: 22 Oct 2020 at 10:36am
yea makes no sense to me but I guess that's just how it works man. I decided to just toss this sh*t away and am upgrading to MSI
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.063 seconds.