ASRock.com Homepage
Forum Home Forum Home > Media&User's Review > Networking Products
  New Posts New Posts RSS Feed - Does the OpenVPN function work?
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Does the OpenVPN function work?

 Post Reply Post Reply
Author
Message
kkws0615 View Drop Down
Newbie
Newbie


Joined: 03 Mar 2016
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote kkws0615 Quote  Post ReplyReply Direct Link To This Post Topic: Does the OpenVPN function work?
    Posted: 03 Mar 2016 at 4:31pm
I have updated new firmware today, I want to try new function "OpenVPN".
It doesn't work, I can't find any help on GUI. Please help!

Enable DDNS server. Service Provider is No-IP.com. I got correct IP showed on the no-ip website.
Enable VPN server. I got correct WAN IP Address and Domain Name.
Export Config File. 
Start openvpn on this config file.

The log shows:
Thu Mar 03 16:26:22 2016 OpenVPN 2.3.10 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Feb  1 2016
Thu Mar 03 16:26:22 2016 Windows version 6.1 (Windows 7)
Thu Mar 03 16:26:22 2016 library versions: OpenSSL 1.0.1r  28 Jan 2016, LZO 2.09
Thu Mar 03 16:26:22 2016 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Thu Mar 03 16:26:22 2016 Socket Buffers: R=[8192->8192] S=[8192->8192]
Thu Mar 03 16:26:22 2016 UDPv4 link local: [undef]
Thu Mar 03 16:26:22 2016 UDPv4 link remote: [AF_INET]192.168.1.185:443
Thu Mar 03 16:26:22 2016 TCP/UDP: Incoming packet rejected from [AF_INET]192.168.100.1:443[2], expected peer address: [AF_INET]192.168.1.185:443 (allow this incoming source address/port by removing --remote or adding --float)
Thu Mar 03 16:26:24 2016 TCP/UDP: Incoming packet rejected from [AF_INET]192.168.100.1:443[2], expected peer address: [AF_INET]192.168.1.185:443 (allow this incoming source address/port by removing --remote or adding --float)
Thu Mar 03 16:26:28 2016 TCP/UDP: Incoming packet rejected from [AF_INET]192.168.100.1:443[2], expected peer address: [AF_INET]192.168.1.185:443 (allow this incoming source address/port by removing --remote or adding --float)
Thu Mar 03 16:26:28 2016 TCP/UDP: Incoming packet rejected from [AF_INET]192.168.100.1:443[2], expected peer address: [AF_INET]192.168.1.185:443 (allow this incoming source address/port by removing --remote or adding --float)



Try on iphone:
2016-03-03 16:01:55 ----- OpenVPN Start -----
OpenVPN core 3.0 ios arm64 64-bit
2016-03-03 16:01:55 UNUSED OPTIONS
4 [resolv-retry] [infinite]
5 [nobind]
6 [persist-key]
7 [persist-tun]
12 [verb] [3]

2016-03-03 16:01:55 LZO-ASYM init swap=0 asym=0
2016-03-03 16:01:55 EVENT: RESOLVE
2016-03-03 16:01:55 Contacting 192.168.1.185:443 via UDP
2016-03-03 16:01:55 EVENT: WAIT
2016-03-03 16:01:55 SetTunnelSocket returned 1
2016-03-03 16:01:55 Connecting to sqa1234567890.no-ip.org:443 (192.168.1.185) via UDPv4
2016-03-03 16:02:05 Server poll timeout, trying next remote entry...
2016-03-03 16:02:05 EVENT: RECONNECTING
2016-03-03 16:02:05 LZO-ASYM init swap=0 asym=0
2016-03-03 16:02:05 EVENT: RESOLVE
2016-03-03 16:02:05 Contacting 192.168.1.185:443 via UDP
2016-03-03 16:02:05 EVENT: WAIT
2016-03-03 16:02:05 SetTunnelSocket returned 1
2016-03-03 16:02:05 Connecting to sqa1234567890.no-ip.org:443 (192.168.1.185) via UDPv4
2016-03-03 16:02:06 NET Internet:NotReachable/-- -------
2016-03-03 16:02:06 NET WiFi:NotReachable/-- -------
2016-03-03 16:02:07 NET Internet:ReachableViaWWAN/WR t------
2016-03-03 16:02:07 NET WiFi:NotReachable/WR t------
2016-03-03 16:02:07 UDP send error: send: Can't assign requested address
2016-03-03 16:02:07 Transport Error: EADDRNOTAVAIL: Can't assign requested address
2016-03-03 16:02:07 EVENT: TRANSPORT_ERROR EADDRNOTAVAIL: Can't assign requested address [ERR]
2016-03-03 16:02:07 Client terminated, restarting in 5...
2016-03-03 16:02:09 EVENT: DISCONNECTED
2016-03-03 16:02:09 Raw stats on disconnect:
  BYTES_OUT : 84
  PACKETS_OUT : 6
  NETWORK_SEND_ERROR : 1
  TRANSPORT_ERROR : 1
  N_RECONNECT : 1
2016-03-03 16:02:09 Performance stats on disconnect:
  CPU usage (microseconds): 17613
  Network bytes per CPU second: 4769
  Tunnel bytes per CPU second: 0
2016-03-03 16:02:09 ----- OpenVPN Stop -----
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 2196
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 08 Mar 2016 at 5:50pm

You use the private IP not public IP, so OpenVPN client can't work. Please connect G10 under cable modem.

 

 

 
 
Back to Top
angela erin View Drop Down
Newbie
Newbie


Joined: 10 May 2016
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote angela erin Quote  Post ReplyReply Direct Link To This Post Posted: 10 May 2016 at 8:48pm
Try for dynamic IP address than VPN.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.