ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Restart to UEFI ??
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Restart to UEFI ??

 Post Reply Post Reply Page  12>
Author
Message
Finnipinni View Drop Down
Newbie
Newbie
Avatar

Joined: 31 Aug 2015
Location: Norway
Status: Offline
Points: 37
Post Options Post Options   Thanks (0) Thanks(0)   Quote Finnipinni Quote  Post ReplyReply Direct Link To This Post Topic: Restart to UEFI ??
    Posted: 16 Mar 2016 at 3:28pm
I wonder what the download to the board A88M-G/3.1 is doing ?
Is the board running legacy BIOS if this utility is'nt run ?
I'm running all GPT-disks and W10 on M.2 NVMe.
A88M G-3.1 2x4GB XMS SM951NVMe NanoPSU MediaPC
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5266
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 16 Mar 2016 at 4:44pm
Restart to UEFI is designed to be used when you are utilizing the fast or ultra fast boot options in your UEFI. This causes the system to post so quickly that you do not have time to press a key to enter the UEFI. The app, when used will restart the PC directly into the UEFI without you needing to press anything.
Back to Top
Finnipinni View Drop Down
Newbie
Newbie
Avatar

Joined: 31 Aug 2015
Location: Norway
Status: Offline
Points: 37
Post Options Post Options   Thanks (0) Thanks(0)   Quote Finnipinni Quote  Post ReplyReply Direct Link To This Post Posted: 16 Mar 2016 at 9:30pm
Thanks Xaltar :)
OK - nice to know, but I think the boot is fast enough.
A88M G-3.1 2x4GB XMS SM951NVMe NanoPSU MediaPC
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 5000
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 16 Mar 2016 at 11:36pm
Originally posted by Finnipinni Finnipinni wrote:

I wonder what the download to the board A88M-G/3.1 is doing ?
Is the board running legacy BIOS if this utility is'nt run ?
I'm running all GPT-disks and W10 on M.2 NVMe.


The Restart to UEFI program does not control or configure the UEFI firmware in legacy mode or UEFI mode. That is only controlled by the CSM option, or if you use the Secure Boot option.

As Xaltar said, Restart to UEFI is only a convenience feature that lets us easily enter the UEFI GUI from Windows. I use it all the time when I want to get into the UEFI from Windows. No need to press the Del or F2 keys, just run it, click both settings on and click Apply.

It can be used whether we are in Legacy or UEFI mode.
Back to Top
donalgodon View Drop Down
Newbie
Newbie
Avatar

Joined: 21 Sep 2017
Status: Offline
Points: 90
Post Options Post Options   Thanks (0) Thanks(0)   Quote donalgodon Quote  Post ReplyReply Direct Link To This Post Posted: 04 Oct 2017 at 2:24am
I tried to use the ASRock app, but it didn't boot me into UEFI.
Back to Top
MisterJ View Drop Down
Senior Member
Senior Member


Joined: 19 Apr 2017
Status: Offline
Points: 1082
Post Options Post Options   Thanks (0) Thanks(0)   Quote MisterJ Quote  Post ReplyReply Direct Link To This Post Posted: 04 Oct 2017 at 5:15am
Boot to UEFI is a feature in W10 just not convenient to use.  Please Google it and you will see what I mean.  Enjoy, John.
Fat1 X399 Pro Gaming, TR 1950X, RAID0 3xSamsung SSD 960 EVO, G.SKILL FlareX F4-3200C14Q-32GFX, Win 10 x64 Pro, Enermx Platimax 850, Enermx Liqtech TR4 CPU Cooler, Radeon RX580, BIOS 2.00, 2xHDDs WD
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 5000
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 04 Oct 2017 at 9:30am
Originally posted by donalgodon donalgodon wrote:

I tried to use the ASRock app, but it didn't boot me into UEFI.


I have seen an occasional problem with Restart to UEFI with certain platforms. That is, I've seen it fail with my Ryzen PC, but that bug is no longer a problem. Restart to UEFI is working fine now.

What board/system are you using?

Originally posted by MisterJ MisterJ wrote:

Boot to UEFI is a feature in W10 just not convenient to use.  Please Google it and you will see what I mean.  Enjoy, John.


Yes, it is not readily available in Windows 10 or 8.1, usually offered when Windows won't boot correctly.

Otherwise, I've been using the ASRock Restart to UEFI program for years on many ASRock boards, and it always worked fine, with the recent exception of my Ryzen system, which is now cured. I believe it is the Advance(d) AM4 Boot Training option that breaks it, which I now have disabled

Back to Top
donalgodon View Drop Down
Newbie
Newbie
Avatar

Joined: 21 Sep 2017
Status: Offline
Points: 90
Post Options Post Options   Thanks (0) Thanks(0)   Quote donalgodon Quote  Post ReplyReply Direct Link To This Post Posted: 10 Oct 2017 at 12:50am
Originally posted by parsec parsec wrote:

Originally posted by donalgodon donalgodon wrote:

I tried to use the ASRock app, but it didn't boot me into UEFI.


I have seen an occasional problem with Restart to UEFI with certain platforms. That is, I've seen it fail with my Ryzen PC, but that bug is no longer a problem. Restart to UEFI is working fine now.

What board/system are you using?

Originally posted by MisterJ MisterJ wrote:

Boot to UEFI is a feature in W10 just not convenient to use.  Please Google it and you will see what I mean.  Enjoy, John.


Yes, it is not readily available in Windows 10 or 8.1, usually offered when Windows won't boot correctly.

Otherwise, I've been using the ASRock Restart to UEFI program for years on many ASRock boards, and it always worked fine, with the recent exception of my Ryzen system, which is now cured. I believe it is the Advance(d) AM4 Boot Training option that breaks it, which I now have disabled



AsRock AB350M Pro4 Micro ATX  in UEFI mode.

Ryzen 5 1600

Windows 10 x64

32GB Corsair @3933 (via XMP Profile)

No CPU overclock, etc.

I have the Rapid Boot/Fast Boot feature enabled, but the ASRock Restart to UEFI utility doesn't work for me at all.

I even tried "shutdown /r /fw /t 0" via admin command prompt and it didn't work.


Edited by donalgodon - 10 Oct 2017 at 1:11am
Back to Top
MisterJ View Drop Down
Senior Member
Senior Member


Joined: 19 Apr 2017
Status: Offline
Points: 1082
Post Options Post Options   Thanks (0) Thanks(0)   Quote MisterJ Quote  Post ReplyReply Direct Link To This Post Posted: 10 Oct 2017 at 1:58am
donalgodon, instead of just reporting that things do not work, please tell us what they DO and any messages you get.  Please try this help to Restart to BIOS in W10:

https://www.laptopmag.com/articles/access-bios-windows-10

Have you tried turning off Fast Boot?  What is the state of CSM?  Please open your BIOS and hit F9 (Load UEFI Defaults), then F10, then try Restart to UEFI.
Enjoy, John.
Fat1 X399 Pro Gaming, TR 1950X, RAID0 3xSamsung SSD 960 EVO, G.SKILL FlareX F4-3200C14Q-32GFX, Win 10 x64 Pro, Enermx Platimax 850, Enermx Liqtech TR4 CPU Cooler, Radeon RX580, BIOS 2.00, 2xHDDs WD
Back to Top
kemijuyaj View Drop Down
Newbie
Newbie


Joined: 20 Oct 2017
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote kemijuyaj Quote  Post ReplyReply Direct Link To This Post Posted: 20 Oct 2017 at 12:49am
Originally posted by donalgodon donalgodon wrote:

Originally posted by parsec parsec wrote:

Originally posted by donalgodon donalgodon wrote:

I tried to use the ASRock app, but it didn't boot me into UEFI.


I have seen an occasional problem with Restart to UEFI with certain platforms. That is, I've seen it fail with my Ryzen PC, but that bug is no longer a problem. Restart to UEFI is working fine now.

What board/system are you using?

Originally posted by MisterJ MisterJ wrote:

Boot to UEFI is a feature in W10 just not convenient to use.  Please Google it and you will see what I mean.  Enjoy, John.


Yes, it is not readily available in Windows 10 or 8.1, usually offered when Windows won't boot correctly.

Otherwise, I've been using the ASRock Restart to UEFI program for years on many ASRock boards, and it always worked fine, with the recent exception of my Ryzen system, which is now cured. I believe it is the Advance(d) AM4 Boot Training option that breaks it, which I now have disabled



AsRock AB350M Pro4 Micro ATX  in UEFI mode.

Ryzen 5 1600

Windows 10 x64

32GB Corsair @3933 (via XMP Profile)

No CPU overclock, etc.

I have the Rapid Boot/Fast Boot feature enabled, but the ASRock Restart to UEFI utility doesn't work for me at all.

I even tried "shutdown /r /fw /t 0" via admin command prompt and it didn't work.
i have same problem too

Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.031 seconds.