ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - [SOLVED]Extreme4+.UEFI in BIOS-compatibility mode?
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

[SOLVED]Extreme4+.UEFI in BIOS-compatibility mode?

 Post Reply Post Reply
Author
Message
yaromir View Drop Down
Newbie
Newbie


Joined: 19 Jun 2016
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote yaromir Quote  Post ReplyReply Direct Link To This Post Topic: [SOLVED]Extreme4+.UEFI in BIOS-compatibility mode?
    Posted: 20 Jun 2016 at 3:01am
Hello, everyone.

I'm trying to install Windows 10 x86_64 to PC with ASRock Z170 Extreme 4+.
I've created GPT partition table on the hard drive and when i try to install Windows it says that it can't be installed on the hard drive with GPT partition table. This happens when system firmware operates in BIOS-compatibility mode. I have experience of Windows 10 x86_64 installation on UEFI machine, but it requires firmware to operate in UEFI mode. Windows is pretty radical about this: it wants either BIOS - MBR or UEFI - GPT.

Problem can be solved if i'll reformat hard drive to old MBR partition table format, but i don't want to do this.

Laptops usually have UEFI menu option that switches UEFI / BIOS-compatibility. I can't find such option in UEFI menu of the motherboard. Does it have such option?

Thanks in advance.



Edited by yaromir - 07 Jul 2016 at 3:56pm
Back to Top
tsunami2311 View Drop Down
Newbie
Newbie


Joined: 19 Jun 2016
Status: Offline
Points: 43
Post Options Post Options   Thanks (0) Thanks(0)   Quote tsunami2311 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2016 at 12:21pm
hit f11 to get to boot menu select uefi usb stick  I  think by defualt it boots in legacy mode which pmap usb (stick name)

atlest that is how i understand it and what I did

and manual creating GPT partition threw disk management didnt work for me windows setup threw out errors, and when I let setup create it made recovery partition i didnt want. so i got pissed and just installed as MBR/NTFS.

Later on a test disk I managed to get it to work

F11 (boot menu)
picked UEFI usb stick (pmap usb  legacy)

in windows setup I did the following cause I didnt want the recovery partition setup makes.

Repair option
CMD Option

Diskpart
list disk
select disk # (picking appropriate disk)
Clean
Covert GPT
Create partition efi size=100 (100mb)
Create partition msr size=16 (16mb)
Create partition primary (use remainder of space)

Shut down
start up pc
F11 (boot option)
UEFI usb boot stick
Install windows normal pick primary partition windows will install. and it will install as GPT with out recovery partition.

If you dont care that there is recovery partition just  run windows setup normal, and when comes drive page just pick the drive and delete the partition and then hit new and will make 4 partitions

I have not bother do all this on my SSD as i cant be bother redo it again


Edited by tsunami2311 - 20 Jun 2016 at 12:40pm
Back to Top
yaromir View Drop Down
Newbie
Newbie


Joined: 19 Jun 2016
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote yaromir Quote  Post ReplyReply Direct Link To This Post Posted: 07 Jul 2016 at 3:56pm
Solved the issue.

Originally posted by tsunami2311 tsunami2311 wrote:


hit f11 to get to boot menu select uefi usb stick  I  think by defualt it boots in legacy mode which pmap usb (stick name)


Not exactly. I had two options in F11 boot menu:

UEFI: <My external DVD drive>
USB:  <My external DVD drive>

The first one boots in UEFI mode, the second one boots in BIOS compatibility mode.

When i booted in UEFI mode, Windows was installed without issues.

Thanks.

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.063 seconds.