ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Secure Flash Check Fail
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Secure Flash Check Fail

 Post Reply Post Reply
Author
Message
BroDragon View Drop Down
Newbie
Newbie
Avatar

Joined: 11 Sep 2015
Location: San Leandro, CA
Status: Offline
Points: 25
Post Options Post Options   Thanks (0) Thanks(0)   Quote BroDragon Quote  Post ReplyReply Direct Link To This Post Topic: Secure Flash Check Fail
    Posted: 04 Jul 2016 at 9:52am
On my Z170 k6 I'm trying to update my UEFI from V1.7. In the UEFI main menu I select internet update, it finds the internet connection, it downloads, it reboots and then is displays "Secure Flash Check Fail". I tried going through the App store but in Bios and Drivers it says "No available update in the server". The UEFI still lists as V1.7. A little help please!
"I'm trying to thing but nothin' happens" Gerome 'Curly' Howard
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 04 Jul 2016 at 11:26am
Originally posted by BroDragon BroDragon wrote:

On my Z170 k6 I'm trying to update my UEFI from V1.7. In the UEFI main menu I select internet update, it finds the internet connection, it downloads, it reboots and then is displays "Secure Flash Check Fail". I tried going through the App store but in Bios and Drivers it says "No available update in the server". The UEFI still lists as V1.7. A little help please!


I'm assuming a Fatalty Z170 Gaming K6? Not the K6+?

If you have your CPU and memory over clocked, it is best to run UEFI updates at stock speeds.

The problem might be that the Internet Flash feature suggests (requires?) you insert a USB flash drive into a USB port on the board's IO panel. That is done to save the downloaded UEFI file, which is used if the UEFI update has a problem, such as the PC loosing power during the update.

The error message you saw means the UEFI update did not happen. If a UEFI update did run, you would first see "Processing Crashless Feature", with a progress bar indicating the progress. Next you would see "Processing UEFI Update" (or similar, can't recall the exact text", with another progress bar. Finally a prompt would appear to press Enter to restart the PC. I'm sure you saw none of that.

The current APP Shop version is 1.0.24 for your board. If that's what you have installed, the server seems to have been down when you ran it.

It's easy IMO to download the latest UEFI file from your board's download page, unzip the file and copy the result to a USB flash drive. Put the USB flash drive into a USB port on the board's IO panel. Restart the PC into the UEFI, and run Instant Flash from the Tools page. Works fine for me every time.

http://www.asrock.com/mb/Intel/Fatal1ty%20Z170%20Gaming%20K6/?cat=Download&os=BIOS

Or try Internet Flash again with a USB flash drive in a USB port.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.094 seconds.