ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - SM951 as OS boot device information
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

SM951 as OS boot device information

 Post Reply Post Reply Page  <1234 19>
Author
Message
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 4933
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jun 2015 at 1:12pm
For any requests regarding booting from the SM951 the feature you need to request is called NVMe support. 

Asrock has no plans to release official support on boards with chipsets older than the intel 9 series. However, as tech support posted in this thread, if you would like assistance with a board not listed for support contact them via:


Asrock have already provided assistance to one forum member here using a z77 board (link to bios update in OP) so you are not without options. Please allow time for Asrock to process your request and get back to you.

Back to Top
Gunslinger View Drop Down
Newbie
Newbie
Avatar

Joined: 27 Jun 2015
Status: Offline
Points: 17
Post Options Post Options   Thanks (0) Thanks(0)   Quote Gunslinger Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jun 2015 at 5:34pm

Thanks for the Reply. I have dropped them a request for help, but don't have a reference number and am waiting for some reply other than the automated one


The Version i have is NOT the NVMe one, but the AHCI version. I figured that the NVMe support may not be extended back to the z87 boards, but had hoped for support for the AHCI version, given that the boards are hardly obsolete !


I can't remember if i put in the information that it was the AHCI one i have, hopefully someone will be in touch soon, so i know one way or the other, because i can't use the system as it stands, and if i have to buy a different board i will

Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 4933
Post Options Post Options   Thanks (1) Thanks(1)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jun 2015 at 8:17pm
Important update:

It has come to my attention (thank you Parsec) that the SM951 is not in fact an NVMe supporting drive, while it was originally claimed by Samsung that it would support the feature the final release product is in fact AHCI not NVMe. 

Boot support for the Z97 Extreme6 is confirmed as being applied in beta bios 2.04 and then in release version 2.10. Interestingly the 2.10 bios revision only notes the addition of NVMe support and not improved M.2 support as stated on the 2.04 beta bios. This did not help my confusion Angry LOL

So as it stands I can only confirm support on the Z97 Extreme6 with bios version 2.10 and Z77 Extreme4 with the bios download linked here in this thread.

I do however suspect that all boards updated with NVMe support likely also received the same improved M.2 support the Z97 Extreme6 received and as such should support booting from the SM951.


I have added this info to the OP
Back to Top
Gunslinger View Drop Down
Newbie
Newbie
Avatar

Joined: 27 Jun 2015
Status: Offline
Points: 17
Post Options Post Options   Thanks (0) Thanks(0)   Quote Gunslinger Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jun 2015 at 8:23pm
yeah, the whole m.2 format is a minefield, and then Samsung go and drop 2 different versions of the same SSD with the same model name... lol, typical.

Does the NVMe version also support AHCI ? .... and there goes the can holding all the worms lol


Edited by Gunslinger - 28 Jun 2015 at 8:23pm
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 4933
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jun 2015 at 8:27pm
I set out to provide useful information on the SM951 front with this thread thinking it would be easy to just gather all the useful info from other threads on the matter. Boy was I wrong lol.

Hopefully the info I have provided now will be at least mostly accurate. Thank you to everyone helping out, this thread is designed to be informative to anyone having issues booting from the SM951.
Back to Top
Gunslinger View Drop Down
Newbie
Newbie
Avatar

Joined: 27 Jun 2015
Status: Offline
Points: 17
Post Options Post Options   Thanks (0) Thanks(0)   Quote Gunslinger Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jun 2015 at 6:06am
I got a new BIOS from Tech Support for my Z87m OC Formula, it's now booting happily off the Samsung SM951 (AHCI) into Windows 7 64bit

Clap
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 4933
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jun 2015 at 1:25pm
Great news Thumbs Up

Would you mind uploading and sharing the BIOS you were sent for your board so I can put it on the list of boards with custom bios for the SM951?
Back to Top
Gunslinger View Drop Down
Newbie
Newbie
Avatar

Joined: 27 Jun 2015
Status: Offline
Points: 17
Post Options Post Options   Thanks (0) Thanks(0)   Quote Gunslinger Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jun 2015 at 6:53pm
Eddy from Tech Support has just linked it in this thread here....

http://forums.tweaktown.com/asrock/61077-clutching-straws-sm951-support-z87m-board.html#post499137


note that whilst it is referred to as "L1.83A" there is no "L" in the filename once unpacked from the archive, or referenced in the BIOS after flashing (not that i saw anyway)
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 4933
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jun 2015 at 8:54pm
Thanks Gunslinger, I'll add it to the OP for any other Z87m OC Formula users.
Back to Top
odiebugs View Drop Down
Newbie
Newbie


Joined: 07 Jul 2015
Status: Offline
Points: 193
Post Options Post Options   Thanks (0) Thanks(0)   Quote odiebugs Quote  Post ReplyReply Direct Link To This Post Posted: 22 Jul 2015 at 4:25am
Xaltar:  Can you post some info on booting under main for M2, as to any BIOS / UEFI settings, and if the M2 will be seen in drive list in it, and if MBR and GPT both work.  

A nice guide would help as you see there have been questions, and soon will grab one to replace windows boot on RAID.  Thanks.

Maybe you could also cover the difference in M2 as it pertains to one being SSD and one a PCI-e interface on the M2.


Edited by odiebugs - 22 Jul 2015 at 4:29am
asrocking
Back to Top
 Post Reply Post Reply Page  <1234 19>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.063 seconds.