ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Z77 Extreme6 - Win10 Upgrade - BSOD Intel Graphics
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Z77 Extreme6 - Win10 Upgrade - BSOD Intel Graphics

 Post Reply Post Reply
Author
Message
rycherulz View Drop Down
Newbie
Newbie


Joined: 03 Aug 2016
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote rycherulz Quote  Post ReplyReply Direct Link To This Post Topic: Z77 Extreme6 - Win10 Upgrade - BSOD Intel Graphics
    Posted: 03 Aug 2016 at 7:23pm
Hi all,

Hope you can help with this issue. I upgraded my perfectly stable Windows 7 Pro system to Win 10 Pro last week. It seemed to be OK for a bit, but then I noticed it was throwing BSOD errors for the integrated Intel graphics card on my MBD every couple of hours. I downloaded WhoCrashed (GREAT program), and here's what it told me (I already knew it based on my perusal of Event Viewer, but it was nice to see it verified):

This was probably caused by the following module: igdkmd64.sys (igdkmd64+0x1269A)
Bugcheck code: 0x1000007E (0xFFFFFFFFC0000005, 0xFFFFF800D9A6269A, 0xFFFFD00022D28978, 0xFFFFD00022D28190)
Error: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M
file path: C:\WINDOWS\system32\drivers\igdkmd64.sys
product: Intel HD Graphics Drivers for Windows 8(R)
company: Intel Corporation
description: Intel Graphics Kernel Mode Driver
Bug check description: This indicates that a system thread generated an exception which the error handler did not catch.
This appears to be a typical software driver bug and is not likely to be caused by a hardware problem.
A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: igdkmd64.sys (Intel Graphics Kernel Mode Driver, Intel Corporation).
Google query: Intel Corporation SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M

I have downloaded and tried to install the latest intel driver from both windows update and intel's site directly. No go. Same error.

I then downloaded and ran DDU (Display Driver Uninstall), rebooted to Safe Mode, and removed all Intel drivers. I let it turn off driver installs through Windows Update. Then I downloaded WUSHOWHIDE, the tool from Microsoft to be able to hide problem Windows Updates. 

I even went to Intel's site, and updated everything Intel in my system.

I tried disabling the video in Device Manager, and uninstalling the driver. No change.

Nothing is helping. Every few of hours my system BSOD's and reboots, which I suspect is Windows trying to update that driver constantly. I am officially at a crossroads here. I'm ready to restore the image I made via Windows Backup the night I upgraded, and roll back to Windows 7 Pro, or maybe try a fresh install of Windows 10 Pro via a downloaded DVD ISO.

Thankfully, my data is on separate physical drives, so reimaging the machine won't cost much time (other than the zillion apps I use).  Can anyone help me out and suggest a possible work around?

Just FYI, here's my system.
Windows 10 Pro (upgraded from Windows 7 Pro)
Motherboard: ASRock Z77 Extreme6
CPU Intel 3770K 3.5 GHz Quad Core
GPU: EVGA GeForce GTX 650 Ti Boost
16 GB Crucial Ballistix Sport (2 x 8GB) DDR3-1600 Memory
OS Drive: Samsung 840 Pro Series 256GB 2.5" Solid State Drive
Data Drives: 2 - Western Digital VelociRaptor 500GB 3.5" 10000RPM Internal Hard Drive (RAID 1 Config)

Back to Top
rycherulz View Drop Down
Newbie
Newbie


Joined: 03 Aug 2016
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote rycherulz Quote  Post ReplyReply Direct Link To This Post Posted: 04 Aug 2016 at 9:27pm
Just for future generations....

I threw in the towel, popped in my Win 7 Repair Disk, and reverted back to the Win 7 Pro image I made to my USB drive before I upgraded. I thought about reinstalling a fresh Win 10 Pro OS on the system, but honestly, it's not worth the hassle (drivers, apps, tweaking everything to my liking). The revert took an hour or so, with me only sitting in front of it for five minutes to make sure it started restoring.

If ASRock or Intel ever fix that driver, I'll get back on the horse, and try again. My system did activate for Windows 10, so I know I can go to it any time I want now.
Back to Top
celtek View Drop Down
Newbie
Newbie
Avatar

Joined: 04 Aug 2016
Location: MA, USA
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote celtek Quote  Post ReplyReply Direct Link To This Post Posted: 04 Aug 2016 at 9:41pm
I probably would have tried a clean installation of Windows 10 before throwing in the towel. Nonetheless, I hope your issue gets resolved.
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 5000
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 04 Aug 2016 at 10:51pm
Originally posted by rycherulz rycherulz wrote:

Just for future generations....

I threw in the towel, popped in my Win 7 Repair Disk, and reverted back to the Win 7 Pro image I made to my USB drive before I upgraded. I thought about reinstalling a fresh Win 10 Pro OS on the system, but honestly, it's not worth the hassle (drivers, apps, tweaking everything to my liking). The revert took an hour or so, with me only sitting in front of it for five minutes to make sure it started restoring.

If ASRock or Intel ever fix that driver, I'll get back on the horse, and try again. My system did activate for Windows 10, so I know I can go to it any time I want now.


Sorry to hear about your problems with a Windows 10 "upgrade", if we can call your experience an upgrade, which it obviously is not.

For whatever reason, it seems the Win 10 upgrade installations have the most problems, in contrast to a fresh Win 10 installation. I have a fresh Win 10 installation on my Z77 Extreme4 board, but use a video card. I should try using the Intel graphics for a test. It seems you are using a video card instead of the Intel graphics, or do you use both?

Regarding if ASRock could fix the Intel graphics driver, mother board manufactures do very, very little if any modifications to drivers provided by another manufacture. The most any can do is modify some of the installation settings, if possible, or add their logo for display during the installation.

From having access to the driver's source code, to testing and verification of any changes to that code, even the potential for a mother board manufacture to modify another manufactures driver more than likely does not even exist. Anyone that has worked in software development will know how difficult and unlikely that scenario is.

Even the driver provider may be unable to fix a problem with a driver used with a new version of Windows. A perfect example of this is the Intel network drivers for the networking capabilities included in their chipsets, and their dedicated networking chips.

I have several ASRock Intel processor/chipset boards that have two network chips. A feature of the Intel network driver called Teaming allows the two chips to be combined in several ways for various purposes. The Teaming feature that I have used in the past no longer works with Windows 10. That fact is acknowledged by Intel in their documentation (Readme files) for their Windows 10 compatible network drivers.

After multiple updates to this driver (at least five), and one year later, the Teaming feature is still not fixed with Windows 10. The ability to create VLANs also does not work with Windows 10. If the provider of a driver can't fix it, who can?
Back to Top
rycherulz View Drop Down
Newbie
Newbie


Joined: 03 Aug 2016
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote rycherulz Quote  Post ReplyReply Direct Link To This Post Posted: 05 Aug 2016 at 12:02am
I don't use the Intel graphics card, just my EVGA GeForce GPU. That's what was particularly frustrating with this; the one driver that was crashing my system is something I will never use. 

Yeah, I know a fresh install would probably be better, and I will probably try in a month or two when my schedule slows down; I just have too much happening right now to sit there installing a fresh copy, drivers, all my apps, and tweaking everything to my liking. 

Honestly, this is no biggie for me. I don't HAVE to have Windows 10. I just wanted it activated before the July 29th deadline, which I did. Now, I can mess with it when I have more time.
Back to Top
wannagofast View Drop Down
Newbie
Newbie


Joined: 05 Aug 2016
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote wannagofast Quote  Post ReplyReply Direct Link To This Post Posted: 05 Aug 2016 at 5:59am
Originally posted by rycherulz rycherulz wrote:

I don't use the Intel graphics card, just my EVGA GeForce GPU. That's what was particularly frustrating with this; the one driver that was crashing my system is something I will never use.

Bummer that you are having issues. I run Windows 10 Pro on a very similar setup with no issues.
I do have one question though. If you are running an Nvidia PCI-e card why have you not disabled
the intel video stuff in the bios. There really should be no need to even have that driver on your PC.
If you do work up the desire to do a clean install of 10 I would definitely be sure to turn that off first.

Peace  Wanna 
Z77 Extreme6 - i7-3770K @ 4.5 GHz - 8GB GSkill 1866
MSI GTX 970 4GD5T OC - Samsung 850 Pro 128 GB SSD
Back to Top
rycherulz View Drop Down
Newbie
Newbie


Joined: 03 Aug 2016
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote rycherulz Quote  Post ReplyReply Direct Link To This Post Posted: 08 Aug 2016 at 11:58pm
There is no way to disable it in the BIOS. I looked (and looked). 

Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5110
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 09 Aug 2016 at 12:37am
Try setting the system to boot in safe mode: Run "MSconfig.exe" select the "boot" tab and check the safe mode option. Before you restart download the latest version of DDU (Display Driver Uninstaller) and extract it. Once you reboot into safe mode run it and clear all graphics drivers (AMD, Intel and Nvidia) then run msconfig again and uncheck safe mode and reboot. Reinstall your display drivers for the EVGA only.

Also, to disable the iGPU set the shared memory setting to "Auto" the system will automatically disable the iGPU with this setting if a discrete GPU is detected.
Back to Top
wannagofast View Drop Down
Newbie
Newbie


Joined: 05 Aug 2016
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote wannagofast Quote  Post ReplyReply Direct Link To This Post Posted: 09 Aug 2016 at 5:57am
Originally posted by Xaltar Xaltar wrote:

Also, to disable the iGPU set the shared memory setting to "Auto" the system will automatically disable the iGPU with this setting if a discrete GPU is detected.

Enter bios and go to the Advanced page, North Bridge Configuration. Disable IGPU Multimonitor. Then Intel doesn't show up in Windows at all.
I actually had to set IGPU Multimonitor to disabled on mine, just setting shared memory to auto didn't work to disable it.
Just setting shared memory to auto would make it use my Nvidia card, but it still wanted to load a driver for Intel.

Peace    Wanna


Edited by wannagofast - 09 Aug 2016 at 6:06am
Z77 Extreme6 - i7-3770K @ 4.5 GHz - 8GB GSkill 1866
MSI GTX 970 4GD5T OC - Samsung 850 Pro 128 GB SSD
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 5000
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 09 Aug 2016 at 10:12am
I agree about all the advice about disabling the Intel graphics in the UEFI.

Both of the UEFI options listed above are set by default to the values suggested above, Share Memory is set to Auto, and IGPU Multi-Monitor is set to Disabled.

Of course the main way to enable not using the IGPU is to set Primary Graphics Adapter to PCI Express.

If a cable to a monitor is connected to the Intel graphics on the board's IO panel, the UEFI may consider that an active connection, which does not necessarily mean in use. I'm referring to Primary Graphics Adapter being set to PCI Express.

When Primary Graphics Adapter to PCI Express, IGPU Multi-Monitor must be set to Enabled to have both active.

I just remembered, on my ASRock Z170 board, with a Windows 10 fresh, not upgrade installation, I have the Intel graphics driver installed, and an Nvidia graphics driver installed. I tried using both GPUs at the same time (which works), and changed back to just using the video card.

This means I have the Intel graphics driver installed while using a video card, and I don't get any BSODs related to the Intel graphics driver. I don't have any BSODs.

I need to check the Windows 10 (fresh, not upgrade) installation on my Z77 Extreme4 board, I forget if I have the Intel graphics driver installed.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.055 seconds.