ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Z170 Gaming-ITX/ac Loses Audio on HDMI2 @ 4K
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Z170 Gaming-ITX/ac Loses Audio on HDMI2 @ 4K

 Post Reply Post Reply Page  123>
Author
Message Reverse Sort Order
hiluke View Drop Down
Newbie
Newbie


Joined: 01 Mar 2016
Location: Sydney
Status: Offline
Points: 28
Post Options Post Options   Thanks (1) Thanks(1)   Quote hiluke Quote  Post ReplyReply Direct Link To This Post Topic: Z170 Gaming-ITX/ac Loses Audio on HDMI2 @ 4K
    Posted: 21 Mar 2017 at 6:17pm
Originally posted by Stefan75 Stefan75 wrote:

Originally posted by hiluke hiluke wrote:

Originally posted by Stefan75 Stefan75 wrote:

Could you please test if you get all the color information on your display with UHD 60hz?
You can use these test patterns: http://cellarcinema.info/temp/uhdtest.zip
Open the pictures with 'right mouse button' edit on W10.
I can't get 4:4:4 with ASRock and LSPCON HDMI 2.0

Yep I'll give it a go when I get home.
EDIT:
I have tried that Quick Brown Fox picture and all of it (including the last two lines) looked like it displayed properly.
The ChromaRes only shows 4:2:2 so I assume that this means I am not getting 4:4:4 then.

I could get 4:4:4 mode on a Samsung UE48JU7580.
But I had to enable 'HDMI UHD Color' and change the HDMI input type to 'PC'

Ah!
I had HDMI UHD Color set already. My Input type was set to "HDMI 2/DVI" so that I could set "Movie" picture mode. Setting to "PC" allowed me to get 4:4:4 chroma.
I have a Samsung UA55KS8000WXXY.
Back to Top
Stefan75 View Drop Down
Newbie
Newbie
Avatar

Joined: 15 Feb 2017
Location: Switzerland
Status: Offline
Points: 80
Post Options Post Options   Thanks (0) Thanks(0)   Quote Stefan75 Quote  Post ReplyReply Direct Link To This Post Posted: 21 Mar 2017 at 4:03pm
Looks like there is a 1.65 firmware for the LSPCON.
Seems to fix some frame rate issue.
Back to Top
Stefan75 View Drop Down
Newbie
Newbie
Avatar

Joined: 15 Feb 2017
Location: Switzerland
Status: Offline
Points: 80
Post Options Post Options   Thanks (0) Thanks(0)   Quote Stefan75 Quote  Post ReplyReply Direct Link To This Post Posted: 21 Mar 2017 at 4:00pm
Originally posted by hiluke hiluke wrote:

Originally posted by Stefan75 Stefan75 wrote:

Could you please test if you get all the color information on your display with UHD 60hz?
You can use these test patterns: http://cellarcinema.info/temp/uhdtest.zip
Open the pictures with 'right mouse button' edit on W10.
I can't get 4:4:4 with ASRock and LSPCON HDMI 2.0

Yep I'll give it a go when I get home.
EDIT:
I have tried that Quick Brown Fox picture and all of it (including the last two lines) looked like it displayed properly.
The ChromaRes only shows 4:2:2 so I assume that this means I am not getting 4:4:4 then.

I could get 4:4:4 mode on a Samsung UE48JU7580.
But I had to enable 'HDMI UHD Color' and change the HDMI input type to 'PC'


Edited by Stefan75 - 21 Mar 2017 at 5:17pm
http://cellarcinema.info
Back to Top
nilsman View Drop Down
Newbie
Newbie


Joined: 23 Feb 2017
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote nilsman Quote  Post ReplyReply Direct Link To This Post Posted: 04 Mar 2017 at 2:17am
Thanks. I reinstalled Intel HD Graphics and got it semi working. Really strange as I had already reinstalled it once before and that did not help. But it's still not 100% stable... I get random audio drop outs now and again when using Spotify and Tidal (PCM). But strangely bit streaming DTS MA and TrueHD now seems to work fine. To be honest I think the Intel HD Graphics and/or LSPCON firmware needs some further developments/updates... At least it seems the LSPCON supports these formats :-)
Back to Top
hiluke View Drop Down
Newbie
Newbie


Joined: 01 Mar 2016
Location: Sydney
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote hiluke Quote  Post ReplyReply Direct Link To This Post Posted: 03 Mar 2017 at 7:17am
Originally posted by nilsman nilsman wrote:

Hi,

Can I ask if you have HD sound formats like DTS MA or Dolby TrueHD working ref:

http://forum.asrock.com/forum_posts.asp?TID=4513&PID=24255&#24255

Thanks in advance

They don't appear in the supported formats, however I am only running audio through my TV speakers at the moment, which doesn't support HD sound (DTS and Dolby Digital do work though).
Back to Top
nilsman View Drop Down
Newbie
Newbie


Joined: 23 Feb 2017
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote nilsman Quote  Post ReplyReply Direct Link To This Post Posted: 01 Mar 2017 at 6:39am
Hi,

Can I ask if you have HD sound formats like DTS MA or Dolby TrueHD working ref:

http://forum.asrock.com/forum_posts.asp?TID=4513&PID=24255&#24255

Thanks in advance
Back to Top
Stefan75 View Drop Down
Newbie
Newbie
Avatar

Joined: 15 Feb 2017
Location: Switzerland
Status: Offline
Points: 80
Post Options Post Options   Thanks (0) Thanks(0)   Quote Stefan75 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Feb 2017 at 8:24pm
Originally posted by hiluke hiluke wrote:

Originally posted by Stefan75 Stefan75 wrote:

Could you please test if you get all the color information on your display with UHD 60hz?
You can use these test patterns: http://cellarcinema.info/temp/uhdtest.zip
Open the pictures with 'right mouse button' edit on W10.
I can't get 4:4:4 with ASRock and LSPCON HDMI 2.0

Yep I'll give it a go when I get home.
EDIT:
I have tried that Quick Brown Fox picture and all of it (including the last two lines) looked like it displayed properly.
The ChromaRes only shows 4:2:2 so I assume that this means I am not getting 4:4:4 then.

Thanks for checking...
ChromaRes.png... I also get 4:2:2 only
TextTest_1920x1080.png... red/yellow text is not vibrant, red/blue text font not pixel perfect
TintBlueRGB.PNG... the word red/magenta looks like 3D

My setup:
J3455-ITX FW 1.2
LSPCON FW 1.61
Club3D 3m 4K HDMI cable
Philips 43PUS6101/12 (HDMI 3 4:2:2/4:4:4 enabled)

I'm trying to get Intel to expand the features of the HD graphics control panel (force YCbCr 4:4:4).
Please post too ;)

cu


Edited by Stefan75 - 24 Feb 2017 at 8:31pm
Back to Top
hiluke View Drop Down
Newbie
Newbie


Joined: 01 Mar 2016
Location: Sydney
Status: Offline
Points: 28
Post Options Post Options   Thanks (1) Thanks(1)   Quote hiluke Quote  Post ReplyReply Direct Link To This Post Posted: 24 Feb 2017 at 6:15am
Originally posted by Stefan75 Stefan75 wrote:

Could you please test if you get all the color information on your display with UHD 60hz?
You can use these test patterns: http://cellarcinema.info/temp/uhdtest.zip
Open the pictures with 'right mouse button' edit on W10.
I can't get 4:4:4 with ASRock and LSPCON HDMI 2.0

Yep I'll give it a go when I get home.
EDIT:
I have tried that Quick Brown Fox picture and all of it (including the last two lines) looked like it displayed properly.
The ChromaRes only shows 4:2:2 so I assume that this means I am not getting 4:4:4 then.


Edited by hiluke - 24 Feb 2017 at 4:34pm
Back to Top
Stefan75 View Drop Down
Newbie
Newbie
Avatar

Joined: 15 Feb 2017
Location: Switzerland
Status: Offline
Points: 80
Post Options Post Options   Thanks (0) Thanks(0)   Quote Stefan75 Quote  Post ReplyReply Direct Link To This Post Posted: 23 Feb 2017 at 4:07pm
Could you please test if you get all the color information on your display with UHD 60hz?
You can use these test patterns: http://cellarcinema.info/temp/uhdtest.zip
Open the pictures with 'right mouse button' edit on W10.
I can't get 4:4:4 with ASRock and LSPCON HDMI 2.0
Back to Top
hiluke View Drop Down
Newbie
Newbie


Joined: 01 Mar 2016
Location: Sydney
Status: Offline
Points: 28
Post Options Post Options   Thanks (1) Thanks(1)   Quote hiluke Quote  Post ReplyReply Direct Link To This Post Posted: 23 Feb 2017 at 6:05am
Happy to report that it has been over 8 days now without any issues.
Display has come back every time after monitor sleeping, and no audio loss.
Think it might finally be working! :-)
HDMI2 3840 ? 2160 at 60Hz.
HDMI2 FW version 1.61
BIOS 7.10
Windows 10 64-bit
Intel Graphics 15.45.14.4590 (direct from Intel website, not ASRock)
Back to Top
 Post Reply Post Reply Page  123>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.063 seconds.