ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - CSM/MBR boot on Taichi
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

CSM/MBR boot on Taichi

 Post Reply Post Reply
Author
Message
claude.rivet View Drop Down
Newbie
Newbie


Joined: 11 Feb 2017
Location: Montreal
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote claude.rivet Quote  Post ReplyReply Direct Link To This Post Topic: CSM/MBR boot on Taichi
    Posted: 11 Feb 2017 at 4:46am
Hello,

I am trying to setup my BIOS for CSM/MBR booting rather than UEFI, it is required by Grub4dos and I need that bootloader.

I cannot find where I can specify if boot is UEFI or CSM/MBR, anyone can help?

Thanks, regards
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 5003
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 11 Feb 2017 at 9:02am
Originally posted by claude.rivet claude.rivet wrote:

Hello,

I am trying to setup my BIOS for CSM/MBR booting rather than UEFI, it is required by Grub4dos and I need that bootloader.

I cannot find where I can specify if boot is UEFI or CSM/MBR, anyone can help?

Thanks, regards


Very simple answer. With CSM enabled (the default setting) you will get MBR formatting and booting, at least that is how it works in Windows. I don't think it will be any different with any version of Linux.

With CSM enabled, all the sub-options will be set to Legacy Only, which will cause MBR booting.

Setting CSM to disabled, or with CSM enabled, setting the Launch Storage OpROM policy to UEFI Only, causes GPT booting/formatting. The terms MBR and GPT are not mentioned, but I assure you that is how it works.

ASRock always set the default value of the CSM option to Enabled, and the CSM sub-options to Legacy Only. That always causes MBR formatting and booting, the default behavior when CSM is enabled.
Back to Top
claude.rivet View Drop Down
Newbie
Newbie


Joined: 11 Feb 2017
Location: Montreal
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote claude.rivet Quote  Post ReplyReply Direct Link To This Post Posted: 14 Feb 2017 at 11:04pm
Thanks!

Back to Top
CPL0 View Drop Down
Newbie
Newbie


Joined: 13 Feb 2017
Status: Offline
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote CPL0 Quote  Post ReplyReply Direct Link To This Post Posted: 15 Feb 2017 at 1:15am
Disable fast boot and enable CSM


You could press F11 before BIOS posts to get the boot selection menu.


2 disk's shown here with a choice of either legacy (in red box) or UEFI boot.  Choose legacy. Note that with CSM enabled and legacy devices (storage / graphics) one can still boot a GPT disk.

Personally I haven't used MBR partitioning on internal drives for years but from the sound of your other post it appears you have a GPT disk. The GPT contains a protective first sector that reports to any legacy system expecting MBR that the disk is fully used. If it's a disk you do not want to keep any data from then you could clear the first sector and create an MBR there instead.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.059 seconds.