ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Enable vt-d on J3455B-ITX
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Enable vt-d on J3455B-ITX

 Post Reply Post Reply
Author
Message
compcj View Drop Down
Newbie
Newbie


Joined: 01 Apr 2017
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote compcj Quote  Post ReplyReply Direct Link To This Post Topic: Enable vt-d on J3455B-ITX
    Posted: 08 Apr 2017 at 8:56pm
Intel J3455 has the vt-d function(which is the main reason I chose) according to ark.intel.com,
however there seems no vt-d option in Asrock J3455B-ITX BIOS settings,

According to an existing post:
http://forum.asrock.com/forum_posts.asp?TID=3875&PN=1&title=enable-vtd-on-j3455itx

Another asrock J3455 build "J3455-ITX" doesn't have vt-d support at first, but then got a 1.11 BIOS patch to fix, while the latest BIOS for J3455B-ITX is still 1.10, which is the initial one.

I've contacted Asrock support by filling online forms, but got no response till now.

I wonder if  there're any options to merge the patch in 1.20 BIOS of J3455-ITX with 1.10 BIOS of J3455B-ITX to enable VT-d? Or did anyone receive patched BIOS for J3455B-ITX from asrock tech support?

Thank you.




Edited by compcj - 09 Apr 2017 at 4:10am
Back to Top
compcj View Drop Down
Newbie
Newbie


Joined: 01 Apr 2017
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote compcj Quote  Post ReplyReply Direct Link To This Post Posted: 10 Apr 2017 at 7:25pm
So I'm the only one to have the problem? :(
Back to Top
new2asrock View Drop Down
Newbie
Newbie


Joined: 21 Mar 2017
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote new2asrock Quote  Post ReplyReply Direct Link To This Post Posted: 02 May 2017 at 12:15am
Hi,

No you're not, a new BIOS version would be nice as I experience stability issues.

I'm using this motherboard as a Proxmox VE server.

Also I noticed that each time the MB is powered off and the power supply is disconnect from the wall plug, the BIOS is reseted to default at the next start, even date and time are reseted.
(CMOS battery is ok)


Rgds


Edited by new2asrock - 02 May 2017 at 12:16am
J3455B
Back to Top
new2asrock View Drop Down
Newbie
Newbie


Joined: 21 Mar 2017
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote new2asrock Quote  Post ReplyReply Direct Link To This Post Posted: 06 May 2017 at 6:13pm
Hi,

I found this thread :

https://forums.tweaktown.com/asrock/64652-asrock-j3455b-itx-support-vt.html

about a 1.15 BIOS beta version.

I applied it, Intel vt-d is now available.

It also appears to solve boot issues with EUFI OS.

However, would it be possible to have an official one ?

Thanks,

Rgds
J3455B
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 2628
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 09 May 2017 at 4:13pm

Dear New2asrock,

 

Thank you for contacting ASRock.

 

We have added the Intel VT-d support in our latest production BIOS P1.20.

Please download the BIOS from ASRock website.

http://www.asrock.com/mb/Intel/J3455B-ITX/?cat=Download&os=BIOS

 

Thank you!

Yours truly,

ASRock TSD

Back to Top
new2asrock View Drop Down
Newbie
Newbie


Joined: 21 Mar 2017
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote new2asrock Quote  Post ReplyReply Direct Link To This Post Posted: 16 May 2017 at 6:07pm
Dear ASRock TSD,

Thanks for this, downloaded and applied with success.

Let's see.

Best regards
J3455B
Back to Top
mdn15 View Drop Down
Newbie
Newbie


Joined: 05 Jan 2018
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote mdn15 Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jan 2018 at 6:42am
Dear ASRock TSD,

I have tried both P1.20 and P1.30 on this board (J3455B-ITX).  I see the VT-d option in the BIOS and enable it.  However when I passthrough a device in ESXI, VT-d does not appear to properly apply.  I have tried both ESXI 6.0 an 6.5.

What can I do to get VT-d to properly work on this board?

Thanks
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.094 seconds.