ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - B350 Pro4 Keyboard not working outside BIOS
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

B350 Pro4 Keyboard not working outside BIOS

 Post Reply Post Reply
Author
Message
TMDave View Drop Down
Newbie
Newbie


Joined: 19 May 2017
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote TMDave Quote  Post ReplyReply Direct Link To This Post Topic: B350 Pro4 Keyboard not working outside BIOS
    Posted: 19 May 2017 at 6:31pm
Hi all,

I just bought an Asrock Pro4 B350 board to pair with a Ryzen 1600 as an upgrade, since I've put it into my system i need to repair windows on bootup but can't as my keyboard stops working once windows tries to boot to repair.

My keyboard works in BIOS just not windows so I can't start the repair- I wasn't sure if this was an issue with drivers or how to go about fixing it.

Thanks!
Back to Top
MisterJ View Drop Down
Groupie
Groupie


Joined: 19 Apr 2017
Status: Offline
Points: 682
Post Options Post Options   Thanks (0) Thanks(0)   Quote MisterJ Quote  Post ReplyReply Direct Link To This Post Posted: 20 May 2017 at 3:03am
TMDave, what version of Windows is on your system?  Is your KB/Mouse wireless, USB or PS-2?  Can you boot into Safe Mode?  You may need to reinstall Windows.  Enjoy, John.
Back to Top
Goxilih View Drop Down
Newbie
Newbie


Joined: 20 May 2017
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote Goxilih Quote  Post ReplyReply Direct Link To This Post Posted: 20 May 2017 at 3:30pm
I have same problem, i try to install Windows 7, usb mouse and keyboard, atm i Will buy ps/2 keyboard and try cause everything i tried doesn't resovle my problem, in bios everything works fine, Motherboards ab350 pro4 ryzen 5 1600
Back to Top
Synthetic1101 View Drop Down
Newbie
Newbie


Joined: 24 May 2017
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Synthetic1101 Quote  Post ReplyReply Direct Link To This Post Posted: 24 May 2017 at 7:16am
Having the same issue, has anyone found a solution to the problem yet?
Back to Top
clubfoot View Drop Down
Newbie
Newbie
Avatar

Joined: 28 Mar 2016
Location: Canada
Status: Offline
Points: 241
Post Options Post Options   Thanks (0) Thanks(0)   Quote clubfoot Quote  Post ReplyReply Direct Link To This Post Posted: 24 May 2017 at 7:30am
have you tried the other usb ports 3 or 2?
Back to Top
ronniedude View Drop Down
Newbie
Newbie


Joined: 20 May 2017
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote ronniedude Quote  Post ReplyReply Direct Link To This Post Posted: 24 May 2017 at 3:17pm
OMG GUYS I CAN HELP HERE!!!

Okay so I had the same problem, I had windows 7 on a prior mobo/cpu and i didn't feel like reinstalling anything, so what I had to do was borrow a ps/2 keyboard from a friend...

(if you need to, go to a local computer shop and ask if you can buy/borrow an old one they are simply outdated so they just might give it to you)

Once I had the ps/2 keyboard, I loaded up a portable linux distro and placed the asrock beta win7 usb drivers in my user>desktop folder. (I have an AB350M Pro4) and I got the beta driver from here: http://www.asrock.com/MB/AMD/AB350M%20Pro4/index.asp#osW764 )

Once it was on my desktop, I loaded up win7, navigated with the ps/2 keyboard to the device manager and selected the unknown peripherals with a yellow exclamation mark next to them and pointed it to the folder with the drivers.

With all the usb drivers loaded in now it works great for mostly. (theres this weird bug where the usb's stop working after sleep mode, oh well, beta drivers :P
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.

This page was generated in 0.031 seconds.