ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X370 Fatal1ty - Cannot create RAID using RCADM
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X370 Fatal1ty - Cannot create RAID using RCADM

 Post Reply Post Reply
Author
Message
XyrO View Drop Down
Newbie
Newbie
Avatar

Joined: 31 May 2017
Location: Paris
Status: Offline
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote XyrO Quote  Post ReplyReply Direct Link To This Post Topic: X370 Fatal1ty - Cannot create RAID using RCADM
    Posted: 31 May 2017 at 4:50pm
Hello everybody.

I'm in a trouble while trying to create a RAID for my operating system with my new motherboard. I think my disk are fine.

If i create those disk using the legacy tools it works, but i can't find the RAID drive while installing Windows 10 (I have a USB stick with those specific drivers...)

When i'm trying to use the 2nd way to create the result of the command rcadm -M -qa is :

no controllers, arrays, or disks supplied try -qa instead 


Here is an image of the error





here is the document i used : http://asrock.nl/downloadsite/Manual...K4/English.pdf


I'm trying to make a RAID 0 with 0 SSD of 120Gb (I want the RAID 0 to aggregate disk space, i'm well aware of how it works).

Another thing, in the document provided by Asrock to create the RAID, they ask us (page 10) to set the ?nboard RAID 3TB+ Unlocker??option to "UEFI Mode For GPT Partition" but i can't find those option. I'm using the lastest bios firmwmare available AKA version 2.40


To resume : 
-Using legacy mode to create Raid it seems to work but the driver seems not to work on Windows 10 (I tried a few diff矇rents)
-Using UEFI boot and rcadm i can't find controller/array or disk ...

Seems using UEFI and rcadm could result in a faster boot so i'd like to use this. But if anyone get some working driver for the Legacy option I could use it.


If anybody have any tips regarding my issue it would be awesome.
I wish to RAID
Back to Top
XyrO View Drop Down
Newbie
Newbie
Avatar

Joined: 31 May 2017
Location: Paris
Status: Offline
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote XyrO Quote  Post ReplyReply Direct Link To This Post Posted: 31 May 2017 at 7:49pm
I'm the only one having issue with RAID around? I saw somewhere that doing a diskpart on the disk could help. I will try this later this day and give some input.
I wish to RAID
Back to Top
Pissedoffcil View Drop Down
Newbie
Newbie


Joined: 31 May 2017
Location: Canada
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Pissedoffcil Quote  Post ReplyReply Direct Link To This Post Posted: 31 May 2017 at 10:28pm
Hello Xyro,
You are not alone although my problem is different and it occurs on an AB350 Pro4. My issue is that I can't create the RAID array in the bios config utility. That tool only detects one of my drives for some reason so I'm stuck. The second way also yields an "empty response"...

When using the first method, did you try to load the driver from your usb stick manually when in the drive selection dialog?
Back to Top
XyrO View Drop Down
Newbie
Newbie
Avatar

Joined: 31 May 2017
Location: Paris
Status: Offline
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote XyrO Quote  Post ReplyReply Direct Link To This Post Posted: 31 May 2017 at 11:00pm
Hello Pissedoffcil

Yes but it didn't work sadly.

When i  search for the drivers Windows10 didn't find any compatible driver, but i had a tons of drivers (for SATA Controllers & RAID) which were not compatible. I tried those also but i didn't work either.

If someone get some driver (maybe those from the CD where not the good one or i choose the wrong one) for 64 bits Windows10 OS i could give another try later this day.
I wish to RAID
Back to Top
Pissedoffcil View Drop Down
Newbie
Newbie


Joined: 31 May 2017
Location: Canada
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Pissedoffcil Quote  Post ReplyReply Direct Link To This Post Posted: 31 May 2017 at 11:31pm
Did you try to get those from AMD's all-in-one driver pack?
Back to Top
XyrO View Drop Down
Newbie
Newbie
Avatar

Joined: 31 May 2017
Location: Paris
Status: Offline
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote XyrO Quote  Post ReplyReply Direct Link To This Post Posted: 31 May 2017 at 11:43pm
I don't think so i'll give it a try this ! Thanks for the input, i'll let you know.
I wish to RAID
Back to Top
Pissedoffcil View Drop Down
Newbie
Newbie


Joined: 31 May 2017
Location: Canada
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Pissedoffcil Quote  Post ReplyReply Direct Link To This Post Posted: 01 Jun 2017 at 12:44am
See how effed up my drives are in Windows... I have the feeling that there is some residue RAID data from the previous install which could explain why the second drive isn't picked up by the BIOS and why my 256Gb drive is seen as a 512 Gb with an extra 256Gb filled...

https://1drv.ms/i/s!AtVjQqdqkuwH3VnrE6brncgOJ8OM
Back to Top
XyrO View Drop Down
Newbie
Newbie
Avatar

Joined: 31 May 2017
Location: Paris
Status: Offline
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote XyrO Quote  Post ReplyReply Direct Link To This Post Posted: 01 Jun 2017 at 7:04pm
Ok so it worked.

I created the raid using the legacy way (not using UEFI and rcadm). And i used the drivers called RAID bottom from the all in one package.

But now i have a weird issue. When i turn my computer OFF, the system shutdown, but the motherboard, fan and leds are still up&running. I have to push the power button to turn off the computer completely. Any idea?
I wish to RAID
Back to Top
Pissedoffcil View Drop Down
Newbie
Newbie


Joined: 31 May 2017
Location: Canada
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Pissedoffcil Quote  Post ReplyReply Direct Link To This Post Posted: 02 Jun 2017 at 12:26am
Good to hear and you should probably start a new thread for the new issue.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 36.161 seconds.