ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - M.2 slot problem (AB350 Gaming K4)
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

M.2 slot problem (AB350 Gaming K4)

 Post Reply Post Reply
Author
Message
quesinckl View Drop Down
Newbie
Newbie


Joined: 12 May 2017
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote quesinckl Quote  Post ReplyReply Direct Link To This Post Topic: M.2 slot problem (AB350 Gaming K4)
    Posted: 20 Jun 2017 at 2:59pm
The uefi could not detect the SSD installed in the first m.2 slot, but only in the second m.2 slot. 

I am using Samsung 850 evo on Win10, remember BIOS 2.50 maybe.
Back to Top
lowdog View Drop Down
Newbie
Newbie


Joined: 16 Apr 2017
Location: Australia
Status: Offline
Points: 194
Post Options Post Options   Thanks (0) Thanks(0)   Quote lowdog Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2017 at 5:54pm
Drives connected to M.2 slot 1 disappear on both X370 Taichi and Fat Pro Gaming for no apparent reason (Intel M.2 1TB SSD 540s Series)......either a hardware fault with the board or bios issue??????????

Who Knows????

All I know is it's giving me the SHIIIIIITS!!!!!

Edited by lowdog - 23 Jun 2017 at 6:01pm
X399 Fat Pro Gaming bios 3.10 - TR4 1900X - 64GB G-SKILL TridentZ F4-3200C14Q-64GTZ @ 3133MHz - Vega 64 AIO with EK block - WC Custom loop - 1500W Silverstone PSU - yay
Back to Top
Jm62383 View Drop Down
Newbie
Newbie


Joined: 03 Apr 2017
Location: White Cloud, MI
Status: Offline
Points: 87
Post Options Post Options   Thanks (0) Thanks(0)   Quote Jm62383 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2017 at 10:39pm
Slot 1 is for a PCI-E M.2....SLot 2 is for SATA..You must have a Sata M.2 and thats why it works in slot 2.
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2017 at 10:41pm
Originally posted by quesinckl quesinckl wrote:

The uefi could not detect the SSD installed in the first m.2 slot, but only in the second m.2 slot. 

I am using Samsung 850 evo on Win10, remember BIOS 2.50 maybe.


You have the AB350 Gaming K4 board, and have a Samsung M.2 850 EVO, which is a SATA M.2 SSD.

Checking your board's specs, from the Storage section:

1 x Ultra M.2 Socket (M2_1), supports M Key type 2242/2260/2280 M.2 PCI Express module up to Gen3 x4 (32 Gb/s) (with Ryzen Series CPU) or Gen3 x2 (16 Gb/s) (with A-Series APU)

1 x M.2 Socket (M2_2), supports M Key type 2230/2242/2260/2280/22110 M.2 SATA3 6.0 Gb/s module

http://www.asrock.com/mb/AMD/Fatal1ty%20AB350%20Gaming%20K4/index.asp#Specification

The M2_1 slot only supports PCIe M.2 SSDs, it does not support SATA M.2 SSDs.

The M2_2 slot only supports SATA M.2 SSDs.

This explains why an M.2 SATA 850 EVO is only detected in the M2_2 slot.

Not all M.2 slots support both types of M.2 SSDs. Some boards have M.2 slots that support both types, but that is not true for every board. An M.2 slot that supports both PCIe and SATA M.2 SSDs must have the slot connected to both the PCIe lanes in the CPU or chipset, and the SATA resources in the chipset, and be able to detect the type of M.2 SSD being used. That adds to the complexity of the board, and its cost.

We really must be careful when checking the specs of a board, to be sure we understand its capabilities and limitations.


Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 2804
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jun 2017 at 5:19pm
Dear quesinckl,

Greetings, this is ASRock TSD.


With regard to the Fatal1ty AB350 Gaming K4 specification, Ultra M.2 Socket (M2_1) supports for "PCIE interface device", M.2 Socket (M2_2) supports for "SATA interface device".

According to the HDD specification, the Samsung 850 Evo which is a SATA type device.

So, this HDD can only be detected in M2_2 socket instead of M2_1 socket.

Here is detailed Spec. of Samsung 850 EVO SSD,


Thanks!

All the best,
ASRock TSD

Back to Top
punkdawa View Drop Down
Newbie
Newbie
Avatar

Joined: 23 Jun 2017
Location: Indonesia
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote punkdawa Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jun 2017 at 11:41pm
Can you boot using that Intel 540s Series M.2 2280 SATA3 on M.2 Ultra slot? Sorry for OOTing, my thread don't have any answer Unhappy
Back to Top
jljnrtgk5 View Drop Down
Newbie
Newbie


Joined: 20 Aug 2017
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote jljnrtgk5 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Aug 2017 at 10:34am
Hey may I ask if these slot would perform differently when it comes to a display card?
I installed the display card GTX460, very old one, on the steel PCI slot and there was nothing shown on the screen, not even the bios.
After that I tried installing the display card on the bottom PCI slot and it works fine.
So is there any problem with the compatibility of the steel slot to the old display card? or it's normal to have old display card on the bottom PCI slot???
Thank you in advance.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.