ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X370 Taichi - bluetooth dead but WIFI works???
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X370 Taichi - bluetooth dead but WIFI works???

 Post Reply Post Reply Page  <123
Author
Message
ChosenBC View Drop Down
Newbie
Newbie
Avatar

Joined: 31 Oct 2017
Location: MA, USA
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote ChosenBC Quote  Post ReplyReply Direct Link To This Post Posted: 31 Oct 2017 at 10:48pm
I know this a day late and a dollar short, but I have seen this on Dell Laptops too. I find the most common cause is the WiFi/BT Card.
Make sure the Computer is off, remove the screw holding it in place, remove the card and make sure the metal contacts are clean, then reinsert the card and screw back in place. most of the time this will resolve it more permanently unless you get up and go with your desktop often, then it may come slightly loose or change position in it's slot causing the issue to reoccur.
Back to Top
Zendal View Drop Down
Newbie
Newbie


Joined: 24 Feb 2018
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Zendal Quote  Post ReplyReply Direct Link To This Post Posted: 16 Mar 2018 at 5:41pm
This issue still exists. Bios 4.40
Back to Top
valerian View Drop Down
Newbie
Newbie


Joined: 15 Nov 2018
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote valerian Quote  Post ReplyReply Direct Link To This Post Posted: 15 Nov 2018 at 4:02pm
Since several weeks I have the integrated Bluetooth adapter that stoped working. It is no more listed in the Device Manager. At its place is a unrecognized USB device.
I tried many workaround and finally succeed to make it working.
The motherboard is an ASROCK X370 Taichi.
Here is the list of all my changes that may not be all needed.
1) Update of the bios to P4.80
2) In the bios I set the BT adapter to ON.
3) After booting the computer I installed the Intel BT driver V20.70.0.4
4) In the device manager I install manually a Microsoft Wireless Wifi router.
5) Then I shut down the computer and remove the power for 5 minutes.
6) At start up I change the BT option in the bios to AUTO.
Miracle, after booting, in the device manager the BT adapter is recognized!
Back to Top
alee685 View Drop Down
Newbie
Newbie


Joined: 06 Dec 2018
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote alee685 Quote  Post ReplyReply Direct Link To This Post Posted: 06 Dec 2018 at 11:36am
I have this same motherboard and I just wanted to register an account to tell you thank you and that this worked!

On a side note, does anyone know where the bluetooth/wifi card is on this board so if we need to upgrade it in the future we can?
Back to Top
valerian View Drop Down
Newbie
Newbie


Joined: 15 Nov 2018
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote valerian Quote  Post ReplyReply Direct Link To This Post Posted: 06 Dec 2018 at 3:56pm
My pleasure, I passed many hours before finding that trick.My Bluetooth link is still working hopefully
The Bluetooth/Wifi board is removable as I was able to change it under warranty (the 5 GHz was not working). You need to remove the board from the computer to access the screws on the bottom side. Removing the white plastic cover above the rear connectors is needed in the process.
But I do not know if the BT/Wifi board form factor is standard.
Back to Top
 Post Reply Post Reply Page  <123
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.031 seconds.