ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - SOLVED-Fatal1ty Z270 Gaming-ITX/ac Dual 4K Support
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

SOLVED-Fatal1ty Z270 Gaming-ITX/ac Dual 4K Support

 Post Reply Post Reply Page  12>
Author
Message
johnboy View Drop Down
Newbie
Newbie


Joined: 25 Jul 2017
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnboy Quote  Post ReplyReply Direct Link To This Post Topic: SOLVED-Fatal1ty Z270 Gaming-ITX/ac Dual 4K Support
    Posted: 25 Jul 2017 at 10:22am
I really need your help before ordering this motherboard. I have 2 4K monitors 3840x2160@60Hz.
Does this motherboard support dual 4K&60hz using only the iGPU (i7 7700)?
I can use the onboard DisplayPort + Thunderbolt/DisplayPort adapter or DisplayPort + HDMI 2.0 (the monitor has a HDMI 2.0 port as well). Any chance to get this working or I'll need a discrete GPU?
This computer isn't meant for gaming and I don't want to put more heat inside the case with a discrete GPU and a bigger PSU besides the case I have in mind is really tiny and I won't have any room for those things.
Can anyone help me? Thanks in advance.


Edited by johnboy - 29 Aug 2017 at 4:20am
Back to Top
johnboy View Drop Down
Newbie
Newbie


Joined: 25 Jul 2017
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnboy Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2017 at 10:16pm
Anyone? Please?
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 2092
Post Options Post Options   Thanks (1) Thanks(1)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 18 Aug 2017 at 3:49pm

Dear Johnboy,

 

Thank you for contacting ASRock.

 

Regarding your question, Fatal1ty Z270 Gaming-ITX/ac can support dual 4K 3840x2160@60Hz with DisplayPort and HDMI 2.0.

 

Thank you!

Yours truly,

ASRock TSD



Edited by ASRock_TSD - 22 Aug 2017 at 3:06pm
Back to Top
johnboy View Drop Down
Newbie
Newbie


Joined: 25 Jul 2017
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnboy Quote  Post ReplyReply Direct Link To This Post Posted: 19 Aug 2017 at 10:08am
Thanks for your response.
It's really works, just tested, but I wonder why it's not working with 1 monitor on display port and another monitor on usb-c/thunderbolt port (with usb-c/display port adapter).
This configuration works on lenovo P50, is there any reason why isn't working with Fatality z270 Gaming-ITX motherboard? Bios is updated to version 2.30.
Thanks in advance.



Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 5001
Post Options Post Options   Thanks (1) Thanks(1)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 19 Aug 2017 at 10:45am
Originally posted by johnboy johnboy wrote:

Thanks for your response.
It's really works, just tested, but I wonder why it's not working with 1 monitor on display port and another monitor on usb-c/thunderbolt port (with usb-c/display port adapter).
This configuration works on lenovo P50, is there any reason why isn't working with Fatality z270 Gaming-ITX motherboard? Bios is updated to version 2.30.
Thanks in advance.





You'll need to be much more specific about the Lenovo P50 laptop. There are multiple configurations of that PC. They can have Xeon processors, with a slightly different Intel iGPU, and have either an Nvidia Quadro 1000M or 2000M GPU. One of the 4K video outputs on the P50 is Thunderbolt 3, not USB C.

Do you have a Thunderbolt card in your Z270 board?
Back to Top
johnboy View Drop Down
Newbie
Newbie


Joined: 25 Jul 2017
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnboy Quote  Post ReplyReply Direct Link To This Post Posted: 22 Aug 2017 at 1:14pm
The Lenovo P50 has a i7 6820HQ,  Intel HD Graphics 530, a Quadro M1000M and has a TB3 port.
The Fatality z270 itx has a TB3 port/controller as well. The USB-C/DisplayPort adapter which I'm using maybe isn't compatible with the AsRock chip because in theory it should be working right?
When I enable only the iGPU on the Lenovo everything keeps working, but when I try the same on the motheboard I can't even get a signal to the monitor on the TB3 port.



Edited by johnboy - 22 Aug 2017 at 1:14pm
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 2092
Post Options Post Options   Thanks (1) Thanks(1)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 22 Aug 2017 at 3:10pm

Dear Johnboy,

 

Thank you for your reply.

 

Please make sure your thunderbolt is enabled in BIOS setting, and thunderbolt driver has installed.

BIOS Path: Advanced > Intel Thunderbolt > Enable

Press F10 to save BIOS setting.

Driver download link: http://www.asrock.com/MB/Intel/Fatal1ty%20Z270%20Gaming-ITXac/index.asp#osW1064

 

Thank you!

Yours truly,

ASRock TSD

Back to Top
johnboy View Drop Down
Newbie
Newbie


Joined: 25 Jul 2017
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnboy Quote  Post ReplyReply Direct Link To This Post Posted: 22 Aug 2017 at 8:56pm
Thunderbolt is enabled, tried all modes even the "Display Port only" but no joy. Despite of the adapter works on the Lenovo I'll try another one because I read people complaining around the same behavior with macbook pro's and they fixed using a different usb-c/display port adapter. The only problem is the "Hit and Miss" thing with money out of your pocket trying to find a compatible adapter (if that's the case).
Thanks, you guys are being really helpfull.
Back to Top
johnboy View Drop Down
Newbie
Newbie


Joined: 25 Jul 2017
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnboy Quote  Post ReplyReply Direct Link To This Post Posted: 29 Aug 2017 at 4:17am
Thanks everyone, it was the USB-C/Display Port adapter. Altough the adapter works on the Lenovo it won't  on z270 ITX thunderbolt port.  I bought a new one from Cable Matters and worked like a charm.


Edited by johnboy - 29 Aug 2017 at 4:18am
Back to Top
Stefan75 View Drop Down
Newbie
Newbie
Avatar

Joined: 15 Feb 2017
Location: Switzerland
Status: Offline
Points: 80
Post Options Post Options   Thanks (0) Thanks(0)   Quote Stefan75 Quote  Post ReplyReply Direct Link To This Post Posted: 29 Aug 2017 at 9:27pm
wow, 2x UHD60 (2x18gbit/s)... didn't expect that to work with intel onboard only
http://cellarcinema.info
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.125 seconds.