ASRock.com Homepage
Forum Home Forum Home > Gaming Zone > Gaming PC Build Advice
  New Posts New Posts RSS Feed - ASRock AB350M Pro4 Compatability RAM Issues.
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

ASRock AB350M Pro4 Compatability RAM Issues.

 Post Reply Post Reply
Author
Message
Woutou View Drop Down
Newbie
Newbie


Joined: 03 Sep 2017
Location: Canada
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Woutou Quote  Post ReplyReply Direct Link To This Post Topic: ASRock AB350M Pro4 Compatability RAM Issues.
    Posted: 05 Sep 2017 at 5:40am
I'd like to thank you all in advance for any help you guys could bring to my issue first off.

So here's my build;

AMD - Ryzen 3 1200 3.1GHz Quad-Core Processor

ASRock - AB350M Pro4 Micro ATX AM4 Motherboard

Ballistix Sport LT 8GB 288-Pin DDR4 SDRAM DDR4 2400

ADATA - Ultimate SU800 128GB 2.5" Solid State Drive

Western Digital - Caviar Blue 1TB 3.5" 7200RPM Internal Hard Drive

EVGA - GeForce GTX 1050 Ti 4GB SC GAMING ACX 2.0 Video Card

DEEPCOOL TESSERACT SW Mid Tower Computer Case with Side Window and 2 Blue LED Fans SGCC+PLASTIC+RUBBER COATING

EVGA - B3 450W 80+ Bronze Certified Fully-Modular ATX Power Supply

Basically my issue is that my Computer turns on stays on for about 30 seconds then it turns of for a few seconds then it will turn on again, my motherboard speaker beeps 3 times that tells me the ram isn't connecting to the mobo but I've tried multiple times to get it in but it doesn't snap into place? But it feels very snug. Any advice? Thanks!:)
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4733
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 05 Sep 2017 at 9:25am
Originally posted by Woutou Woutou wrote:

I'd like to thank you all in advance for any help you guys could bring to my issue first off.

So here's my build;

AMD - Ryzen 3 1200 3.1GHz Quad-Core Processor

ASRock - AB350M Pro4 Micro ATX AM4 Motherboard

Ballistix Sport LT 8GB 288-Pin DDR4 SDRAM DDR4 2400

ADATA - Ultimate SU800 128GB 2.5" Solid State Drive

Western Digital - Caviar Blue 1TB 3.5" 7200RPM Internal Hard Drive

EVGA - GeForce GTX 1050 Ti 4GB SC GAMING ACX 2.0 Video Card

DEEPCOOL TESSERACT SW Mid Tower Computer Case with Side Window and 2 Blue LED Fans SGCC+PLASTIC+RUBBER COATING

EVGA - B3 450W 80+ Bronze Certified Fully-Modular ATX Power Supply

Basically my issue is that my Computer turns on stays on for about 30 seconds then it turns of for a few seconds then it will turn on again, my motherboard speaker beeps 3 times that tells me the ram isn't connecting to the mobo but I've tried multiple times to get it in but it doesn't snap into place? But it feels very snug. Any advice? Thanks!:)


Your memory should be in the A2 and B2 slots. Or do you have a single 8GB DIMM? Then either A2 or B2.

If you consistently get three beeps, either the memory is not seated correctly, or it not working.

The single ended locking DIMM slots can be difficult to use for some people. Insert the memory into the slot end without the locking latch first, but don't press it all the way down. Then get the other end into the slot with the locking latch. Then with two hands, but use your fingers, press the memory into the slot. The locking latch should pop into place by itself if you have done it correctly. If you look at the memory in the slot, look at the top edge of the DIMM slot, and check the the memory is evenly seated in the slot from one end to the other.

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.

This page was generated in 0.047 seconds.