ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - New, unopened X370 Killer SLI/ac rebate failed
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

New, unopened X370 Killer SLI/ac rebate failed

 Post Reply Post Reply Page  <12
Author
Message
S_Hawking View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Sep 2017
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote S_Hawking Quote  Post ReplyReply Direct Link To This Post Posted: 17 Sep 2017 at 10:15am
I just wanted to update this thread for posterity's sake (I hate coming across dead threads that don't resolve).

Anyways, I was finally able to get my rebate registered on the site by emailing the rebate support people at rebate@asrockamerica.com. They just needed a copy of my invoice and the S/N that was being blocked. They then were able to remove the S/N from the system, and I could register. I still don't know why my S/N was already registered, but for now my issue is resolved.  
Back to Top
datonyb View Drop Down
Senior Member
Senior Member


Joined: 11 Apr 2017
Location: London U.K.
Status: Offline
Points: 2269
Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 17 Sep 2017 at 7:29pm
well thanks for finalising the thread mate

and glad you got the issue sorted
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.047 seconds.