Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Z370 Extreme4 - No BIOS LED - Nothing on Screen
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Z370 Extreme4 - No BIOS LED - Nothing on Screen

 Post Reply Post Reply
GeoD View Drop Down

Joined: 04 Dec 2017
Location: USA
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote GeoD Quote  Post ReplyReply Direct Link To This Post Topic: Z370 Extreme4 - No BIOS LED - Nothing on Screen
    Posted: 08 Dec 2017 at 11:27pm
PCPartPicker part list:

CPU: Intel - Core i5-8400 
CPU Cooler: Cooler Master - Hyper 212 EVO
Motherboard: ASRock - Z370 Extreme4 
Memory: G.Skill - Ripjaws V Series 16GB (2 x 8GB) DDR4-3000 Memory
Storage: Samsung - 850 EVO 500GB M.2-2280 Solid State Drive 
Storage: Western Digital - Caviar Blue 1TB 3.5" 7200RPM Internal Hard Drive
Video Card: Gigabyte - GeForce GTX 1080 8GB WINDFORCE OC 8G Video Card
Case: Phanteks - ECLIPSE P400 TEMPERED GLASS ATX Mid Tower Case 
Power Supply: EVGA - SuperNOVA G3 650W 80+ Gold Certified Fully-Modular ATX Power Supply  

So, I finally did it, built my first computer! I went ahead and put everything together and Friday and held my breath as I booted for the first time..... IT WORKED! All fans buzzed on, all lights worked, I even saw something on my screen!  The computer started its POST, and was at about 45% when I had to go pee. I know, I know, how could I leave the room during that very first POST?  I had been holding my pee for a long time, antsy to get the build done.  When I came back, the PC was off, and nothing was on my screen.  Since then, I have not had ANYTHING get back to my screen.  The PC still boots up, all the fans work, all components seem to be working.... but I have never gotten back to a POST or BIOS screen.  My monitor doesn't even pick anything up.

One important note to mention:  My MOBO had a red light on it next to the BIOS 1 chip, this was representing the BIOS in use.... even though it was red I researched and saw this was normal.  I have not seen that red light come on since the first POST.

I have gone through Tom's Hardware check list more times than I can count.  I have tried single stick RAM in all slots, both sticks.  I have really tried everything that I could think of, I even started from scratch yesterday.  One of my good friends who has built several PCs in the past came over and did his routine, no luck.  I just tried resetting my CMOS, and that did not boot the PC... My MOBO does not have a case speaker, I have one of those on order now.  This is my first build so I am not too familiar with troubleshooting from here, although I am relatively tech savvy and can understand a lot of what I read.

Edited by GeoD - 08 Dec 2017 at 11:29pm
Back to Top
jachary1 View Drop Down

Joined: 24 Dec 2017
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote jachary1 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Dec 2017 at 12:19am
I know this maybe too late for you but I had the same issue. I removed my Gigabyte video card and was able to use the BIOS. Afterwards I was able to replug in the Gigabyte RX580 card and use it. However I dont get the BIOS screen, it goes straight to the  windows login now.

The video ports on the MB dont show anything. Did you make progress on yours? and any tips?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.078 seconds.