ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - 1800x & x370 Taichi Freezing issue
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

1800x & x370 Taichi Freezing issue

 Post Reply Post Reply Page  123 4>
Author
Message
hav0k View Drop Down
Newbie
Newbie
Avatar

Joined: 02 Mar 2018
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote hav0k Quote  Post ReplyReply Direct Link To This Post Topic: 1800x & x370 Taichi Freezing issue
    Posted: 02 Mar 2018 at 1:44pm
Hello Everyone
 

I would very much like any support I can get in resolving this issue.

I just finished a brand new Ryzen build. It runs very well under load, but freezes randomly at idle. By "freezes" i mean it's like everything stops responding instantly, mouse doesn't move, no BSOD, no restart, no graphical artifacts. The only way out is cold reboot via the case reset button.

  • CPU: 1800x
  • MB: ASRock x370 Taichi (with latest BIOS as of now - 4.40)
  • RAM G.Skill Flare-X 3200
  • GPU: Asus ROG RX580
  • PSU: Seasonic Prime Ultra Titanium 750W

System temps are very well within normal parameters. System voltages from the PSU are rock-stable too.

This is a system which I intend to use for my daily work and stability is of utmost importance for me. I haven't overclocked anything - everything is at stock "Auto". I even down-stepped the RAM from the XMP-3200 profile to the safe JEDEC 2400Mhz.

  1. Brand new Windows 10 x64 Pro installed on a Samsung 960 Evo 256GB SSD.
  2. Latest OS updates applied.
  3. Latest drivers for the Chipset, GPU and other peripherals applied.
  4. Latest BIOS.
  5. Latest firmware for the SSD drives.
  6. Disabled PCI Express Link State Power Management (within Power Options).
  7. Disabled Hard Disk Turnoff timeout (within Power Options).
  8. Ran sfc and dism.

The funny thing is it rock-stable on all the stress tests i threw at it. 3DMark, CPU-Z, Aida64, Heaven Benchmark, and several hours of Memtest86. It's just this totally random hard lock screen freeze (or whatever you can name it) when I'm basically doing nothing - like writing in a text document or going around in the Control Panel, or even when i'm not at the computer at all. There's nothing in the Event Log (besides the improper shutdown message), no crash dumps either.


I'm very frustrated and disappointed by now. Wish I could just reproduce the issue every time that would be great and narrow-down the possible culprit, but alas, these freezes happen randomly - sometimes once a day, sometimes between minutes of each-other.

Back to Top
JohnM View Drop Down
Groupie
Groupie
Avatar

Joined: 20 Feb 2018
Location: UK
Status: Offline
Points: 262
Post Options Post Options   Thanks (0) Thanks(0)   Quote JohnM Quote  Post ReplyReply Direct Link To This Post Posted: 02 Mar 2018 at 8:24pm
I know that Linux users have problems with Ryzens freezing when idling and the fix is to disable global C states in the BIOS. AMD blames it on power supplies but any that claims to be Intel Haswell compatible should be able to output the low power the processor consumes at idle without shutting down. I thought Windows users were not supposed to have this problem. I don't have any issues with my system (details below and somewhat different from yours) but although I let it put the monitor to sleep I've changed the power profile to not let the computer sleep.
ASRock Fatal1ty AB350 ITX P4.90, AMD Ryzen 5 2400G, 2x8GB Corsair CMK16GX4M2A2666C16, 250GB Samsung 960EVO, 500GB Samsung 850EVO, 4TB WD Blue, Windows 10 Pro 64, Corsair SF450, Cooler Master Elite 110
Back to Top
hav0k View Drop Down
Newbie
Newbie
Avatar

Joined: 02 Mar 2018
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote hav0k Quote  Post ReplyReply Direct Link To This Post Posted: 02 Mar 2018 at 8:52pm
Yeah I've read all about that issue over the Internet. Seems like the low-power C6 state is causing problems in Linux. I don't know if this is the case with Windows.

I would be really surprised if the PSU is to blame. This is a premium quality unit and I hardly believe that it would shut down due to the system being "too efficient". Just the case fans alone draw enough power on the +12v lane to keep it "awake".
https://lime-technology.com/forums/topic/61767-amd-ryzen-update/

So, in my opinion, only two possibilities left:
1. The OS is not handling the low-power states very well (C6). But if this was the case we would've heard a much bigger outcry.
2. The CPU gets so under-powered in this state that it terminally shuts down. Whether it's a problem in the AMD microcode or the default BIOS values from the MB manufacturer is not clear.

I just left the system running idle with the screen not allowed to sleep. Started HWInfo and went away for half an hour. And as expected, I found the system frozen. The VID value was showing a voltage of 0.400 in it's last moments. I'm starting to convince myself that #2 would be the case...

I would like to make and experiment and disable C6, but I can't seem to find the C6 Mode option in the BIOS. I've seen on pictures that it should be under Cool'n'Quiet but I don't have it there, maybe because of a different BIOS version?
I don't want to disable Global C-States for now, because it looks like this also disables XFR (tested).


Edited by hav0k - 02 Mar 2018 at 8:52pm
Back to Top
JohnM View Drop Down
Groupie
Groupie
Avatar

Joined: 20 Feb 2018
Location: UK
Status: Offline
Points: 262
Post Options Post Options   Thanks (0) Thanks(0)   Quote JohnM Quote  Post ReplyReply Direct Link To This Post Posted: 02 Mar 2018 at 10:00pm
It probably doesn't help but in my BIOS I can find C6 Mode on the Advanced\CPU Configuration page:

  Cool 'n' Quiet
  AMD fTPM switch
  SVM Mode
  C6 Mode

ASRock Fatal1ty AB350 ITX P4.90, AMD Ryzen 5 2400G, 2x8GB Corsair CMK16GX4M2A2666C16, 250GB Samsung 960EVO, 500GB Samsung 850EVO, 4TB WD Blue, Windows 10 Pro 64, Corsair SF450, Cooler Master Elite 110
Back to Top
hav0k View Drop Down
Newbie
Newbie
Avatar

Joined: 02 Mar 2018
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote hav0k Quote  Post ReplyReply Direct Link To This Post Posted: 02 Mar 2018 at 10:01pm
Originally posted by JohnM JohnM wrote:

It probably doesn't help but in my BIOS I can find C6 Mode on the Advanced\CPU Configuration page:

  Cool 'n' Quiet
  AMD fTPM switch
  SVM Mode
  C6 Mode



Yeah, i only have the first three. My BIOS is v4.40.
Back to Top
JohnM View Drop Down
Groupie
Groupie
Avatar

Joined: 20 Feb 2018
Location: UK
Status: Offline
Points: 262
Post Options Post Options   Thanks (0) Thanks(0)   Quote JohnM Quote  Post ReplyReply Direct Link To This Post Posted: 02 Mar 2018 at 10:11pm
Again, completely different motherboard and processor, but I've had terrible problems with the equivalent version (also numbered 4.40). Updating it to the beta (4.43 in my case; 4.41 in yours) fixed everything except the Intel WiFi, which I don't use anyway. The feeling is that the 4.40 BIOS was rushed out to enable compatibility with the Raven Ridge APUs and it's badly broken in places. My only other option was the beta, which thankfully helped. At least you have more choices.
ASRock Fatal1ty AB350 ITX P4.90, AMD Ryzen 5 2400G, 2x8GB Corsair CMK16GX4M2A2666C16, 250GB Samsung 960EVO, 500GB Samsung 850EVO, 4TB WD Blue, Windows 10 Pro 64, Corsair SF450, Cooler Master Elite 110
Back to Top
hav0k View Drop Down
Newbie
Newbie
Avatar

Joined: 02 Mar 2018
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote hav0k Quote  Post ReplyReply Direct Link To This Post Posted: 02 Mar 2018 at 10:17pm
Do you by any chance have something like a "Power Supply Idle Control" option somewhere in the BIOS? Like under Advanced/Zen or something? I have a hinch...

PS: Should be right under the Global C-States option.


Edited by hav0k - 02 Mar 2018 at 10:19pm
Back to Top
Erasmus_Tycho View Drop Down
Newbie
Newbie
Avatar

Joined: 20 Jan 2018
Location: Phoenix, AZ
Status: Offline
Points: 85
Post Options Post Options   Thanks (0) Thanks(0)   Quote Erasmus_Tycho Quote  Post ReplyReply Direct Link To This Post Posted: 03 Mar 2018 at 1:43am
Hey Havok, 
there's a few things I'd try if that's what you suspect.  First I'd try to set the windows power management to the performance mode to avoid the downclocks all together.  Next, I'd manually set the voltage, you don't even need to change the clock, just manually set the voltage so it doesn't drop below the level you're suspecting is the freezing point.

I'm running the x370 Taichi with an 1800x and have zero problems... though I'm overclocking and I have always used the windows performance profile.  You're right that BIOS version 4.4 no longer has the c-state option under that menu.  I'll look through mine and take a look, it could have moved to the Zen common options.
ASRock x370 Taichi V4.4| Ryzen 1800x | 16GB x 2 DDR4 3200 (14cas) | GTX 1080 Ti K|NGP|N | WD NVMe Black 512GB | 2 x 500GB Samsung EVO 960 | Corsair HX1000 | EK Custom Loop (360mm rad + 280mm rad)
Back to Top
hav0k View Drop Down
Newbie
Newbie
Avatar

Joined: 02 Mar 2018
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote hav0k Quote  Post ReplyReply Direct Link To This Post Posted: 03 Mar 2018 at 1:59am
I have a suspicion that the C6 Mode option is actually renamed to "Power Supply Idle Control" (i might be mistaken though).
The fact is that setting it to "Low Current Idle" allows the CPU to undervolt down to 0.400v, while the "Typical Current Idle" keeps it at minimum of around 0.8v.

I'm currently running tests to see if it will freeze again, but it looks promising. Been stable for hours now.

If this fixes it, it raises several questions. Namely why is this happening in first place with stock settings, which by default should be the most stable, and second - what is this new option and why the C6 Mode is gone from the newer BIOS? I'm not going to speculate an AMD attempt to cover their problems by renaming a core processor functionality to something as ubiquitous as this, but it has crossed my mind...

I'm trying to stay away from manual (over)clocking for now, because i really like the Core Boost, the XFR and the Cool'n'Quet functionality. The system has never crashed even once on all the stress tests i've put it through.
Back to Top
Erasmus_Tycho View Drop Down
Newbie
Newbie
Avatar

Joined: 20 Jan 2018
Location: Phoenix, AZ
Status: Offline
Points: 85
Post Options Post Options   Thanks (0) Thanks(0)   Quote Erasmus_Tycho Quote  Post ReplyReply Direct Link To This Post Posted: 03 Mar 2018 at 3:29am
Valid questions... I had a hell of a time until I switched to bios version 4.4, ever since things have run as expected.  Certainly frustrating how all over the place our experiences seem to be with this chipset and CPU.
ASRock x370 Taichi V4.4| Ryzen 1800x | 16GB x 2 DDR4 3200 (14cas) | GTX 1080 Ti K|NGP|N | WD NVMe Black 512GB | 2 x 500GB Samsung EVO 960 | Corsair HX1000 | EK Custom Loop (360mm rad + 280mm rad)
Back to Top
 Post Reply Post Reply Page  123 4>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.