ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - 2200G support on Fatal1ty Gaming X
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

2200G support on Fatal1ty Gaming X

 Post Reply Post Reply Page  12>
Author
Message
brPariah View Drop Down
Newbie
Newbie


Joined: 04 Mar 2018
Location: Brazil
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote brPariah Quote  Post ReplyReply Direct Link To This Post Topic: 2200G support on Fatal1ty Gaming X
    Posted: 04 Mar 2018 at 10:31pm
Hello, I've recently acquired a whole new PC and I've decided to migrate to the AM4 platform. I've been using this PC for quite a long time and it is very stable for as long as I do not overclock it. I don't really get any blue screen or anything. However, I noticed there's a lack of support for the new Ryzen 2000s processors for my Fatal1ty motherboard.
There is no way for me to overclock my iGPU throught the bios, I've looked all over the CBS settings and there's nothing regarding the integrated GPU.
There's a bug in the Ryzen master application that does not let me overclock both the CPU and iGPU at the same time. I can only overclock one at a time. If I overclock the GPU, the CPU downclocks to @ 3.7 MhZ; on the otherhand, if I overclock the CPU, the GPU downclocks to 1.100 MHz.
By default, the iGPU has a locked set frequency of 200 MHz when I boot up Windows, it remains the same even under stress, which is too low and not its standard frequency. I have to "overclock" it in order to enable its standanrd frequency of 1.100 Mhz otherwise the iGPU would stay downclocked even under heavy load.
The voltage by default was too high, I don't exactly remember how much, but I believe it was set to 1.4 V.
THIS IS MY CONFIG: Fatal1ty X370 Gaming X (BIOS 4.50), RYZEN 2200G, Radeon Software 17.7, Crucial Sports 4 GB @ 2933 single channel.

UPDATE: I WAS ABLE TO SOLVE THE LOCKED iGPU frequency by updating the bios to the beta version (4.53 for the Fatal1ty Gaming X). Now it is boosting accordingly.
I'm not able to overclock the iGPU past 1300 MHz in the Ryzen Master Application which is extremely disappointing given that I have a mid range MB. Even at 1200 MHz it is unstable and crashes the system.
 I can't change the SOC V  in the Ryzen Master Application because it requires a restart and the system won't post.
Even after updating the bios to 4.53, I still can't find the settings to overclock the iGPU in the bios.




Edited by brPariah - 05 Mar 2018 at 12:07pm
Back to Top
JohnM View Drop Down
Groupie
Groupie
Avatar

Joined: 20 Feb 2018
Location: UK
Status: Offline
Points: 267
Post Options Post Options   Thanks (0) Thanks(0)   Quote JohnM Quote  Post ReplyReply Direct Link To This Post Posted: 04 Mar 2018 at 11:33pm
Assuming you've loaded the BIOS defaults the clocks of both the cores and the iGPU scale dynamically, depending on load, as do the voltages. While idle they consume relatively little power. If you put a heavy load on the CPU cores and the iGPU at the same time you will get less than maximum performance from both in order to keep the overall power usage somewhere close to the TDP. So, for example, the iGPU will only reach its maximum clock frequency if the CPU cores are lightly loaded. If you take manual control of the clocks and voltages you can push both outside of this envelope but you will have to deal with the extra heat produced. The controls you need are all there in the BIOS but some are somewhat hidden among the pages and pages under the Advanced heading. Ryzen Master does work but you have to set the BIOS overclocking options to their default settings first.

Your best and easiest way to get better performance out of your set-up would be to add a second RAM DIMM and run in dual channel mode.
ASRock Fatal1ty AB350 ITX P4.90, AMD Ryzen 5 2400G, 2x8GB Corsair CMK16GX4M2A2666C16, 250GB Samsung 960EVO, 500GB Samsung 850EVO, 4TB WD Blue, Windows 10 Pro 64, Corsair SF450, Cooler Master Elite 110
Back to Top
JohnM View Drop Down
Groupie
Groupie
Avatar

Joined: 20 Feb 2018
Location: UK
Status: Offline
Points: 267
Post Options Post Options   Thanks (0) Thanks(0)   Quote JohnM Quote  Post ReplyReply Direct Link To This Post Posted: 04 Mar 2018 at 11:41pm
We don't have the same motherboard, but you might find better functionality from updating your BIOS to the beta version 4.53.
ASRock Fatal1ty AB350 ITX P4.90, AMD Ryzen 5 2400G, 2x8GB Corsair CMK16GX4M2A2666C16, 250GB Samsung 960EVO, 500GB Samsung 850EVO, 4TB WD Blue, Windows 10 Pro 64, Corsair SF450, Cooler Master Elite 110
Back to Top
devoker View Drop Down
Newbie
Newbie


Joined: 05 Mar 2018
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote devoker Quote  Post ReplyReply Direct Link To This Post Posted: 05 Mar 2018 at 12:03am
Can confirm that I am having this same issue. The iGPU caps at 1100 Mhz when attempting to overclock via Ryzen Master and I could only find settings in the BIOS to delegate 2G of memory to the iGPU.
Back to Top
JohnM View Drop Down
Groupie
Groupie
Avatar

Joined: 20 Feb 2018
Location: UK
Status: Offline
Points: 267
Post Options Post Options   Thanks (0) Thanks(0)   Quote JohnM Quote  Post ReplyReply Direct Link To This Post Posted: 05 Mar 2018 at 12:17am
Originally posted by devoker devoker wrote:

I could only find settings in the BIOS to delegate 2G of memory to the iGPU.

Which BIOS? I have a different motherboard but when I changed to the beta BIOS I found that the 2 GB limit had been removed.
ASRock Fatal1ty AB350 ITX P4.90, AMD Ryzen 5 2400G, 2x8GB Corsair CMK16GX4M2A2666C16, 250GB Samsung 960EVO, 500GB Samsung 850EVO, 4TB WD Blue, Windows 10 Pro 64, Corsair SF450, Cooler Master Elite 110
Back to Top
brPariah View Drop Down
Newbie
Newbie


Joined: 04 Mar 2018
Location: Brazil
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote brPariah Quote  Post ReplyReply Direct Link To This Post Posted: 05 Mar 2018 at 12:26am
Originally posted by JohnM JohnM wrote:

Assuming you've loaded the BIOS defaults the clocks of both the cores and the iGPU scale dynamically, depending on load, as do the voltages. While idle they consume relatively little power. If you put a heavy load on the CPU cores and the iGPU at the same time you will get less than maximum performance from both in order to keep the overall power usage somewhere close to the TDP. So, for example, the iGPU will only reach its maximum clock frequency if the CPU cores are lightly loaded. If you take manual control of the clocks and voltages you can push both outside of this envelope but you will have to deal with the extra heat produced. The controls you need are all there in the BIOS but some are somewhat hidden among the pages and pages under the Advanced heading. Ryzen Master does work but you have to set the BIOS overclocking options to their default settings first.

Your best and easiest way to get better performance out of your set-up would be to add a second RAM DIMM and run in dual channel mode.


Regarding the iGPU frequency, it is LOCKED at 200 MHz. I inspected its performance with HWmonitor and even under stress the GPU frequency remains the same; if I play a game, no matter how demanding it is, the iGPU frequency will constantly be at 200 Mhz and I can even notice it by the performance (FPS). The only way for me to increase it is by manually setting it to 1100 Mhz in the Ryzen Master Application and the performance immediately improves in games (twice as much in fact), otherwise, it will stay at 200 MHz. Also, I disabled turbo boost and set a fixed CPU voltage (1.25V) and CPU frequency at 3.8 MHz. So, even when idling, my CPU runs at 3.8 MHz as is confirmed by HWmonitor. It doesn't get past 65 C under heavy loads.

If my system were not very stable under stock settings, I'd definitely heed your advice and flash the bios to the beta 4.53 version.
Back to Top
devoker View Drop Down
Newbie
Newbie


Joined: 05 Mar 2018
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote devoker Quote  Post ReplyReply Direct Link To This Post Posted: 05 Mar 2018 at 12:26am
AMD Fatal1ty AB350 Mini-ITX on 4.40.
Back to Top
devoker View Drop Down
Newbie
Newbie


Joined: 05 Mar 2018
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote devoker Quote  Post ReplyReply Direct Link To This Post Posted: 05 Mar 2018 at 12:51am
I just updated to the beta 4.43 and the CPU temperature problem fixed.
In 4.40, I was also able to OC the CPU via the BIOS and OC the iGPU via Ryzen Master.
I had to do the same thing for 4.43 because I still could not find how to OC the iGPU via the BIOS.
I would note that the 2G cap for memory delegation to the iGPU is now raised to 16 GB.
Back to Top
brPariah View Drop Down
Newbie
Newbie


Joined: 04 Mar 2018
Location: Brazil
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote brPariah Quote  Post ReplyReply Direct Link To This Post Posted: 05 Mar 2018 at 12:00pm
I've updated the bios to the beta version and it solved the locked iGPU frequency. Now it is boosting accordingly up to 1100 MHz.

Nonetheless, I'm unable to overclock the iGPU frequency past 1300 MHz. Even at 1200 MHz the system gets unstable. Anything over 1300 will immediately lock up my system. Also, I can't really change the SOC Voltage because it requires the system to restart and then the motherboard won't post (it gives two beeps) and the debug shows F7. I still can't find anywhere for me to overclock the iGPU in the bios even with the beta version.

I'll be absolutely disappointed with Asrock if I can't at least get the iGPU frequency to 1600 MHz, especially because I bought a mid range motherboard (Fatal1ty Gaming X) hoping for it to last for a future upgrade. If the support for the 2200 doesn't improve I'll return this product and buy a biostar racing gt7 instead.
Back to Top
JohnM View Drop Down
Groupie
Groupie
Avatar

Joined: 20 Feb 2018
Location: UK
Status: Offline
Points: 267
Post Options Post Options   Thanks (0) Thanks(0)   Quote JohnM Quote  Post ReplyReply Direct Link To This Post Posted: 05 Mar 2018 at 9:28pm
Originally posted by brPariah brPariah wrote:


I'll be absolutely disappointed with Asrock if I can't at least get the iGPU frequency to 1600 MHz

There are no guarantees when it comes to overclocking. I don't think your expectations are realistic. How are you cooling the processor?

I think it was the fact that the BIOS defaults were reset that unstuck it from the fixed 200 MHz.
ASRock Fatal1ty AB350 ITX P4.90, AMD Ryzen 5 2400G, 2x8GB Corsair CMK16GX4M2A2666C16, 250GB Samsung 960EVO, 500GB Samsung 850EVO, 4TB WD Blue, Windows 10 Pro 64, Corsair SF450, Cooler Master Elite 110
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.063 seconds.